FlightAware Discussions

VRS: Show both dump1090 ADSB and FA MLAT positions


#1

Here is how to show both the output of dump1090 (normal adsb positions) and FA mlat positions in VRS.

Assumed setup for this procedure:
a) PiAware 2.1-3
b) mlat-aware dump1090: either latest FA-supplied version or mutability 1.15~dev: see Note below
c) VRS version 2.2 (this will recognise mlat positions)

Note for dump1090:
Ensure that it is listening for incoming MLAT positions on port 30104. This will be automatically set when upgrading FA-supplied dump1090 from the Web Control Panel. When using dump1090-mutability, issue the below command and set "Port for Beast-format input connections” to 30104 (the previous default was 30004):


sudo dpkg-reconfigure dump1090-mutability

The above is not strictly necessary for displaying MLAT traffic in VRS but is required to view MLAT traffic on the dump1090 web interface when the instructions and port settings that appear below are followed exactly.

Instructions:
In this example, the IP address of my Pi is 10.0.1.203 and I’m naming the Location and feeds ‘LS’.

  1. Reconfigure PiAware and add a listening port to the mlat-client (the mlat client will provide positions on this port):

sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 ext_basestation,listen,30106"
sudo piaware-config -restart

  1. Add a receiver in VRS for ADS-B positions from dump1090:
    Name: (Receiver name)
    Format: AVR or Beast Raw Feed
    Location: (set this if you want receiver range plots)
    Connection type: Network
    Address: (IP address of your Pi)
    Port: 30005https://farm6.staticflickr.com/5750/21943000475_2f944cc103_b.jpg

  2. Add a receiver in VRS for MLAT positions from FA mlat-client:
    Name: (Receiver name)
    Format: Basestation
    Location: (set this if you want receiver range plots)
    Connection type: Network
    Address: (IP address of your Pi)
    Port: 30106https://farm6.staticflickr.com/5647/21945465685_9f4c204e19_b.jpg

  3. Create a merged feed and enable both single feeds from above:
    (Ignore the ‘MLAT’ column; this is probably a leftover from previous VRS versions and as far as I know not relevant any more.)
    https://farm1.staticflickr.com/652/21320286624_e35b267f85_b.jpg

  4. Add a column ‘MLAT’ to the VRS display:
    https://farm6.staticflickr.com/5804/21952769991_e80f77d4d0_c.jpg

  5. IMPORTANT: Select one of the newly created receivers on the VRS map display (Click on the Menu icon on the map, then 3rd line ‘Receiver’). Enjoy the combined display or view the individual receivers separately one at a time. Note that mlat positions are marked as such:
    https://farm6.staticflickr.com/5730/21756136169_1a6749dcb5_b.jpg

Please let me know if that works for you. Any corrections and suggestions welcome :slight_smile:


Run Run as fast as you can away from Flightaware!!
adsbreceiver + VRS - How to get setup with MLAT
more information on piaware internal web site available?
Installed dump1090-muta v1.15~dev; VRS not showing MLAT pos
Error on MLAT
mlat(15007): socket.error: [Errno 98] Address already in use
#2

Awesome. Works perfectly for me. Many thanks!


#3

Thanks for the post, I did not realize that I can integrate a MLAT-indicator in the list now. I like the idea of the indicator.

I’ve tried this, but it did not work for me. I have the latest stock Piaware/dump1090 and my MLAT port is 31003.

Is this port somehow mixed up, because it is different from yours?

But I can assign the MLAT feed in the merge options to MLAT, then it seems to work, but I think it is sometimes mixed up.


#4

Stock image doesn’t have anything configured on port 31003.


#5

Is there any way to get a version number of dump1090?

There really should be a version number that can be identified for the ‘stock version’. Am I just to blind to see?

I did update dump1090, using the option from my stats page, so it should be the latest one, but I can’t tell, because I don’t know the version.

I had a look at my notes from the past, and somewhen, I did this:

sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30004 basestation,listen,31003

I think, this was done due to a post here somewhere to get the MLAT resuls show up in VRS.

So, what to do, to straighten things out?


#6


$ dpkg -l dump1090
$ dump1090 --help    # look at the top; the version number for the FA dump1090 only started being accurate recently


sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30004 basestation,listen,31003

I think, this was done due to a post here somewhere to get the MLAT resuls show up in VRS.

So, what to do, to straighten things out?

Just run the new piaware-config command in the top post and it’ll replace your old setting.


#7

Follow my instructions and forget your old notes;)

Seriously, it does not matter which port numbers you specify (and you can make up your own scheme if you like) but everything has to correspond to each other: mlat-client beast output (either 30004 or 30104) has to correspond with dump1090 input and mlat-client ext_basestation listening port (either 31003 or 30106) has to correspond with what you specify in VRS.


#8

hi mgunther,

very good - as always from your side!

as the fa forum search function is suboptimal (as with nearly all forums) - why don’t you open a thread called ‘mgunthers tips around ads-b’ where they all are aggregated or at least linked from. this would be simply great!

thanx
tom


#9

I haven’t configured anything out of the ordinary with this setup

  • Dump1090_mut 1.15
  • Piaware (latest)
  • VRS (latest)

Now my question. Why are my “format to port” settings completely opposite of what Mgunther has in his setup.
I have never really noticed until I read this post. I have had the mlat and position data separated in VRS for a while now with no problems.
I still have no problems with the latest port configurations following the release of Piaware 2.1-3.
The difference is my Mlat (30106) runs on "basestation"
and my position data (30005) runs on “AVR or Beast”

It runs great, and shows MLAT planes in the VRS list settings. Just curious how this is happening.
It will not work for me with the formats swapped.


#10

hello franzpo,

they changed because of unwanted mlat forwarding - see this thread for more information about: http://discussions.flightaware.com/ads-b-flight-tracking-f21/piaware-2-1-3-released-t36047.html.


#11

I have read through the posts several times. This is how I made the changes to make the newest version of Piaware work with Dump1090-mutability and show Mlat in VRS.

I have not come up with any commands on my own. I mostly clip and paste the commands these guys post.
If everything works with this configuration then what would I have had to do to end up with this working the way it is?


#12

hmmm - don’t know if i understood your question but …

they changed the port mlat is forwarded to in piaware. if you install piaware and dump1090 newest flightaware versions normally nothing has to be changed manually as they changed ports in both apps. if you use other combinations of dump and piaware or use other software you have to change the ports so that they fit together and meet your needs.


#13

2.1-3 only changed the default port, which was used if you had not done any manual config. If you had manually changed the configuration before upgrading, the upgrade didn’t touch those settings. So long as your piaware settings match your dump1090 settings, you’re good.


#14

This is exactly what I have so I’m not sure where you are seeing a difference.


#15

And you are absolutely right. I have messed with this quite a bit today and now I am seeing cross eyed I guess.

On another note. Thank you guys for all the support you provide this forum. You, Obj, and others put a lot of time into helping people out.
I could not set this stuff up on my own without support from the forum.


#16

for some reason I am getting a connection refused to my rpi:30005


#17

Can you please explain what you are trying to do, what step you are at and where you see the connection refused message? A screenshot would be very helpful.


#18

Actually what I ended up doing was modifying the command to send the 30005 data to the VRS server instead of pulling it.


#19

So so are OK now?


#20

yeah seems to be working, thanks!