Error on MLAT

So I started out with setting the -config to feed data to VRS and it worked. Then I saw a thread (Co-Op feeds) and followed the instructions there to feed them MLAT but his killed my local VRS feed so I tried to reset it back so I could see mine own MLAT.

Since then I have not been able to see results on my Default Dump1090 page, sporadic results on my VRS. I have tried every command I have found On the forums with no improvement.

And ever since this started the Log on the ADS-B page repeats this over and over mlat(3904): Beast-format results connection with localhost:30104: [Errno 111] Connection refused

What can I do to fix this. I have very very basic command lien skills but telling me to open up “name here” will not help I just don’t know how to do it. Gotta give me the complete set of instructions.

What version of dump1090 and piaware are you running?

dump1090 --help 
dump1090-mutability --help
piaware -v

Both are the most up to date ones as I tried upgrading both to resolve the issue to no avail.

If all else fails, wipe the card and do a clean reinstall.

Yeeeaaa, thats is my worst case scenario fix.

Which version of dump1090? (mutability, flightaware?)

And what is the output of

sudo piaware-config -show

I’ll have to get that tonight. However I rebooted the Piaware about three hours ago via the internet interface on Flightaware and no longer getting errors on that log. I have to verify at home with port changes if it is forwarding malt to VRS or not.

Dump1090 is Flightaware 1.2-3 and piaware is 2.1-3

Config -show displays this,

Mlat 1

mlatResults 1

mlatResultsFormat {beast,connect,localhost:30104 basestation,listen,310003}

If your local VRS is set to port 310003 (I think you may have one too many 0’s) for MLAT then I think you should be set. If you wanted to try the Co-Op VRS in addition to local VRS, the command would be

sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 beast,connect, basestation,listen,310003"
sudo piaware-config -restart

If MLAT isn’t working with local VRS, try mgunther’s excellent tutorial:

Thanks you sir! I did add too many zeros when typing. Will try re doing ports on VRS tonight. Imma learning slowly!

Are you back online now?

Yes far as I can tell. However on my VRS I set the two feeds to merge for one output, but also allow me to select which feed so I could plot ranges. But I am noticing when I select the “merged” feed does not show the combined planes from either feed all the time. I don’t know if this is in my VRS settings (I sat it up following that other thread on doing it)

Here is my Site, you can see from your self. Piaware - MLAT is the combined “merged” feed from the other two.

So in conclusion it is working enough to make me happy a little, May buy a new antenna and get more range out of it now. If only I could reach atlanta…

Thanks again!

Mine also behaves in this manner. I don’t think there is anything wrong, I think it is the way VRS is handling the data.
However, when I am merging my Mlat and ADSB receivers in VRS it will show some as MLAT planes on the page but if I just choose the MLAT receiver to show on the map it will show a bunch more then when the ADSB receiver is merged. Make sense??