MLAT results don't show up in VRS anymore

I think there was an auto-update, and since then, I can not see MLAT in VRS anymore.

I’ve updated dump1090 and PiAware manually again, and also did the following:

sudo piaware-config -mlatResultsFormat “beast,connect,localhost:30004 basestation,listen,31003”
sudo service piaware restart

I installed two receiver in VRS:

Receiver: AVR, Port 30005
Receiver MLAT: BaseStation, Port 30003

I receive something on both receiver, but it seems to be the same:

I tried to catch up with all the MLAT-posts. Did I miss something, or is something wrong?



One of these things is not like the other… Try port 31003 in VRS :slight_smile:

Arghhh! I just think it is too warm these days! :unamused:

For sure, thanks a lot!


I’m kinda stupid on these things but how would I got about getting MLAT to show up on my VRS without messing up my other settings? I do know my VRS is using 30003 for the feed.

Did you merge the feeds together? So it will show MLAT planes and the rest? Thats what I did to show both on VRS map. Just wanted to see if others did it that way.



That is exactly what I did also. Labeled the receivers ADSB and MLAT. Have you noticed the MLATs quickly change over to the default receiver?
Mine are only showing 5-10 seconds or so.


Which version of VRS are you running ? Here I have 2.1.01579 downloaded from , it has a few more options for MLAT
explained in the Change list



Assuming the use of the same dump1090 decoder, what is the rationale for identifying a separate receiver for ADS-B and MLAT? Once I enabled MLAT forwarding on dump1090-m everything comes over the same port (30005 IIRC).

This is not the default if you are using the FA dump1090 or a recent (development) dump1090-mutability; it’s also not suitable if you want to forward port 30005 output elsewhere e.g. other feeders but exclude mlat results.