VRS preview - no MLAT (Solved)

I finally got around to installing the VRS preview on a spare computer. A couple of odd things I notice. AVR/Beast uses port 30002 instead of 30005? It defaults to 30002. I set it to 30005 and it didn’t show any aircraft. Also, now that I’m using port 30002 and plenty of aircraft are visible, the MLAT indicator in the List tab always shows “No”. This MD-88 is most likely transmitting MLAT. What am I doing wrong?


I had to run this command to get MLAT to work on VRS.

sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30004 basestation,listen,31003"

Then in VRS I had to “add” a second receiver to VRS. Then merge the feeds together. When I brought up the VRS map, I had to click merge feeds on it also. Then it showed MLAT planes and ADS-B.

Receiver: AVR, Port 30005
Receiver MLAT: BaseStation, Port 30003

Thanks for the great, detailed reply. That’s a lot of hoops to jump through! Geez. So after all that, what does the display look like? Any different? I think I’m seeing all the aircraft, just that one indicator that says “MLAT - No”.

Here is a picture I took a few days ago of my VRS map. The darker shade is MLAT. If you click on the menu tab up top of the map and click on receivers that’s where is shows me the merge two receivers together. Or you can pick the one or other. I had it running before just to show MLAT planes on VRS. Setting up the other receiver in the setting for VRS was’t to hard. Just use the same IP address and location. Just use that other port number. Then under the setting click on merge feeds and check both boxes. I’m not sure if i forgot anything or not.

Thanks again. You’re right, not so hard. I’ll give it a try.

No problem. Let me know how you make out.

I ran the command on my Pi, then changed my receiver to AVR, port 30005 - 0 aircraft. Then, I changed it to Base Btation, port 30003 and I’m seeing aircraft, but still says No MLAT. Rather than create a new receiver, I just used the default receiver and changed the options to see how each worked.

Edit: Oops. Forgot to restart Piaware. Working now. :smiley: Thanks again.

@sjacket99 - thanks again for your help!

PS. How do I change the Subject to say “Solved”?

Just click on the edit button on one of the post, that you posted and here then you should be able to edit the subject.

Glad you got it working. Nice to hear from you… :smiley:

Thanks again.

I’ve been very busy with work around the yard. I was sick for a long time and the chores got away from me, but now that I feel good again I’ve been clearing trees. Also, it’s been too hot to go up on the roof. Also, there was that Windows 10 thing. :laughing:

Yea there is always something to do. Glad you are feeling better. It’s starting to get cooler here in the evenings.