Piaware 2.1-3 released


#1

Piaware 2.1-3 is now available. You can update via the ADS-B stats control panel, or by manually installing the updated packages.

The default port for multilateration results has changed

Piaware now sends mlat results to port 30104 by default. This change is to try to avoid accidentally feeding mlat results to a dump1090 that is not mlat-aware and may forward the results on unexpectedly (e.g. to other feeder software that doesn’t expect to see them).

If you are using the Flightaware-provided dump1090, please update your dump1090 package as well as updating piaware. The updated dump1090 package has a corresponding change and you don’t need to do anything special.

If you are using a different dump1090 and want to continue to forward mlat results to it, you will need to reconfigure either piaware or dump1090. To reconfigure piaware to use the older default of port 30004:



$ sudo piaware-config -mlatResultsFormat beast,connect,localhost:30004
$ sudo service piaware restart


Alternatively, you can reconfigure your dump1090 to accept data on port 30104 by passing “–net-bi-port 30104” on the command line.

If you do either of these, please be sure that whatever dump1090 feeds on to is expecting to see mlat results, or that you are running a mlat-aware dump1090 that doesn’t forward the results on.

If you’ve previously changed the piaware mlatResultsFormat option, that setting overrides the default already and you shouldn’t need to touch it.

Other changes

Mostly bugfixes and minor tweaks. Full changelog is here. Main user-visible changes:

  • Avoid ever running two copies of piaware (with the same pidfile, at least)

  • Fix piaware-status in non-English locales

  • Additional logging in fa-mlat-client to report more details of how well multilateration is working.

  • Detect problems with the UDP traffic used by multilateration (if there is a problem, you’ll get some log messages & an anomaly on the stats page)


VRS: Show both dump1090 ADSB and FA MLAT positions
ADS-B Receiver Project Setup Scripts
Multilateration (MLAT) now available on PiAware!
Newbie Question
Piaware 2.1-5
Issue with new setup
Mlat no longer working for me
New user, need help with the MLAT function
Piaware 2.1-5
#2

Thanks!


#3

Thanks for the update…

I’m sure you can do this and if so I don’t know how. Is there a way to check to see if MLAT is sending messages or logs. To make sure it’s feeding to FA?

Thanks.


#4

The mlat client logs to the piaware logs in /tmp/piaware.out.


#5

Thanks obj…

So it should look something like this?

09/28/2015 22:59:39 6146 msgs recv’d from dump1090-mutab (2914 in last 5m); 6146 msgs sent to FlightAware
09/28/2015 23:04:11 mlat(16674): Receiver status: connected
09/28/2015 23:04:11 mlat(16674): Server status: synchronized with 59 nearby receivers
09/28/2015 23:04:11 mlat(16674): Receiver: 1317.8 msg/s received 22.0kB/s from receiver
09/28/2015 23:04:11 mlat(16674): Server: 3.7 kB/s from server 0.0kB/s TCP to server 11.2kB/s UDP to server
09/28/2015 23:04:11 mlat(16674): Results: 1677.2 positions/minute
09/28/2015 23:04:11 mlat(16674): Aircraft: 146 of 156 Mode S, 69 of 83 ADS-B used
09/28/2015 23:04:39 9128 msgs recv’d from dump1090-mutab (2982 in last 5m); 9128 msgs sent to FlightAware
09/28/2015 23:09:39 12003 msgs recv’d from dump1090-mutab (2875 in last 5m); 12003 msgs sent to FlightAware
09/28/2015 23:14:39 14663 msgs recv’d from dump1090-mutab (2660 in last 5m); 14663 msgs sent to FlightAware


#6

Yep!


#7

Thanks. Thanks for the help and everything you do and FA does. I learned a few good things from you.


#8

Would you expect to see:
09/29/2015 02:21:06 mlat(4771): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
09/29/2015 02:21:36 mlat(4771): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
09/29/2015 02:21:58 56 msgs recv’d from dump1090-mutab (53 in last 5m); 56 msgs sent to FlightAware
09/29/2015 02:22:07 mlat(4771): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
09/29/2015 02:22:37 mlat(4771): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
filling up /tmp/piaware.out?
Did not make any changes to dump1090-mutabiliity. This is just a test bed. One feeder uses ppup1090 to forward to planeplotter. Would 2.1.3 affect that one if it was updated?
:confused:


#9

you need to edit /etc/default/dump1090-mutability and change this

Port to listen on for Beast-format input connections. 0 disables.

BEAST_INPUT_PORT=“30104”

where it used to be 30004


#10

Thanks, that cleared up nicely. Since I only have two beasts, one of whom provides my avatar, I don’t think it will be a problem w/ my production Rpi. :slight_smile:


#11

Awesome! :smiley:


#12

yesterday with 2.1-2 i saw all mlat tracked planes in vrs (port 30005 and beast format set there)
now - nothing

tomas
finally total flightaware bored


#13

In another thread I explained the steps you can take to get your mlat positions showing again in VRS:

The opening post of “Piaware 2.1-3 released” answers exactly your question:
If you use non-FA supplied dump1090, you can either re-configure PiAware or dump1090. The post has instructions for both.
If you use FA-supplied dump1090, you should upgrade this also through the control panel. I understand all required port changes will be made automatically and you won’t have to do anything else.

For you, a third option is available: You can make the mlat client listen for connections on yet another port and create a new feed in VRS to connect to that. You can then combine these two feeds (from dump1090 and mlat-client) into one feed that you display on the VRS map. This solution has the added benefit of separating your feeds so that you can display them separately (or combined), have separate range plots, have separate position counts in VRS and generally know exactly what you are getting from which source.


#14

hello mgunther,

thanx a lot for all your support and the friendly offer to show me how to merge two data streams in vrs.

but i always try to keep things as simple as possible. and now i have to switch ports here and there and back and forth.
and as i said the mlat data was at port 30005 - here obj talks about ‘old port was 30004’

i just want to setup a good site -> deliver them data for free -> and want to get back free and easy to use mlat data. without messing up my other feeds or personal output.

but the question remains: how do i get back the mlat data to port 30005 where they were and worked perfect?

kind regards
tom


#15

Just as the opening post states:


sudo piaware-config -mlatResultsFormat beast,connect,localhost:30004
$ sudo service piaware restart


#16

that was what i did - the error message i mentioned in the other thread - went away.

but still i did not see mlat data in vrs and planefinder map - as it was the days until yesterday night when i did the update …


#17

So, I’ve just updated to 2.1-3 and also did a reboot.

Now, my stats-page is hanging and MLAT planes show up in my VRS, but not on the dump1090 map page anymore.


#18

OK, can you confirm which version of dump1090 you are using and if you updated that as well or made any changes to it? Are you using the FA supplied version, plain Malcom Robb version or Mutability version?
Does MLAT traffic show on the dump1090 web page?


#19

mguenther - i feel so sorry to waste your time - with my personal bullshit.
i installed mutability dump (latest) along your good explanation here in the forum. and then newest piaware - obviously was provided before obj post. in vrs my setting is port 30005 beast mode …


#20

If your not seeing MLAT planes on VRS. If you have it setup right and under settings have the feeds merged together. I did the same thing awhile back. I had to bring the VRS map up on the computer and on the map section click on menu “I think” and under their I had to check merge feeds also.