Version 2.0-3 released and auto-updated


#1

Hi everyone,

We’ve released v2.0, which contains the ability to do multilateration (MLAT) of Mode S (non-ADS-B) aircraft. The PiAware server queries multiple PiAwares that all see the same Mode S target and the server does the math to MLAT the location of the Mode S aircraft. Currently, the MLAT functions and data are in test and will not be visible anywhere yet because we need this testing first before this will work at scale. Stay tuned for updates over the coming days & weeks.

All SD Card users and all Debian package users with auto-update should be running 2.0. If you installed it via package and didn’t get an update, visit flightaware.com/adsb/piaware/upgrade

In order for your site to participate in MLAT, you will also need to set your exact location on your stats page. Also, you can always turn off MLAT via your stats page.

What It Will Do

  • Participate in the FlightAware MLAT network, using additional bandwidth (perhaps 20-50Kbps at peak)

  • Help FlightAware test client/server communication, back-end performance, scalability, data accuracy, and data integration

What It Won’t Do Yet (but will in the future)

  • Show MLAT data on your dump1090 web interface

  • Show MLAT data on FlightAware.com

  • Show MLAT stats

More info about MLAT here: flightaware.com/adsb/mlat/

Related thread: Multilateration (MLAT) Beta


#2

Hmmm… looks like I got auto-updated, just wondering since I run dump1090-mut, do I need to change or modify any settings again?


#3

From what I can see, I don’t believe so as I do think it seems to be working.


#4

Any way to tell this working? I see it says it is enabled but no indication on the stats page of mlat stats or on the log. I will dig around the Pi log itself to see if I can tell it is working.


#5

Ok this seems simple but I’ve got a question.

The “My ADS-B” page says I have

Anomaly report for PiAware feeder with a MAC address of b8:27:eb:f9:57:36:
This system is running PiAware version 1.20. PiAware version 2.0 is current. Please upgrade to the latest version by visiting flightaware.com/adsb/piaware/upgrade.

However… I’m not running a MAC so when I go to the “upgrade page” it refers you to the “Build an ADS-B” page and tells you to just repeat steps #2 and 3

Well the file is sill the older version that I have so what should I do? The MAC file is the 2.0 but the PC is not


#6

For PiAware, probably easiest thing to do is go to your statistics page and then select “send command to device”, click the command chevron, select the piaware upgrade and click to send the command


#7

Just sent the command. Let’s hope it works.

Amazing in this day of information services that these things are very much living in the 1980’s still with how things are conveyed to us.

Guess I’ve just gotten lazy and used to a button to click.


#8

FWIW this is a Media Access Control address aka ethernet address. It’s used to identify the receiver. Nothing to do with Apple :wink:


#9

Changing the setting, “Auto-update PiAware software” to “Allow auto-updating” will enable automatic upgrades in the future.


#10

I interpret this to mean that the location I’ve entered is the exact location of my antenna (and it is).

My further interpretation (by omission) is that I can still have Precision on Coverage Map set to something other than Exact.

Please confirm–

And thanks for the update! Primary and secondary PiAware feeders both updated, and running with obj’s dump1090-mutability.

bob k6rtm


#11

Did this but has not updated yet.


#12

[quote=“k6rtm”]

Yes – that setting obscures your exact location to the public, but the MLAT servers have access to it so they can do the correct calculation.


#13

What kind of bandwidth do you have on your internet? We have an issue with some devices that take more than 15 seconds to download the 2MB update.


#14

Normal DSL, about a 3mb download speed.


#15

How is the testing going at FlightAware?


#16

So should I download the file, even though it doesn’t say it’s a version 2.0 and reinstall it?


#17

I have updated manually to 2.0.3 on a couple of boxes I have with no problems. I just tried to update one of my sites and I noticed that FA is showing that the site has not checked in.

I have purged the system of old piaware files and tried to reinstall clean. The binary starts and appears to be working but it is not logging. So I straced the process and it appears to be working. I can’t tell what I may have done to cause this. I touched the log file piaware.out in /var/log, purged the package and the configs, re-downloaded and installed.

I was running piaware-mutability previously if that makes a difference.



gettimeofday({1433822674, 988136}, NULL) = 0
send(5, "\27\3\1\0P \352\253\21.2@\252\213'I\347\324\302r\35T\3110\10c\24\373\0\376f\210"..., 85, 0) = 85
gettimeofday({1433822674, 996149}, NULL) = 0
gettimeofday({1433822674, 997957}, NULL) = 0
write(4, "\0", 1)                       = 1
futex(0x17aac70, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x1a61120, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x1a61124, FUTEX_WAIT_PRIVATE, 765, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x17aac70, FUTEX_WAKE_PRIVATE, 1) = 0
gettimeofday({1433822675, 3421}, NULL)  = 0
gettimeofday({1433822675, 3948}, NULL)  = 0
gettimeofday({1433822675, 4745}, NULL)  = 0
gettimeofday({1433822675, 6227}, NULL)  = 0
gettimeofday({1433822675, 7915}, NULL)  = 0
send(5, "\27\3\1\0000P\332\225B$v\7e	\354\304\266!.\206\f\337\315???L_\2610\330\232"..., 53, 0) = 53
gettimeofday({1433822675, 13935}, NULL) = 0
gettimeofday({1433822675, 15502}, NULL) = 0
gettimeofday({1433822675, 16701}, NULL) = 0
write(4, "\0", 1)                       = 1


Anyone have any thoughts on a) why the logs are not being written b) could this be a bug


#18

I decided to upgrade my site 6699 Pi 2 running dump1090-mutability and piaware-mutability (pm) to piaware (pia)2.0-3. pm & pia don’t play well and the 'sudo dpkg -i piaware_2.0-3_armhf.deb failed with an error
/usr/lib/Tcllauncher5/pkgindex.tcl also in pgk tcllauncher 1.5 +6.1 broken pipe (if I can read my own writing).

Resolved this time from notes on prior fiascos:

sudo apt-get install -fy
(msg: Following pkgs automatically installed and no longer required- itcl3 librecoffice tcl-tls tcllauncher tclLib tclx8.4
sudo apt-get autoremove
<cd to local dir w/ source>
sudo dpkg -i piaware_2.0-3_armhf.deb
(msg: missing dependencies…guess which ones)
sudo apt-get upgrade
(warning msg: you might want to fun apt-get -f install to load missing dependencies)
sudo apt-get -f install
… piaware finished installing and is running the MLAT enabled.

AND I didn’t even have to drag the rubber chicken widdershins across the keyboard this time! :mrgreen:


#19

Stock piaware writes to /tmp/piaware.out, not /var/log


#20

Yes, piaware and (piaware-mutability + dependencies) will not coexist at the moment. You must remove one before installing the other. tcllauncher is a separate package as packaged for piaware-mutability, but it is included directly in the standard piaware package.