FlightAware Discussions

Piware not working properly

I bought a full setup on Ebay or Amazon, was able to go through the step by step and everything worked perfectly for 6 months.

Then one night, it somehow could not connect and I no longer could use it. I tried formatting the memory stick, changed the password on my network and piware to see if that was it. Nothing.

I have a solid red light. Flashing green intermittently. I know this is vague, but I’m not savy at all with this stuff.

So you followed this to get back to a working system? https://flightaware.com/adsb/piaware/build

Red light just means the device has power.
If you have another sd-card, you can try that.

With a fresh format you’ll need to claim the new station.
Or you’ll have to enter your old feeder-id: For Beginners - How to Get Back Existing Station Number in A Fresh Install

Yes, I followed that build.

Tried two different SD cards.I just did a new format today, and it’s been waiting for 30m to claim a station, cant find it.

Which RPi is it?

Can you share the config file you used? (replace password)

Wow. I unpulled the SD and plugged it into computer and I got a popup that said “This drive needs to be formatted”

Wonder if thats the cause?

If you plugged it into a Windows computer, you may get the drive needs formatting message. Ignore it. Look for the card mounted as a drive, mine likes G:. The drive should contain the files from the boot partition.

Raspbian image and Piaware image do not give the message “This drive needs to be formatted”.

Armbian image does give this message, even though the image is perfectly written and works ok in OrangePi.

Which image you have written to your microSD card?

I am getting this message all the time when moving the card from Raspberry to my Windows device. But the SD card works without issues on both devices if i ignore the message.

Could be a flag set on the SD card which the windows device does recognize incorrect.

ok found it, still having same issue as pi isn’t cooperating

i have no idea. how can i find this?

#
# NETWORK CONFIGURATION
#

# By default, PiAware will use DHCP when connecting to your network.
# For other configurations, see the Advanced Configuration page
# linked at the top of this file.

# Should piaware use the wired ethernet port
# for network access?

wired-network yes

# Should piaware use a wifi adaptor for network access?
# If you are using a Pi 3, this will use the built-in wifi.
# Otherwise, you will need to attach a supported USB wifi adaptor.

wireless-network yes

# Wifi SSID and password.
# This should be changed to match your wireless
# network SSID and, for networks that require
# a passphrase, the passphrase.
#
# If your SSID or password contains characters other than
# numbers and letters, such as the # character or whitespace,
# you should enclose the value in quotation marks. For example,
# "pass word" or "pass#word".
#
# To include quotation marks (") in a quoted value, use \"
# To include a backslash (\) in a quoted value, use \\

wireless-ssid blazinwolfgangs
wireless-password ******

#
# 1090MHZ RECEIVER CONFIGURATION
#

# For a complete list of receiver types and their associated settings,
# see the Advanced Configuration page linked at the top of this file.

# For a receiver type of 'rtlsdr', this setting controls the dongle gain.
# Use "max" for maximum gain. Other values are interpreted as a gain in dB.
rtlsdr-gain max

#
# OTHER CONFIGURATION
#

# Should automatic system updates (initiated by FlightAware) be allowed?
allow-auto-updates yes

# Should manual system updates (initiated by you from the website control
# panel) be allowed?
allow-manual-updates yes

# Should PiAware enable multilateration where possible?
# You may need to disable this if multilateration overloads your receiver.
allow-mlat yes

# Should PiAware enable reception of Mode A/C messages when requested?
# You may need to disable this if processing Mode A/C overloads your receiver.
allow-modeac yes


# Additional settings can be added below.

@travisb922

Placing 3 back-ticks ``` above and 3 back-ticks ``` below the chunk of text/code will make it nice looking. This is how it is done:

```
Text line 1
Text line 2
.
.
Text line n
```

EXAMPLE: By placing back-ticks above & below the text you have posted, this is how its appearance improves:

#
# NETWORK CONFIGURATION
#

# By default, PiAware will use DHCP when connecting to your network.
# For other configurations, see the Advanced Configuration page
# linked at the top of this file.

# Should piaware use the wired ethernet port
# for network access?

wired-network yes

# Should piaware use a wifi adaptor for network access?
# If you are using a Pi 3, this will use the built-in wifi.
# Otherwise, you will need to attach a supported USB wifi adaptor.

wireless-network yes

# Wifi SSID and password.
# This should be changed to match your wireless
# network SSID and, for networks that require
# a passphrase, the passphrase.
#
# If your SSID or password contains characters other than
# numbers and letters, such as the # character or whitespace,
# you should enclose the value in quotation marks. For example,
# "pass word" or "pass#word".
#
# To include quotation marks (") in a quoted value, use \"
# To include a backslash (\) in a quoted value, use \\

wireless-ssid blazinwolfgangs
wireless-password ******

#
# 1090MHZ RECEIVER CONFIGURATION
#

# For a complete list of receiver types and their associated settings,
# see the Advanced Configuration page linked at the top of this file.

# For a receiver type of 'rtlsdr', this setting controls the dongle gain.
# Use "max" for maximum gain. Other values are interpreted as a gain in dB.
rtlsdr-gain max

#
# OTHER CONFIGURATION
#

# Should automatic system updates (initiated by FlightAware) be allowed?
allow-auto-updates yes

# Should manual system updates (initiated by you from the website control
# panel) be allowed?
allow-manual-updates yes

# Should PiAware enable multilateration where possible?
# You may need to disable this if multilateration overloads your receiver.
allow-mlat yes

# Should PiAware enable reception of Mode A/C messages when requested?
# You may need to disable this if processing Mode A/C overloads your receiver.
allow-modeac yes


# Additional settings can be added below.
1 Like

Wrong backticks, copy the next line and paste it into your post:
```

The correct backticks are made with the US keyboard, it’s the key to the left of the 1.
Not sure how many other layouts have the correct backtick.

Anyway, i suspect the sd-card might be done for?
Can you use the verification in Balena Etcher after writing the image?

Can you try a new/different sd-card?

1 Like

tried multiple cards, even bought a brand new one and still having the issue. No issues after Etcher

The backtick (grave-accent) key is left of number 1 key on US keyboard, as shown in image below.

backtick_key_us_keyboard

How To Format Messages in This Discussion Forum

OK, no problem, if back-tick ` is not available in keyboard. Use [code] and [/code] instead. See example below:

How typed How will appear
[Code]
text1
#text2
## text3
##tetx4
[/code]
text1
#text2
## text3
##text4

i figured the keyboard issue out lets worry about the adsb

Glad to know that you have sorted the keyboard issue. However these posts are read by lot of other members as well. What I posted was not intended only for your benefit, but for benefit of others too.

Yes, let us now return to original issue of adsb. Unfortunately I have no solution in hand about it. Please wait for input from other members who can give you some advise.

That’s how it’s supposed to be.

You switch it on, wait 10 minutes and then claim the site: https://flightaware.com/adsb/piaware/claim

It shouldn’t be necessary, but you can add this to the configuration:

wireless-country US

These are the shorthands for other countries: https://www.arubanetworks.com/techdocs/InstantWenger_Mobile/Advanced/Content/Instant%20User%20Guide%20-%20volumes/Country_Codes_List.htm

If that doesn’t work, try the Ethernet connection.
If that doesn’t work, you’ll need to connect a monitor and keyboard to diagnose the issue.

You’ll have to have your device on the exactly same network as the RPi for the claim link to work.
If it’s on the WiFi, you should be on the WiFi as well, some routers don’t consider it the same network otherwise.

What version of RPi is it?
Which sd image version are you using?

Have you checked with your router if the RPi is assigned an IP address?
In that case you can connect via putty: For Beginners - How-to SSH to RPi - Setup Putty in Windows

Without actual commands on the device, there is very limited debugging advice i can give you.