FlightAware Discussions

For Beginners - How-to SSH to RPi - Setup Putty in Windows

#1

HOW TO SSH TO RPI - SET UP PUTTY IN WINDOWS

(A) Enable SSH in Pi

First thing you have to do is to enable SSH in RPi.

The easiest way to do this is:
(1) Shutdown/Power off Pi.
(2) Slip-out microSD card from Pi, slip it in a card reader. Plug card reader into your Windows/Mac Computer.
(3) Open Windows/Mac File explorer/File Manager and click on drive pertaining to microSD card. It is drive (F) in my computer, but may be different letter in your computer. This will open the boot folder of the microSD Card.

(4) Create a new blank text file SSH (SSH.txt if file extensions are shown) in the microSD card’s boot folder.

(5) Eject microSD card from Windows/Mac computer, slip it into Pi, and power-up. The Pi will now be enabled for SSH, and you can connect to it through PuTTY.

NOTE: The microSD card will show as boot if you are using Raspbian image. If you are using Puaware SD card image, the microSD card will show as piaware
SSH-1

(B) Install, setup and use PuTTY

(1) Find out your local IP from your Flightaware status page (you must be logged in to your FA account).

https://flightaware.com/adsb/stats/user/

.
Putty-1

.
(2) Download PuTTY windows installer:

Download Page:
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

Direct download link (32-bit):
https://the.earth.li/~sgtatham/putty/latest/w32/putty-0.70-installer.msi

…
(3) Doble click downloaded installer to install the PuTTY.

.
.
(4) After installation is complete, open PuTTY. It will be like screenshot below

PuTTY-1

.
.
(5) Enter your Pi’s Local IP you found from your flightaware stats page in step (1), and make sure SSH is selected and port is 22. Click Open button.

PuTTY-2
.
.
(6) You will get a warning. Click Yes button

!PuTTY-3
.
.
(7) A SSH Cosole window will open with one line Login as . Type pi and press enter. Then it will ask password . Type password (the typed password will not be visible to you). Press Enter key, and you are ready to start using commands.

PuTTY-4

1 Like
Thoughts on optimizing gain
HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration
Announcing PiAware 3! (Latest version: 3.7.1)
Adjusting Dump 1090 mutability gain settings
Changed USB Dongle. No data on PiAware Skyview
Pi zero W intermittent transmit
Piaware SD card image 3.7.1 Quickstart Guide
How to diagnose random connection loss?
Piaware SD card image 3.7.1 Quickstart Guide
Better antenna, lost close-in traffic
Help setting gain using putty
Problem with new install of my old site
#2

Great how-to. I would add the step of saving the connection settings in putty, so next time doesn’t need to type in the IP.
Of course, that means that the IP doesn’t change (static in router).

#3

In Windows 10:
Press Win+R
Enter ssh pi@192.168.0.21

2 Likes
#4

Thanks, didn’t know that Win 10 has embedded SSH in.

#5

included in the April 2018 update

3 Likes
#6

I am getting a refused connection. I followed these instructions previously (months ago) and all worked fine. Any suggestions???

#7

Connection refused means you somehow didn’t enable SSH on the pi.

Or SSH on the pi is not active somehow, that’s unlikely and should be fixed by just power cycling the RPi.

#8

I deleted the SSH file and recreated it. No I get “network error software cause connection abort”

#9

Make sure your putty version is up to date, download a current version.
Link in the first post is not the most current version but should also work.

https://the.earth.li/~sgtatham/putty/latest/w32/putty-0.71-installer.msi

Do you have a static IP in use or is it DHCP?

#10

I have a static IP Ill reinstall putty.

#11

By chance could it be that the static IP is in use twice?

Try a different IP and make sure it is not used.

#12

First a correction IPs are DHCP but have never changed. I have 2 PiAware receivers. At 192.168.1.18 and 192.168.1.8. The one at .18 quit feeding flight aware but the local network display shows it is still receiving and processing data. I was trying to connect to see what is happening, but can’t connect to either PiAware. I went through the IP list on my router and there are no duplicates.

#13

Really not sure what the problem is then.

Maybe you have McAfee firewall or another non-windows firewall enabled?

#14

Thanks for trying. I’m going to quit for now. try again tomorrow.