FlightAware Discussions

Setup Assistance


#1

Hello can anyone assist? Have been running ADSB on my dongle for the longest. My Raspberry 3 retired on me, purchased a new one, even a new dongle, followed the steps probably about ten times now. still no joy, would be willing to let someone remote into my PC, i am at a loss as to why i cant claim it.


#2

@brennan741

  1. Download Piaware image and write it to microSD card using etcher or Win32DiskImager.

http://piaware.flightcdn.com/piaware-sd-card-3.6.3.img.zip

  1. Open the microSD card drive while card is still plugged into Lapto/Desktop, and creat a blank file with name ssh.

  2. Slip the micro SD card in RPi and Powerup.

  3. Follow instruction here:

For Beginners - How to Get Back Existing Station Number in A Fresh Install

.


#3

Can you try describing the actual problem?

If you don’t know whats wrong can you ssh into RPi or connect a display to the RPi?


#4

I somehow didn’t process that.
You need to be on the same local network to claim it.
Maybe your device from which you are trying to claim it is in a different wifi or something?
Also making sure it’s running by somehow finding out the ip and accessing the local map would be a good start :slight_smile:
Does your router list the devices on the network, in that case you can check which ip it has.


#5

So i checked my router and it says im connected. No clue as to why i cant claim. I done the setup over an over.


#6

Sorry i didnt reply yesterday. my account was froze. What is the ssh file for?


#7

When on boot, Pi finds the ssh file, It will enable SSH. You can then issue commands to Pi from your Desktop/Laptop through an App called PuTTY.

You can download PuTTY and install it on your Desktop/Laptop from link given below:

https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

NOTE:
If you are using a Mac computer, you dont need to install PuTTY. You can SSH to RPi using Terminal.

You have to give following command
(Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by the Unique Identifier you have copied from your stats page)

sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

sudo systemctl restart piaware

#8

Thanks for you help Sir, but im not familiar with Putty.


#9

Ok, do this:

  1. Power-off RPi, slip out microSD card, slip into card reader, and plug the card reader to your desktop/laptop.

  2. In File explorer / File manger of desktop/laptop, double click on the drive letter of microSD card. You will see many files. One of these is named piaware-config.txt. Open this file, scroll-down to bottom, and at bottom add following line:

    feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    (Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by the Unique Identifier you have copied from your stats page)

  3. Save the file piaware-config.txtafter adding this line.

  4. Eject the mocroSD card, slip out from card reader, slip into RPi, and power-up.

  5. Wait for 5 minutes, then while logged-in to Flightaware, click this link, and see if all buttons are green.
    https://flightaware.com/adsb/stats/user/


#10

Ok, great, thanks for working with me. Powering back up


#11

If you can’t find out the IP of the RPi putty is not gonna do you much good.
Can you connect a screen or TV to the RPi ? It has a HDMI output.


#12

Tried that Sir and nothing. Thanks for your help. gonna start from the top again.


#13

One thing im noticing is the piware config on the setup page looks nothing like the one i open and input my wifi info. Bottom half is different.


#14

I just checked and this file:
(https://flightaware.com/adsb/piaware/piaware-config.txt)

should be identical to the one on the sd-card image.

Maybe you have a defective sd card?


#15

Hadn’t thought about that, Thanks. Ill see if i have another. Yes my config text looks like that, guess tey just hanvet update the one on the install page


#16

Etcher verifies the image after writing so the sd-card is probably working.

How are you connecting the RPi to the network, did you do it differently when you had it working the last time?

If you could just plug in a screen that would make diagnosing the problem much easier.
I guess you don’t have a HDMI cable?


#17

Trying to locate one, i didn’t do anything different than i did the last time when i had it going


#18

If you are using wifi can you maybe connect it with an ethernet cable temporarily just to see if it works then?
There have been wifi problems with RPi and the new debian.

You could also try setting the wifi country just to make sure that isn’t causing any problems.
In the piaware-config.txt add the following line

wireless-country GB

That would be for Great Britain. You would need to find the code for your country here (https://www.arubanetworks.com/techdocs/InstantWenger_Mobile/Advanced/Content/Instant%20User%20Guide%20-%20volumes/Country_Codes_List.htm)


#19

Ok, cant do that as im on a ATT Hotspot ZTE. this is so frustrating. Last time i had issues he remoted into my PC and assisted me.


#20

How is your computer connected to the ZTE?

You need to connect your computer to the hotspot as well to claim the device.
If you get your internet from somewhere else you can’t claim the device.

Also a good chance to reenter the wifi password to check that it’s the one you are using with the RPi.