Problem using putty with piAware img


#1

I’m using the latest PiAware img software on a pi3 and I’ve got it uploading to FA. I want to add other sharers such as FR24 and to do this I need to use Putty or similar. Whilst mounted in Windows I added the empty file ssh.txt to the boot folder. I know the ip address of the pi but when I try to open the putty window I get a unable to connect error. For some reason if I remove the card and mount it back into windows the ssh.txt file has been deleted, I’ve tried this several times with the same results.
I’ve used putty in the past with other ADSB software without problems, the reason for using the full PiAware img this time I want to use the Beast receiver with the pi and I believe this is the only way of doing it
Paul


#2

You have to name the file ssh not ssh.txt so save it without the extension .txt
At least that is how it works with the stanard raspbian installation, I’m not sure if this is the same with the piaware image, but you can at least try it :wink:


#3
  1. The ssh file name can be either ssh or ssh.txt, both work ok

  2. At boot, if the systems finds file ssh or ssh.txt, it does two things
    (a) Enables ssh
    (b) Deletes file ssh or ssh.txt

  3. Are you using wired network connection, or WiFi? If WiFi, did you configure WFi in the file piaware-config.txt? This is to be done while card is mounted in Windows computer.


#4

Or maybe your firewall is blocking port 22?


#5

I’m using wifi and the configuration is ok (done in the piaware-config file), the pi connects to the wifi ok, I can upload data to Flightaware and it’s showing in my FA control panel, also the pi is showing in my router info.
I’ve also connected a keyboard/vdu to my pi and enabled ssh that way but I’m still unable to connect using putty.
I might re-format the card and start again, perhaps something, somewhere didn’t load correctly


#6

No, I have another card with other sharing software and if I use that in the same pi I can use putty on port 22 without problems


#7

Maybe you are using a different local IP than the IP your router has asigned. Go to you Flightaware stats page and use the local IP shown there.


#8

I went back to square one, formatted the card, re-installed the image and all is working well now, using putty without any problems