ssh connection not possible


#1

Hello everyone,

i´ve updated my reciever to Piaware 3.5 and set it up to use a static ip for the wired Network (192.168.1.45). I´ve also copyied a “renamed”(from xyz.txt to only ssh) file to the sd card to enable ssh. After every boot of the pi this file is erased oder something (can´t see it anymore)

I can see the skyview under the wanted ip and everything looks as it should but i can´t get ssh to work?!

I´m using putty and 192.168.1.45:22 for ssh?!


#2

On boot, Raspbian looks for that “ssh” file and if it exists then

  1. it enables sshd persistently (it will stay enabled even after a reboot)
  2. it removes the “ssh” file

So if the file is being removed then that process is working and ssh is enabled. You have some other sort of problem if ssh is not working for you, but you didn’t describe what actually happens when you try so I can’t diagnose that any further.


#3

hello,

okay few pics from putty

abload.de/img/putty1u6scd.jpg

abload.de/img/putty2tjsfd.jpg

thanks for the help


#4

Sounds like a network or firewall problem (it is not the error I’d expect to see if you could reach the Pi but sshd was not running at all)


#5

Are you sure your router has assigned 192.168.1.45 to your Pi?

To see what IP address has been assigned by router, I have installed an App called “fing” on my Android Phone. When this phone is connected by WiFi to the network on which the Pi is, it shows the actual Local IP as well as the MAC address of ALL devices on LAN, including the Pi. I then SSH using that IP address (for example 192.168.0.20).


#6

Hello,

yes i´m pretty sure about the ip.
I can ping it and flightaware assigns this ip to my rpi (i have no other rpi running at the moment)
and this ip is using the mac address from my rpi…

firewall could be but i have changed only the sd card. I used the same ip for the rpi with the old piaware version?!

abload.de/img/piaware1zgs6m.jpg << scan with ip scanner
abload.de/img/piaware22oszz.jpg << flightaware

edit:
tried the old image from a backup once again and after changing to that sd card ssh is working agian…


#7

If this happens with me, I will first try to debug for a short while. If no success, then I will take an easy way out: format microSD card and write the Piaware (or Respbian) image again. No headaches and no frustration.


#8

Hello,

Mhm what should be different?! Just done that. Got the Image copyed it to the fresh card with the Imagewriter added the lines for static ip to the config and a new file ssh…

But i will try it once more tomorrow :slight_smile:


#9

First remove the lines you have added for static ip to the config. Determine IP of Pi from router or by scanning, then try SSH. If SSH works, then something had gone wrong during adding the lines for static IP.

If above test fails, write new image, create file SSH, but DO NOT add lines for static IP to config. First try without static IP. Determine IP of Pi from router or by scanning, then try SSH. If SSH works, then add lines for static IP.


#10

Sorry if this is way out but have you enabled SSH via “status”?

Hugh


#11

Hi

?!? Status?! Don’t know what you mean… sorry


#12

No, my apologies for not being more explicit!

From the command line:

sudo raspi-config

5 Interfacing Options Configure connections to peripherals

P2 SSH Enable/Disable remote command line

                                                      │ 
      │ Would you like the SSH server to be enabled?             │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │                                                          │ 
      │               <Yes>                  <No> 

Select Yes

I have to do this every time I write a new image SD card. It used to be enabled, now you need to select SSH

Good luck!

Hugh