FlightAware Discussions

No Communication with Flightaware

My site is down and I had updated to 3.7.1. The update had worked fine but remains offline now. I am not sure what happened. I have reflashed the SD card twice and upgraded to RaspPi 3+.

There is no second site for me to claim and I am not sure what component is failing. Pi shows a red LED and the external antenna is fine. Any suggestions? I wonder if my ProStick Plus could have failed. I’m not much of a coder and I edited my piaware-conig.txt file for no wired connection, yes wireless connection and my router SSID and Password

Again, after having worked with both 3.6.3 and 3.7.1, my station is now offline.

Any help or suggestions?

Thanks, in advance.

VB

Can you check with your router if the RPi get’s an IP-address?
Most likely it’s not getting a connection otherwise you should be able to claim it.

Maybe double-check piaware-config.txt?

Router shows piaware as an offline wifi device. Likely my original site. I should’ve clarified a new rasp pi.

Tried almost everything else. Pwr supply, reflash, reformatting the sd. I need to get into the pi shell but can’ right now (no keyboard : ()

Might have to force a port on the router and assign a static ip? Here I was thinking plug & play all along!! lol

It is a piaware sd-card image yes?
As i said the most likely reason is that you have something wrong in piaware-config.txt

If you want to use WiFi don’t plug in the Ethernet cable that can lead to problems.

Putting on a monitor you could at last see if it’s booting correctly.

Thank you @wiedehopf

Just can’t put my hands on the peripherals to access the ssh right now, but I will. Thanks for your help.

victorbravo77

But you could remove the sd-card and check piaware-config.txt on your main computer, couldn’t you? :slight_smile:

After reflashing the piaware-config.txt gets overwritten so you need to do the configuration again. (you can back up the file)

Yes, I just reflashed a new SD card w/ 3.7.1.

… and changed the ssid and p/w for wifi. It worked fine before and then dropped into the netherworld. We did have a short pwr outage for a couple hours. New Raspberry and SD card shouldn’t have been affected. Any cheap and easy way to test the receiver/ProStick?

Connect the RPi via ethernet if you can.

Just to check if network is the problem.

That’s my guess. Network is blocking it for some reason. SSID and P-words on 2.4ghz and 5G are both ‘free and correct’ so to speak. Router admin pages don’t show the device. Trouble-shooting through the router …

All other network devices (lan and wifi) connect and have internet access.

Maybe the WiFi is bad or the reception is insufficient?

I highly doubt it’s the problem but you can try adding
wireless-country US

to the piaware-config.txt

… trying anything at this point. Might need a range-extender because there are a few walls between the two, but as I said piaware 3.6.3 and 3.7.1 both worked 'til the gremlins took hold.

Was that with another RPi or the same one?

Maybe the WiFi on the RPi is just fried for some reason.

Try it close to the router without the dongle connected.
You should still see it in the router.

An easy way to test an RTL dongle is to plug it into a PC with any of the SRD front-end programs to check for function.

… and made the requisite changes to piaware-config.txt.

I assume it’s still not working?

Can you remove wifi name, password and feeder-id and share the rest of the piaware-config?
Did you try it closer to the router or via LAN/Ethernet?

I did. Really no good ethernet connex right now. I can get to both pi platform SSH via hdmi (tv) usb mouse and keyboard. I run the os from the flash.

Stand by. I’ll send a couple versions of the things that I’ve tried.

if you directly connect a keyboard that is not SSH.

(SSH means secure shell, it’s a protocol to connect to a linux console via network)

But if you have access you can check some logs, i’ll give another post on what commands to check.

First let’s look at this command:

sudo journalctl -e -u dhcpcd
(q to get out)

Also this command:

sudo wpa_cli -i wlan0 status
1 Like