FlightAware Discussions

Using Beast GPS receiver from broken FlighFeeder on windows via USB


#21

Yeah just check the error message.
It lists all the packages you need to install.
it’s libboost-system-dev

but just install everything it asks for…
maybe i was unclear?
the dpkg-buildpackage -b command literally says what you need to install. :wink:
(the stuff behind error: Unmet build dependencies)


#22

ah yeah thanks… got it… trying


#23

Bro I’m really sorry for inconvenience, but I’ve installed all the required dependencies, everything installed just fine but now i’m getting THIS…


#24

I’m sorry the file is called differently because of the architecture.

cd ..
ls

Then you can see all the .deb files
it’s probably beast-splitter_3.6.3_i386.deb
that’s the one you need to install with dpkg -i


#25

Like this??


#26

That looks good.

Use the following to edit the configuration.

nano /etc/default/beast-splitter

Change the no after ENABLED to yes.

Did you install piaware already according to the instructions on the flightaware page?
(https://flightaware.com/adsb/piaware/install)
You probably want dump1090-fa as well for the local map, then you can install it with piaware as per the instructions.

You need to configure both of these, i will help.

After the configuration is done or maybe before we should test if the beast-splitter can connect to the beast receiver.
Did you already assign the USB port you have connected the beast to to the VM?

If you did use this command:

file /dev/beast

To check if it’s already accessible. (At least i hope that is how it works :slight_smile: )
Or you can test with beast-splitter directly

beast-splitter --serial /dev/beast --listen 28888:R 

I’m not really sure under which filename in /dev/ the beast is going to appear.
It may be necessary to unplug it and do an ls /dev, then plug it in and do an ls /dev again to see if anything appeared :slight_smile:


#27

it’s telling me serial(/dev/beast): connected to a Radarcape-style receiver is that ok?? i can’t install dump1090-fa, because it says that i386 is not supported… and i dont have the dump1090 too…


#28

That IS SUCCESS :slight_smile:

Yeah we will just compile dump1090-fa as well.

Still wondering why you used i386 instead of amd64. No matter :slight_smile:


#29

yeah… my fault sorry… :slight_smile:


#30

So you can press CTRL-C to stop beast splitter as it was only a test.

then do

systemctl enable beast-splitter
systemctl start beast-splitter
journalctl -u beast-splitter -e --no-pager -n50

And send me the result.

for dump1090-fa

cd
git clone https://github.com/flightaware/dump1090.git
cd dump1090
dpkg-buildpackage -b

you will most likely need dependencies again :wink:


#31

getting this…


#32

and this after dump1090


#33

the dump1090 error is no problem.

go ahead and do

cd
dpkg -i dump1090-fa_3.6.3_i386.deb
nano /etc/default/dump1090-fa

This is what the default config looks like

# dump1090-fa configuration
# This is read by the systemd service file as an environment file,
# and evaluated by some scripts as a POSIX shell fragment.

# If you are using a PiAware sdcard image, this config file is regenerated
# on boot based on the contents of piaware-config.txt; any changes made to this
# file will be lost.
                                                                                                                                       
RECEIVER_OPTIONS="--device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"
DECODER_OPTIONS="--max-range 360"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005"
JSON_OPTIONS="--json-location-accuracy 1"

You need to change some stuff:
First line should be --net-only
Then the end of the 3rd line change 30005 after --net-bo-port to 0

RECEIVER_OPTIONS="--net-only"
DECODER_OPTIONS="--max-range 360"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 0"
JSON_OPTIONS="--json-location-accuracy 1"

After changing the configuration do

systemctl restart dump1090-fa

By now you should also be able to reach your local map under the ip address of the virtual machine.
If you have a browser in the virtual machine try:
http://localhost/dump1090-fa


#34

Regarding the beast errors i’m not quite sure but i hope it will still work. (the baudrate stuff)
The connection errors from the beast will be gone once dump1090-fa is running.


#35

dpkg -i dump1090-fa_3.6.3_i386.deb gived me bunch of errors… and after that nano /etc/default/dump1090-fa gived me empty file…


#36
apt-get update
apt --fix-broken install

#37

ok… everything went normal… i;ve restarted dump1090 via systemctl… all i;m gettinng in browser is “Not Found” uder URL localhost/dump1090-fa


#38

that was if you use the browser in the virtual machine.

i’m not sure if you have given the VM an outward facing ip as well?
then you can use that instead of localhost.

oh there is an apache installed on the VM.
can you remove that :stuck_out_tongue_winking_eye:

try

systemctl stop apache2
systemctl stop apache
systemctl restart lighttpd

does that fix it?
then you can just

systemctl disable apache
systemctl disable apache2

to stop apache from starting automatically.


#39

YEAH MAN!!! You’re the best mate… it worked :smiley: but I live in Armenia not in Milano (as you can’t see on the map :D)… how can i fix that??


#40

you will want to edit the conf file more:

nano /etc/default/dump1090-fa

and after the net-only add:

--lat 50.0 --lon 10.0

according to your position.
you can find that by using google maps for example :wink:
do a right click on your position and click “what’s here”
it should put a marker and there should be coordinates with that.
First is lat second is lon
Be sure to use the format with the . only.

I’m not sure but you can also check on you flightaware status page if it’s still correct or just enter the correct data there as well.

you should also be able to claim your receiver.
you can also use piaware-config to use the old feeder-id if you already have one.

it should look like this

RECEIVER_OPTIONS="--net-only --lat 39.9 --lon 44.7"

then restart dump1090-fa again.