FlightAware Discussions

After update to 3.8.0: Connected to Mode S receiver, but no recent data seen

After the update to the latest version, the data was lost. The configuration files were not updated. Version with Flightaware beastsplitter.

PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”

piaware-status
PiAware master process (piaware) is running with pid 567.
PiAware ADS-B client (faup1090) is running with pid 756.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is running with pid 1600.
Local ADS-B receiver (beast-splitter) is running with pid 549.

beast-splitter (pid 549) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

the Mode-S Beast serial port is NOT producing data on localhost:30005.

What’s your configuration?

Raspberry pi 3+, Flightaware Stick + Raspbian stretch (SD image).

Why do you need beast-splitter at all?

Is it this station: https://flightaware.com/adsb/stats/user/OlegMenkov#stats-92755

Then you are running the piaware sd-card image.

This should fix it:

sudo piaware-config receiver-type rtlsdr
sudo reboot

If it doesn’t, please show the output for this command:

piaware-config

I am use usb flightaware beast-splitter

This is not something the beast-splitter is needed for.
You’ll have to better explain your setup if you don’t want to try what i proposed.
(which is the correct thing to do for the flightaware prostick)

1 Like

Sorry! I am use usb flightaware modes-beast from FlightAware box.

Error fixed! -

Please add option INPUT_OPTIONS="–serial /dev/beast –fixed-baud 1000000" in /etc/default/beast-splitter

1 Like

So this is a disassembled FlightFeeder?

If you can reassamble it and run the standard FlightFeeder image, that’d be great.

Unfortunately, this happened after a lightning strike and the raspberrypi burned out. So I restored it by running on a new raspberry pi4. I had to install a Raspbian buster version on pi4.

1 Like

Aha! Ok, that makes sense. Currently the FlightFeeder image is still on stretch, so it won’t work on a Pi 4 at the moment. (we do plan to update it to Buster - it just hasn’t happened yet)

In any case, I independently restored the receiver to work by buying burnt raspberries and I’m honest with the company)
Currently, everything works well on Buster.

1 Like