FlightAware Discussions

No Data to FA

Hello,

I am getting the below:

pi@raspberrypi : ~ $ sudo piaware-status

PiAware master process (piaware) is running with pid 1203.

PiAware ADS-B client (faup1090) is not running.

PiAware ADS-B UAT client (faup978) is running with pid 2149.

PiAware mlat client (fa-mlat-client) is not running.

Local ADS-B receiver (dump1090-mutabi) is running with pid 583.

Local ADS-B UAT receiver (dump978-fa) is running with pid 2141.

no program appears to be listening for connections on port 30005.

dump978-fa (pid 2141) is listening for connections on port 30978.

faup1090 is NOT connected to the ADS-B receiver.

faup978 is connected to the ADS-B UAT receiver.

piaware is connected to FlightAware.

got ‘couldn’t open socket: cannot assign requested address’

dump1090 is NOT producing data on localhost:30005.

dump978 is producing data on localhost:30978.

Your feeder ID is XXXX (configured at /etc/piaware.conf:10)

Any suggestions?

Why did you change the configuration to receive 978 MHz?

Is that on purpose?

Most likely you changed to UAT/978 MHz reception without knowing that that is not what you want.

To revert to the normal settings:

sudo piaware-config receiver-type rtlsdr
sudo piaware-config uat-receiver-type none
sudo systemctl restart piaware
sudo systemctl restart dump1090-fa
1 Like

Stop deleting your posts :slight_smile:

According to the screenshot you misconfigured fr24feed.
It needs to be set to receiver: beast-tcp and host: 127.0.0.1:30005

Use this, it will fix the fr24feed settings: https://github.com/wiedehopf/adsb-wiki/wiki/Bundle-install-for-dump1090fa

1 Like

So did the changes work?
If not, please show this:

sudo journalctl --no-pager -u dump1090-fa

It is not on purpose

Yes, the changes worked!! Thanks for the help. I’m just starting out with this, so I’m learning on the go.

Hi there,
This is regarding RadarBox24, I am getting the attached errors and I cannot figure out why.

Any ideas?

You need to use network mode as explained in their README.

Otherwise it tries to use the local dongle, which is already used by dump1090-fa.

Network mode means it will get the data from the dump1090-fa that’s already running.

Open file rbfeeder.ini

sudo nano /etc/rbfeeder.ini 

Check that network_mode is set to true, as shown below in bold

And check that those network settings are like the above.

Thanks guys. But I am now getting this error.

Code:
pi@raspberrypi:~ $ sudo systemctl status rbfeeder
● rbfeeder.service - RBFeeder Service
Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled; vendor preset:
Active: active (running) since Fri 2019-09-27 14:34:59 UTC; 8min ago
Process: 19860 ExecStop=/bin/kill -TERM $MAINPID (code=exited, status=1/FAILUR
Main PID: 20973 (rbfeeder)
CGroup: /system.slice/rbfeeder.service
├─20973 /usr/bin/rbfeeder
└─20986 /usr/bin/python3.5 /usr/bin/mlat-client --input-type dump1090

Try following. What you get?

sudo systemctl stop rbfeeder
sudo rbfeeder

For your reference, I get this:
(SCROLL DOWN THE OUTPUT TO SEE IT IN FULL)

[2019-09-27 14:02:41]  Compiled with arch=raspberry
[2019-09-27 14:02:41]  Starting RBFeeder Version 0.2.20 (build 20190905011053)
[2019-09-27 14:02:41]  Using configuration file: /etc/rbfeeder.ini
[2019-09-27 14:02:41]  Network-mode enabled.
[2019-09-27 14:02:41]           Remote host to fetch data: 127.0.0.1
[2019-09-27 14:02:41]           Remote port: 30005
[2019-09-27 14:02:41]           Remote protocol: BEAST
[2019-09-27 14:02:41]  System: raspberry
[2019-09-27 14:02:41]  Start date/time: 2019-09-27 14:02:41
[2019-09-27 14:02:41]  Socket for ANRB created. Waiting for connections on port 32088
Fri Sep 27 14:02:41 2019 mlat-client 0.2.10 starting up
Fri Sep 27 14:02:42 2019 Connected to multilateration server at mlat1.rb24.com:40900, handshaking
Fri Sep 27 14:02:42 2019 Server says:

        AirNAv Server

        The multilateration server source code is available under
        the terms of the Affero GPL (v3 or later). You may obtain
        a copy of this server's source code at the following
        location: https://github.com/mutability/mlat-server

Fri Sep 27 14:02:42 2019 Handshake complete.
Fri Sep 27 14:02:42 2019   Compression:       zlib2
Fri Sep 27 14:02:42 2019   UDP transport:     disabled
Fri Sep 27 14:02:42 2019   Split sync:        disabled
Fri Sep 27 14:02:42 2019 Input connected to 127.0.0.1:32457
Fri Sep 27 14:02:42 2019 Input format changed to BEAST, 12MHz clock
Fri Sep 27 14:02:42 2019 Beast-format results connection with 127.0.0.1:32004: connection established
[2019-09-27 14:02:42]  Connection established.
[2019-09-27 14:02:43]  Connection with RadarBox24 server OK! Key accepted by server.
[2019-09-27 14:03:11]  ******** Statistics updated every 30 seconds ********
[2019-09-27 14:03:11]  Packets sent in the last 30 seconds: 885, Total packets sent since startup: 885
[2019-09-27 14:03:42]  ******** Statistics updated every 30 seconds ********
[2019-09-27 14:03:42]  Packets sent in the last 30 seconds: 1419, Total packets sent since startup: 2304
[2019-09-27 14:04:13]  ******** Statistics updated every 30 seconds ********
[2019-09-27 14:04:13]  Packets sent in the last 30 seconds: 1453, Total packets sent since startup: 3757

I get the following that gets stuck in trying to establish a connection…

Blockquote
pi@raspberrypi:~ sudo systemctl stop rbfeeder pi@raspberrypi:~ sudo rbfeeder
[2019-09-28 16:04:14] Compiled with arch=raspberry
[2019-09-28 16:04:14] Starting RBFeeder Version 0.2.20 (build 20190905011053)
[2019-09-28 16:04:14] Using configuration file: /etc/rbfeeder.ini
[2019-09-28 16:04:14] Network-mode enabled.
[2019-09-28 16:04:14] Remote host to fetch data: 127.0.0.1
[2019-09-28 16:04:14] Remote port: 30005
[2019-09-28 16:04:14] Remote protocol: BEAST
[2019-09-28 16:04:14] System: raspberry
[2019-09-28 16:04:14] Start date/time: 2019-09-28 16:04:14
[2019-09-28 16:04:14] Socket for ANRB created. Waiting for connections on port 32088
Sat Sep 28 16:04:15 2019 mlat-client 0.2.6 starting up
Sat Sep 28 16:04:15 2019 Connected to multilateration server at mlat1.rb24.com:40900, handshaking
Sat Sep 28 16:04:15 2019 Server says:

    AirNAv Server

    The multilateration server source code is available under
    the terms of the Affero GPL (v3 or later). You may obtain
    a copy of this server's source code at the following
    location: https://github.com/mutability/mlat-server

Sat Sep 28 16:04:15 2019 Handshake complete.
Sat Sep 28 16:04:15 2019 Compression: zlib2
Sat Sep 28 16:04:15 2019 UDP transport: disabled
Sat Sep 28 16:04:15 2019 Split sync: disabled
Sat Sep 28 16:04:15 2019 Input connected to 127.0.0.1:32457
Sat Sep 28 16:04:15 2019 Input format changed to BEAST, 12MHz clock
Sat Sep 28 16:04:15 2019 Beast-format results connection with 127.0.0.1:32004: connection established
[2019-09-28 16:04:15] Connection established.
[2019-09-28 16:04:26] Could not start connection. Timeout.
[2019-09-28 16:04:44] ******** Statistics updated every 30 seconds ********
[2019-09-28 16:04:44] Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0
[2019-09-28 16:04:56] Connection established.
[2019-09-28 16:05:06] Could not start connection. Timeout.
[2019-09-28 16:05:15] ******** Statistics updated every 30 seconds ********
[2019-09-28 16:05:15] Packets sent in the last 30 seconds: 0, Total packets sent since startup: 0

I was able to fix the issue with reinstalling RBFEEDER.

Thank you all for your help!

1 Like

:+1: :+1: :+1:
Glad to know you have fixed the issue.