FlightAware Discussions

Succesfully shared ADB-B Flight feed to Flightradar24

After image is written, and microSD card is still in card reader of Desktop/Laptop, Enable ssh.

To enable SSH:

In File Explorer, double click the drive letter of microSD card. This will open the folder /boot and show lots of files and some folders. Right click in /boot folder, and create a new blank file named ssh or ssh.txt

Open terminal and give following command
$ touch /Volumes/piaware/ssh

I get the impression you are just not receiving anything (as in problems with the antenna or dongle)
Have you taken a look at the local map of piaware?

Sorry, I couldn’t respond. Had used up all my replies.
Yes it appears my Tuner is not functioning correctly. i have ordered a new one that will hopefully arrive this week. My current tuner with I send the command rtl_test bring up the following:

pi@raspberrypi:~ $ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.

Late last week it brought up Fitipower which i know is not capable of 1090Mhz. Early last week it showed up as RTL2838. So I think it is fried.

It is just being used currently you need to stop dump1090:

sudo systemctl stop dump1090-fa

But that doesn’t really matter if it is a FitiPower tuner, those are not compatible with ADS-B (1090 MHz)
(so it might pretend to work fine but is never actually receiving anything because the reception is terrible)

1 Like

Yep, time to wait for my new tuner:

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Fitipower FC0012 tuner
Supported gain values (5): -9.9 -4.0 7.1 17.9 19.2
Sampling at 2048000 S/s.

The dongle has two chips.
The rtl_test shows both.

If the Tuner is R820T, it suits 1090 Mhz (Type 1 in table below)
If the Tuner is Fitipower 0012, it does NOT suit 1090 Mhz (Type 2 in table below)

Type Tuner Chip Receiver Chip Dongle Suitable for ADSB
Dongle Type 1 R820T2 RTL2832U YES
Dongle Type 2 FC0012 RTL2832U NO

Yes, i have a 1090Mhz antenna mounted on the roof. i will wait until my new tuner arrives.

Thank you for your assistance.

Second that re Virtual Radar Server, excellent program.


I found the link above extremely helpful!

I bought the FlightAware ProStick Plus, followed the instruction to image the PiAware. Then run a couple “sudo” commands to feed FR24. FlightAware Stick Pro is the best investment I’ve ever made = 29 + 7 antenna!

1 Like

What do you mean with those numbers?

Looking at your stats you have a lot of room for improvement, what antenna are you using?

I mean currency :smile: ProStick Plus + 1090 Antenna => $29.00 + $7.00 = $36.00

For the antenna, I’m using the onelinkmore 1090Mhz Antenna MCX Plug Connector 2.5dbi Gains ADS-B.

1 Like

One of the typical GSM whip antennas which aren’t really for 1090 MHz. (no matter what the description said, i’ve seen countless of those)

See this thread on how to improve your reception significantly:
How to improve performance of whip antenna of DVB-T

1 Like

I have above one, and it is no better than the one in photo below:

Please see this thread:

Trial Run Results for Three Types of Whip Antennas


Raspberry Pi Zero W not expensive, under a third of the cost of a normal Pi. You would need also though a micro USB to USB adapter as it doesn’t have full sized USB port.


That was the first step i did. Remove the tip and replaced it with a copper wire in the required length.

This made a good improvement compared to the default setting, i am using the blue pro plus stick as well.

In one mag-mount, I cut the removeable part of original whip to 52 mm (the one over cookie can in photo in my last post above).

In second mag-mount unscewed the original whip, and in it’s place used a 52 mm long thin steel tie-wire (photo below)

I did not cut it, because i have concerns destroying things :slight_smile: