RTL-SDR V3 issues activating bias t


#1

Further to my previous ?? lol, definitely having an issue activating the bias t with the V3. Now the dongle is working, with map, graphs and downloading to FA, but I can not get the bias t to activate. I have tried the methods mentioned, blacklisting the usb drivers etc, but I am still getting the error “usb_claim_interface error -6”. There is a work around mentioned, but it is for the FA version of 1090 and the files/directories mentioned, I can not find.

Jeff


#2

Ok, with the bias t files loaded, mutability turned off, using rtl_test -t, I get

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
what I should be. On using ./rtl_biast -b 1, I get 4.5v out of the V3 dongle, yay !!

But as soon as I turn mutability back on, back to error “usb_claim_interface error -6” and ./rtl_biast -b 1, no voltage.

So it works but I need to find the correct scripts, using 1090 mutability, for the two to work together.

Jeff


#3

Stupid idea,
but the bias should be activated before the mutability starts… IF the stick is in use then you cant activate the bias-tee.


#4

Не было опыта использования USB - SDR Рафаэль микро R820T2 тюнер ??? :open_mouth:Именно T2, а не Т !:face_with_raised_eyebrow::face_with_raised_eyebrow::face_with_raised_eyebrow:


#5

Yes it appears that way, mutability off before you can activate it but resets and can’t be used when mutability is back on. The reason I need autonomous actions is that PI3 B+ and a POE hat, RTL-SDR V3 and a RTL-SDR Blog ADS-B Triple Filtered LNA, (which is bias t powered, the reason for buying the RTL-SDR V3 dongle), are all going up on the mast, connected to the WWW via network cat 6 cables, so I need to have something that will turn off and on with power via power over ethernet. There was a fix amongst these posts but it is all written for a 1090 FA setup, hence with most of these scripts, there is usually a 1090 mutability version as well.


#6

Yes in all scripts, they state at that stage is says R8020T tuner not the R8020T2, something in the script but if seen, with the rest of the status, your drivers are working!! :slight_smile:


#7

Went through the same problems - Have a look here @obj helped to find the answer :slightly_smiling_face:

Enable BiasT on RTL-SDR v3 before Dump-FA/Piaware start


#8

From the RTL-SDR Blog User Guide:

To enable the bias tee in Linux:

In Linux or MacOS download the source from git, compile it the same way you do the regular RTL-SDR drivers, and then run ./rtl_biast -b 1 to turn the bias tee on and ./rtl_biast -b 0 to turn the bias tee off. The procedure is:

git clone https://github.com/rtlsdrblog/rtl_biast
cd rtl_biast
mkdir build
cd build
cmake …
make
cd src
./rtl_biast -b 1

If you want to be able to run the bias tee program from anywhere on the command line you can also run “sudo make install”.


#10

That is the fix I am talking about but it is designed for the 1090 FA engine, not the 1090 mutability version and like your self, I could not find some of the directories or files he spoke of and trying to do what you did with a new directory, absolutely no good. :slight_smile:


#11

Well I have established that there is nothing wrong with the driver install for the V3, this problem all relates to the bias t install and operation, whilst 1090 mutability is working, getting that" usb_claim interface error -6".


#12

From https://github.com/mutability/dump1090/issues/211
User gleven managed to get it to work. Maybe contact him/her.

I have it working for dump978, however I have an older version that required soldering.


#13

Solved it with one little addition to the script, gained from https://www.raspberrypi.org/forums/viewtopic.php?t=81731, one small little deviation, in instructions on this site, it stated
“additionally after the
cmake …/ -DINSTALL_UDEV_RULES=ON
run the command
ldconfig”

I did that but got an error creating the cached, however this works:

git clone https://github.com/rtlsdrblog/rtl_biast
cd rtl_biast
mkdir build
cd build
cmake …/ -DINSTALL_UDEV_RULES=ON -DDETACH_KERNEL_DRIVER=ON
make
cd src
./rtl_biast -b 1

The addition was in the cmake … line.

Now have 1090 mutability working AND 4.7 volts leaving the V3 and powering my LNA. :slight_smile:


#14

Hmm may be not quite. When I reboot, stop 1090 mutability, go into the relevant directory, rtl_biast/src and re issue the ./rtl_biast -b 1 commnad, I get this error “-bash: ./rtl_biast: No such file or directory” ??


#15

The rtl donlges only allow one program to connect to it at a time. If dump1090 is connected to the dongle then you would need to stop dump1090 before you run the rtl_biast program.

The “usb_claim interface error -6” is because the RTL device is used by another program.

To stop dump1090 you can “kill” the program OR use systemd to stop it:

sudo systemctl stop dump1090-fa
or
sudo systemctl stop dump1090-mutability
or
sudo killall dump1090-fa (must have killall installed)

You can restart the program with

sudo systemctl start dump1090-fa

You can see active programs by running

top
OR
ps aux

“./rtl_biast: No such file or directory””
You can use the find command to see where the program is located.

sudo find / -name rtl_biast

The ./ in front of the command ./rtl_biast -b 1means run the command relative to the current directory.
You can also run rtl_biast from the absolute directory found by the find command.

If you run “sudo make install” after making the rtl_biast program it will install the command. You can then run the command with no path such as “rtl_biast”


#16

Would it be possible to have the rtl_niast program and the switch to turn it at the appropriate time included in the next image of piaware released by Flightaware.

I run a standard piaware image on several installation and all the instructions to get, compile and run rtl_biast at the appropriate time in the boot procedure just manage to destroy the working image and I go back to the beginning and start again.

My interest is in RF, antennae, signal, noise, gain and the optimisation of position reports and aircraft. I have no interest in Linux or programming.

I would prefer it added to the Configure page of the My ADS-B page as the neatest option (where gain setting should also be located) but adding it to the piaware-config would be the next best place.

Your consideration would be appreciated.

S.


#17

Changing Piaware Settings Without SSH and Without microSD Card plugged in Desktop


#18

Thanks, but I can’t see how that helps.

I can run SSH and I can plug the microSD card into the computer. It doesn’t help me get the rtl_biast program nor turn it on at the appropriate time.

What am I missing?

S.


#19

In that thread I have suggested facility to set UUID and GAIN etc from Browser on a Desktop/Laptop on Local Network.

Continuing the same philosophy, this facility can also be provided on the “My ADS-B” page, (as suggested by you), which is again a browser interface. Since “My ADS-B” page is accessible from anywhere in the world through internet, it is a much better and more secure option, specially for remotely located sites.


#20

:smiley:

Sorry, I thought you were proffering a solution to my problem where I want to turn on biasT for a V3 dongle.

I agree that much more useful things can be added to the My ADS-B page to make management more readily for those of us who no longer get joy with tinkering in software. (Been there, done that but moved on to bigger and better things and left COBOL and FORTRAN a long time ago).

I would appreciate a definitive list of instructions to create the rtl_biasT program on the piaware image but all the instructions I have found start with running git and it appears that git is not installed on my image.

Hence I keep taking one step forward and two steps back each time I touch it.

I suspect that the answer to my problem will be to wait till after Easter and buy the parts and simply make a 4.5V power injector.

S.


#21

Do this before you start with instructions to create the rtl_biasT program on piaware image.

sudo apt-get update
sudo apt-get install git