FlightAware Discussions

RTL-SDR v3 with bias Tee use with 3.7.1

Thought this might be useful for those that might attempt this setup:

3.7.1 with RTL-SDR v3 + ADS-B 1090 Bias Tee AND secondary 978 radio

Your rtl_test identifies your radios as the following:

Found 2 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000978
1: Realtek, RTL2838UHIDIR, SN: 00001090

You go through the tutorials, but your bias tee isn’t working quite right… you’re getting nothing on your 1090 feed… even with running the command line stop1090/enable bias tee/start1090

Your solution is to tell your software which device you have listed in your rtl_test that you need to enable the bias tee software. You can do this by an additional argument in this bias-t.conf. the “-d” argument identifies which device in the rtl_test list you need to enable your software bias tee in your v3 radio.

[Service]

ExecStartPre=/home/pi/rtl_biast/build/src/rtl_biast -d 00001090 -b 1

A bit of trial and error it took me to find this - nothing was getting thru for me. I knew the hardware worked; I bench tested prior to installation.

Thanks to wiedehopf for the suggested argument switch (the serial instead of dongle number)

Ensure your power supply is adequate… I did get a voltage drop error on my first activation.

Have you tried -d 00001090 ?

Because the other rtl programs happily take serial numbers as well.

I didn’t try using the serial number.

Understand that I do have the serial #s already set for my 1090/978 radios. I didn’t try if a -s 00001090 would work… that might be cleaner… -d is the arg for device, not serial and this information is going into the bias-t config. I’m slightly afraid to try it because I spent almost two hours deciphering what was happening.

It’s fine because the default is -d 0

So if someone is having a problem -d 1 will fix it.

If you ever plug the USB sticks into the RPi the other way around though, you’ll have to change it.

good point. I’m going to try and see if that arg will work in that file

I use these:

https://www.nooelec.com/store/sdr/sdr-receivers/nesdr-smartee-sdr.html

Always on bias tee.

Plus:

https://www.rtl-sdr.com/new-product-rtl-sdr-blog-1090-mhz-ads-b-lna/

sudo systemctl status dump1090-fa
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
   Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dump1090-fa.service.d
           └─bias-t.conf
   Active: active (running) since Fri 2019-06-07 22:25:01 UTC; 3min 38s ago
     Docs: https://flightaware.com/adsb/piaware/
  Process: 469 ExecStartPre=/home/pi/rtl_biast/build/src/rtl_biast -d 00001090 -b 1 (code=exited, status=0/SUCCESS)
 Main PID: 631 (dump1090-fa)
   CGroup: /system.slice/dump1090-fa.service
           └─631 /usr/bin/dump1090-fa --net-bo-port 30005 --fix --device-index 00001090 --gain 49 --ppm 0 --max-range 360 --net --net-heartbeat 60 --net

Jun 07 22:24:59 piaware dump1090-fa[469]: Found 2 device(s):
Jun 07 22:24:59 piaware dump1090-fa[469]:   0:  Realtek, RTL2838UHIDIR, SN: 00000978
Jun 07 22:24:59 piaware dump1090-fa[469]:   1:  Realtek, RTL2838UHIDIR, SN: 00001090
Jun 07 22:24:59 piaware dump1090-fa[469]: Using device 1: Generic RTL2832U OEM
Jun 07 22:24:59 piaware dump1090-fa[469]: Found Rafael Micro R820T tuner
Jun 07 22:25:01 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Jun 07 22:25:01 piaware dump1090-fa[631]: Fri Jun  7 22:25:01 2019 UTC  dump1090-fa 3.7.1 starting up.
Jun 07 22:25:01 piaware dump1090-fa[631]: rtlsdr: using device #1: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00001090)
Jun 07 22:25:01 piaware dump1090-fa[631]: Found Rafael Micro R820T tuner
Jun 07 22:25:01 piaware dump1090-fa[631]: rtlsdr: tuner gain set to 49.6 dB
Warning: dump1090-fa.service changed on disk. Run 'systemctl daemon-reload' to reload units.

So it looks like the -d 00001090 does work, but I’m getting this warning now at the end of the log.

I’m actually running the non-bias tee version at this very moment on my 978 radio. It’s an experiment; I’ve been having some poor 978 performance.

Of note: I had considered that I had light GA traffic. Then another user had posted on this forum that they was seeing 100+aircraft on 978 traffic per day. I’m about 60 miles from that user… so me seeing 1-5 per day wasn’t making sense.

I’m running the FA antennas, I have both blue and orange FA radios, the nooelec dongle, and just put in the rtlsdr v3 + 1090bias tee to attempt to improve performance… I’m still learning all the software and such along with experimenting with the best possible performance setup; I live in an area where I am not allowed exterior antennas per the HOA; antennas are in the peak of my townhome attic, which is ~~ 40’ up from ground level.

Yeah it won’t actually use the changed file until you do that reload.
(sudo systemctl daemon-reload)

But the bias-t is switched on anyway until the next boot, so if it doesn’t work it won’t necessarily show.

So best to check by rebooting and checking the reception afterwards.
If it doesn’t work change it back.

1 Like

both arguments work -d 00001090 and -d 1

So using -d 00001090 is cleaner. Thanks :slight_smile:

Yeah it will survive changing USB ports for whatever reason along the way :slight_smile:

If you just started with the rtl-sdr LNA with v3 dongle, you should start with a gain of 28 or 25.

You probably have the complete setup in the attic?

A few modifications from this, as I have different radios in place. This is in a closet on the 3rd floor; our first 90 degree day had my pi up to almost 70’C so I changed the setup. I did start in the attic though :slight_smile:

So now the antennas and the bias-tee that chrisjohnston50 linked up top are in the attic. The green(black) 1090FA antenna ----> FA light blue filter ------->ADS-B LNA ------ > Times Microwave 99-6MMB-ON0F —[project box]—> rtl-sdr v3 ----->usb extension 1’ ------> usb hub ------>Pi

I ditched the anker power supply for a ‘Plugable USB 2.0 Powered Hub’ ; it was on a site that found it compatible to power both the Pi and accessories. I did get some performance improvement going this route. I added in ferrites and shorter USB extension cables, as the FA radios cannot sit side-by-side.

I lost my powerline adapter to a nearby lightning strike/power surge (you can see the adapter sideways in the picture) along with three ports in the router I had nearby. I had been struggling with wifi performance so I invested in a Netgear Orbi and have my ethernet lines and improved wifi performance on this level of the house.

The blue plastics are 3d printed and I pulled a CAD for my project box. In the top of the box is a case fan to ensure everything stays cool inside.

I plan on running the script for setting gains.

I’m not too far away from getting an o-scope and doing more optimizing…

I’m becoming a bit of a junkie with it… before my power surge… my numbers were top 100 … dropped a bit when my site was down.

Lose the FA filter, not needed with the rtl-sdr LNA.
You can try it for 978 though.

2 Likes

[quote=“Shadowchasr, post:12, topic:50926”]
as the FA radios cannot sit side-by-side
[/quote]

I noted your comment about having the radios side-by-side. May I have a little elaboration please.

You cannot plug them directly into Pi…

Right you are…thanks.

These you can:

1 Like