FlightAware Discussions

RTL V3 bias T can't enable

I just purchased the LNA to hook up to my v3 RTL unit. I have followed the directions on this site : https://www.rtl-sdr.com/getting-the-v3-bias-tee-to-activate-on-piaware-ads-b-images/ and every time I try to enable the Bias T i get the below error. Help please

pi@piaware:~/rtl_biast/build $ sudo service dump1090-fa stop && cd ~/rtl_biast/build/src && ./rtl_biast -b 1 && sudo service dump1090-fa start
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM

Kernel driver is active, or device is claimed by second instance of librtlsdr.
In the first case, please either detach or blacklist the kernel module
(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6

I should also mention, I need to be spoon fed commands to try, I am not a linux guy what-so-ever

Add some modules to a blacklist, then reboot:

echo -e 'blacklist rtl2832\nblacklist dvb_usb_rtl28xxu\nblacklist rtl8192cu\nblacklist rtl8xxxu\n' | sudo tee /etc/modprobe.d/blacklist-rtl-sdr2.conf
sudo reboot

Alternatively you can go back to the cmake line of the guide and replace it with this line

cmake .. -DDETACH_KERNEL_DRIVER=ON

And then of course finish the guide :wink:

I left a comment on the rtl-sdr .com guide page, but the guide hasn’t been changed yet.

perfect! thanks! I will continue with the guide now and keep plugging along

1 Like

If you aren’t confident in changing gain yourself, i would recommend this script to automatically adjust the gain:
https://github.com/wiedehopf/adsb-wiki/wiki/Automatic-gain-optimization-for-dump1090-fa

A good starting point with that combination is 28.

The default setting for gain will not work well.

1 Like

i’ll give that a shot and see what happens, thanks!

If you want to kick start the automatic gain adjustment, you can use this command:

sudo /usr/local/bin/dump1090-fa-autogain

Don’t run it more often than every 5 minutes or so.
It will only work if there are a few planes around.

1 Like

Tested on freshly written Raspbian Buster WITHOUT installing any version of dump1090

sudo apt update
sudo apt-get install git cmake libusb-1.0

git clone https://github.com/rtlsdrblog/rtl_biast
cd rtl_biast 
sudo mkdir build
cd build
sudo cmake .. 
sudo make
cd src
./rtl_biast -b 1

Found 2 device(s):
  0:  Failed to query data
  1:  Failed to query data

Using device 0: Generic RTL2832U
usb_open error -3
Please fix the device permissions, e.g. by installing the udev rules file rtl-sdr.rules

.

Workaround for usb_open error -3 (missing udev rules)

sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules" 

sudo reboot 

After Reboot

cd rtl_biast/build/src
./rtl_biast -b 1
Found 2 device(s):
  0:  Realtek, RTL2832UFA, SN: 00000101
  1:  Realtek, RTL2838UHIDIR, SN: 00000102

Using device 0: Generic RTL2832U

Kernel driver is active, or device is claimed by second instance of librtlsdr.
In the first case, please either detach or blacklist the kernel module
(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6

Workaround for usb_claim_interface error -6 (Thanks to @wiedehopf)

cd
sudo rm -rf rtl_biast
git clone https://github.com/rtlsdrblog/rtl_biast
cd rtl_biast
sudo mkdir build
cd build
sudo cmake .. -DDETACH_KERNEL_DRIVER=ON
sudo make
cd src
./rtl_biast -b 1
Found 2 device(s):
  0:  Realtek, RTL2832UFA, SN: 00000101
  1:  Realtek, RTL2838UHIDIR, SN: 00000102

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Reattached kernel driver
1 Like

your problem is the decoder (dump1090-fa) or (dump1090-mutability) that ‘claims’ the receiver
at boot time.

this is my workaround

I created a file named mybiast/sh in /home/pi as follows
sudo touch mybiast.sh

made it executable with
sudo chmod +x mybiast.sh

edited the file
sudo nano mybbiast.sh

then added the following lines

sudo killall dump1090-fa &
sudo /home/pi/rtl_biast/build/src/rtl_biast -b 1 &
wait 3 &
sudo service dump1090-fa restart &

saved and exit with Ctrl+W, Ctrl+X

to avoid having to run it every time after reboot
as biast ‘resets’ itself added an extra line in /etc/rc.local
(before the line exit 0)

edited the file
sudo nano /etc/rc.local

added
sudo /home/pi/mybiast.sh &

saved and exit with Ctrl+W , Ctrl+X

reboot and works fine.

HTH
evangel

1 Like

.
No version of dump1090 was installed.
You missed the title of my post:

That’s incorrect, that’s not the problem with the commands he used.

In the guide he is using the bias t is activated each time before dump1090-fa is started.

The error he showed, he stopped dump1090-fa in the same command before using the bias-t command.

there was no dump1090-fa or dump1090-mutability installed when I built & tested biast.
Please see the title of my post.

Irrelevant to this thread, but w/e :slight_smile:

Yeah i assumed evangelyul was talking about the problem the tread starter had.

1 Like

sorry, you are right I missed it all together, not sure why though. apologies :wink:

Neither was there any rtl-sdr blog v3 dongle connected (I dont have one).
Only FA ProStick (RTL2832UFA, SN: 00000101)
and
RB24 FlightStick (RTL2838UHIDIR, SN: 00000102)

On this RPI, I normally run a microSD card with following (two in one :slight_smile:)

  • 2 x Antennas (PCB and Optimized mag-mount)
  • 2 x dongles
  • 2 x dump1090-mutability
  • 2 x piaware (Stations 5252 and 76000)
  • 2 x fr24feed
  • 2 x pfclient

For biast test, I slipped out regular microSD card and slipped in a test microSD card with freshly written Raspbain Buster :slight_smile:

No need to apologize, it happens with all of us.
The bright side is that we now know a new workaround:

1 Like

thanks @abcd567
btw abcd was using a similar LNA type to yours (some time ago you posted, I think was RCA up to 2GHz input dc 5-15V) with cantenna with good results from 70nm range went up to 120nm, and no filter only the v3.

284

1 Like