RTL-SDR V3. Experiment to Enable Bias-T


#1

I did a test with dump1090-fa on Piaware SD Card image:
Build & used package rtl_biast.
Dongle used was DVB-T, as I do not have RTL-SDR V3, hence cannot check with a Voltmeter.

The success was checked by outputs to log file. The log file showed that the software rtl_biast did get hold of the Dongle under command rtl_biast -b 1, and then released it for dump1090-fa to use. Finally dump1090-mutability was found working OK (checked by command top).

STEP-1:

Build package rtl_biast

#First installed Packages needed to build and to fulfill dependencies
cd ~/
sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install libusb-1.0

#Now build rtl_biast
git clone https://github.com/rtlsdrblog/rtl_biast
cd ~/rtl_biast
mkdir build
cd build
cmake ..
make


#TEST-1
cd ~/rtl_biast/build/src
./rtl_biast -b 1

usb_claim_interface error -6


#TEST-2
sudo systemctl stop piaware
sudo systemctl stop dump1090-fa

cd ~/rtl_biast/build/src
./rtl_biast -b 1
Found Rafael Micro R820T tuner

STEP-2:

Created a script which has two parts.
(a) First part is command to switch on bias-t
/home/pi/rtl_biast/build/src/rtl_biast -b 1

(b) Second part is command to redirect output (stdout + stderr) to a log file biast.log to see what is happening.
> /home/pi/biast.log 2>&1

#Created a new blank script file "biast-switch-on.sh"
sudo nano ~/rtl_biast/build/src/biast-switch-on.sh

#Added following text to newly created blank file

#!/bin/sh
/home/pi/rtl_biast/build/src/./rtl_biast -b 1  > /home/pi/biast.log 2>&1
exit 0

#Saved file (Ctrl+o) and Closed (Ctrl+x)

#Made newly created file executeable
sudo chmod +x  ~/rtl_biast/build/src/biast-switch-on.sh

STEP-3:

Created log file biast.log and made it writeable

touch ~/biast.log
chmod a+rwx ~/biast.log

STEP-4:

Edited file dump1090-fa.service
sudo nano /lib/systemd/system/dump1090-fa.service

In this file, just above the line "ExecStart=/usr/bin/dump1090-fa \", ADDED line shown below:

ExecStartPre=/home/pi/rtl_biast/build/src/biast-switch-on.sh

Here is the complete file dump1090-fa.service AFTER ADDING the line starting with ExecStartPre=

# dump1090-fa service for systemd

[Unit]
Description=dump1090 ADS-B receiver (FlightAware customization)
Documentation=https://flightaware.com/adsb/piaware/
Wants=network.target
After=network.target

[Service]
EnvironmentFile=/etc/default/dump1090-fa
EnvironmentFile=-/var/cache/piaware/location.env
User=dump1090
RuntimeDirectory=dump1090-fa
RuntimeDirectoryMode=0755
ExecStartPre=/home/pi/rtl_biast/build/src/biast-switch-on.sh
ExecStart=/usr/bin/dump1090-fa \
 $RECEIVER_OPTIONS $DECODER_OPTIONS $NET_OPTIONS $JSON_OPTIONS $PIAWARE_DUMP109$
 --write-json /run/dump1090-fa --quiet
Type=simple
Restart=on-failure
RestartSec=30
Nice=-5

[Install]
WantedBy=default.target

STEP-5:

Tested by rebooting, then checking contents of log file ~/biast.log

sudo reboot

#After reboot, check log file
cat ~/biast.log
Found Rafael Micro R820T tuner

#BINGO! SUCCESS

STEP-6:

By command top, checked that dump1090-fa and Piaware are running. FOUND RUNNING OK

top - 03:59:56 up 1 min,  1 user,  load average: 0.43, 0.18, 0.06
Tasks: 129 total,   2 running, 127 sleeping,   0 stopped,   0 zombie
%Cpu(s): 11.8 us,  2.7 sy,  0.0 ni, 85.0 id,  0.0 wa,  0.0 hi,  0.5 si,  0.0 st
KiB Mem:    947732 total,   154888 used,   792844 free,     9960 buffers
KiB Swap:        0 total,        0 used,        0 free.    73048 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
  657 dump1090  15  -5   25556   6792   2232 S  25.1  0.7   0:16.16 dump1090-fa
  394 root      20   0    2352   1248    980 R  23.1  0.1   0:15.54 dump978
  393 root      20   0   14736   5356   1488 S   3.6  0.6   0:02.63 rtl_sdr
  564 piaware   20   0   19536   6268   3616 S   1.3  0.7   0:01.09 piaware-console
  372 root      20   0   97772   6352   5204 S   0.7  0.7   0:00.42 rbfeeder
 1013 piaware   20   0   13016   9704   6240 S   0.7  1.0   0:00.55 fa-mlat-client
 1021 pi        20   0    5024   2492   2140 R   0.7  0.3   0:00.14 top
    7 root      20   0       0      0      0 S   0.3  0.0   0:00.29 rcu_sched
  185 root      20   0       0      0      0 S   0.3  0.0   0:00.02 kworker/3:2
  227 root      20   0    8032   2728   2472 S   0.3  0.3   0:01.14 systemd-journal
  399 root      20   0    2232   1156   1080 S   0.3  0.1   0:00.09 uat2json
  488 fr24      20   0   95352   3252   2252 S   0.3  0.3   0:00.23 fr24feed
    1 root      20   0    5420   3992   2776 S   0.0  0.4   0:04.01 systemd


#2

This turned on the volts and powered the amp successfully.

S.


#3

Thanks for pointing out. I have missed @Dxista’s post/RTL-SDR blog, both dated April 26. What I posted above was continuation of my similar work done 3 days before RTL-SDR blog. My work was posted on April 23 for Flightrada24 Pi24 image:

https://forum.flightradar24.com/threads/11826-RTl_SDR-v3-bias-tee-power-on-off?p=104330&viewfull=1#post104330


#4

You do amazing stuff and then document it well. Thanks.

I tried to follow all the various posts on several forums trying to get a simple process to follow to turn on biasT in the V3.

The one Dxista linked to was perfect for me; it was simple and straight forward and worked on a clean piaware image and included loading all the bits like git and utils which I didn’t know I needed when doing my original research.

I’ve done the procedure twice with 100% success.

The amp has been put into service and the power from the V3 is running up the coax as required. I have removed the injector I paid $2 for just last week. Do you need a slightly used injector? Only used with second hand electrons and only on Sundays. :slight_smile:

Keep up the good work.

S.


#5

I have been around forums, discussion groups, and mailing lists for years, albeit not an active participant until recently.

@abcd567 contributions are among the best, if not THE best, I have ever seen. The clarity and level of details are tops. They certainly take a LOT of time, effort, and dedication to put together.

Consider publishing an ebook with the material you have already produced. It’ll not make you rich, but it’ll ensure they are preserved, and help all RadarSpotters whether they frequent forums or not.