FlightAware Discussions

Problem with 978 on Non-SD Card Installation

Hi! Long time reader, first time poster here.

I upgraded my setup from a Pi 3+ to a Pi 4 Model B. When I tried to use the PiAware SD card image like I’ve done previously, the Pi 4 wouldn’t boot and said something about needing a software update. So, I followed this post => Guide to install PiAware on Raspberry Pi 4 and installed PiAware via command line in Raspberry Pi OS.

I’ve previously serialized my two dongles, but now when I try to tell the new installation which dongle to use for 1090 and which to use for 978 I see the following:

pi@raspberrypi : ~ $ sudo piaware-config uat-receiver-type sdr

Set uat-receiver-type to sdr in /etc/piaware.conf:10

pi@raspberrypi : ~ $ sudo piaware-config rtlsdr-device-index 00001090

warning: cannot set option ‘rtlsdr-device-index’, option only supported on PiAware SD card images

pi@raspberrypi : ~ $ sudo piaware-config uat-sdr-device driver=rtlsdr,serial=00000978

warning: cannot set option ‘uat-sdr-device’, option only supported on PiAware SD card images

In light of these warnings, does anyone know how I can tell the new installation which dongle to use for each band? 1090 is currently feeding data as is.

Thanks in advance for any help you can give!

Edit /etc/default/dump1090-fa, include --device-index <serialnumberhere> in the options

Edit /etc/default/dump978-fa, include --sdr driver=rtlsdr,serial=<serialnumberhere> in the options

That seems to have done it. Thanks!