Dual dongle on raspbian/pi4b

I’ve tried searching around but I’m not finding what I need apparently for my set up.

I have the bits and bobs to do a dual sdr dongle set up, using the blue Pro Stick + for 1090, and a nooelec sdr that works for 978. I’ve run them separately on two pi’s- the 1090 setup on a pi4b, and the 978 setup on a pi zero w. Both pi’s are running raspberry pi os (bullseye), not the piaware image. I have enough other services installed and running on the 4b that I can’t (to this point) justify re-imaging with the piaware card.

The 1090 setup has been working great, and as I’ve upgraded components, I find I have the dongle, cabling, and antenna needed to receive 978 UAT signals. Running dual radios is supposed to be possible, but I’m hitting a wall somewhere.

I have run the rtl_eeprom commands to successfully change the serials of the pro stick and the nooelec to be 00001090 and 00000978 respectively.

The advanced settings page seemingly runs through disabling 1090 when enabling UAT, which I’ve successfully done when testing UAT on my pi zero feeder with just the nooelec sdr/978 antenna attached.

Now trying to consolidate to just the pi 4b for both, I’ve been following along with abcd567’s github page to get everything installed and configured. I’ve been using that page since the official flightaware repository doesn’t have arm64 packages.

I guess I’m confused as to:

  • what configs need to be made in /etc/piaware.conf when utilizing two radios on a non-piaware sd image
  • what configs need to look like in /etc/default/dump1090-fa and /etc/default/dump978-fa
    I’ve done the two insertion lines:
    sudo sed -i 's/^RECEIVER_SERIAL=.*/RECEIVER_SERIAL=00001090/' /etc/default/dump1090-fa
    sudo sed -i 's/driver=rtlsdr[^ ]* /driver=rtlsdr,serial=00000978 /' /etc/default/dump978-fa
    and the files reflect those changes. Both have ENABLED= set to yes.
  • likewise what .conf files are symlinked in /etc/lighttpd/conf-enabled/ on a dual radio setup, as my two devices have dissimilar files, and at one point when trying to reinstall everything, the 50-piaware.conf link disappeared. Currently I have enabled:
    50-piaware.conf
    89-skyaware978.conf
    89-skyaware.conf
    90-javascript-alias.conf
    99-unconfigured.conf

If you run the piaware, dump1090-fa, dump978-fa and piaware-web installation scripts from my Github page, then you (or any other user) has nothing to do to configure lighttpd, as it is configured automatically by installation packages.

The only things user has to do is to:
(1) Add your station unique idebntifier by following command (replace xxxxxx by your actual feeder-id / Unique Identifier)

sudo piaware-config feeder-id xxxxxxxxxx 

(2) Serialize the two dongles as 00001090 and 00000978

(3) Add dongle serial numbers to respective config files by following commands

sudo sed -i 's/^RECEIVER_SERIAL=.*/RECEIVER_SERIAL=00001090/' /etc/default/dump1090-fa  
sudo sed -i 's/driver=rtlsdr[^ ]* /driver=rtlsdr,serial=00000978 /' /etc/default/dump978-fa  

Below are screenshots from my Pi4 running 64-bit Raspberrypi OS, and 64-bit packages of piaware, dump1090-fa, dump978-fa, and piaware-web.

 

 

 

I was doing it wrong, apparently. The pi4 I’m using for piaware is a 2GB RAM model. That was enough to get dump1090, piaware, and piaware-web all built. It was not enough for dump978. It tried using the SD card as swap when it ran out of memory, but was never able to push through. Left it run over night, but it still hadn’t completed. 2.1GB probably would’ve been enough memory, but alas…

I swapped SD cards with a pi4 8GB that I could pull out of service for a bit. That extra RAM headroom allowed the 978 bits to compile and install. Swapped SDs back when it was done, and just as you said, nothing further was needed beyond serialized SDRs. All good now.

Though this was sort of a self-made problem: dump978 is available in the flightaware repository for me to install (albeit as armhf arch). The other components wouldn’t install via apt directly, but that one would. So I wasn’t exactly following your scripts.

You are right, initially I faced same problem. Then I built it on 4GB ram Pi4.

To make it very easy for others, I have created my own repository (PPA or personal package archieve) on Github and uploaded the packages I built to this repository.

Now user dont have to compile and built these 64-bit packages. They can add my repository to sources list, then simply issue commands sudo apt install piaware , sudo apt install dump1090-fa and sudo apt install dump978-fa to install 64-bit pre-built packages on a Pi with a ram as low as 1 GB. It is also much faster than building these packages from source code

https://github.com/abcd567a/rpi/blob/master/README.md

 

1 Like