FlightAware Discussions

Help with 978 on new install

Hi all,
New install on clean pi. Two problems I cannot seem to fix.
1: My 978-sdr is being used by dump1090-fa regardless of what I put in rtlsdr-device-index. I would like use to my 1090-sdr for the 1090 band for the better antenna reception. I have tried inputting the serial number in rtlsdr-device-index as well with no change.

rtl_test -d 0 -s 2400000
Found 2 device(s):
0: Realtek, RTL2838UHIDIR, SN: stx:978:68
1: Realtek, RTL2838UHIDIR, SN: stx:1090:75

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.

This file configures piaware and related software.

You can edit it directly or use piaware-config from the command line

to view and change settings.

If /boot/piaware-config.txt also exists, then settings present in

that file will override settings in this file.

allow-manual-updates yes # updated by fa_piaware_config
uat-receiver-type sdr # updated by fa_piaware_config
receiver-type rtlsdr # updated by fa_piaware_config
rtlsdr-device-index 1 # updated by fa_piaware_config
rtlsdr-gain max # updated by fa_piaware_config
rtlsdr-ppm 75 # updated by fa_piaware_config
allow-modeac yes # updated by fa_piaware_config
use-gpsd yes # updated by fa_piaware_config
rfkill yes # updated by fa_piaware_config
uat-sdr-device driver=rtlsdr,serial=stx:978:68 # updated by fa_piaware_config
uat-sdr-gain max # updated by fa_piaware_config
uat-sdr-ppm 68 # updated by fa_piaware_config
feeder-id 7bf5791e-e0f1-49ea-b371-ef7c5760063e # updated by fa_piaware_config
wired-network yes # updated by fa_piaware_config
wired-address 192.168.1.209 # updated by fa_piaware_config

  1. dump978 is not running and I am not sure why.

PiAware master process (piaware) is running with pid 498.
PiAware ADS-B client (faup1090) is running with pid 567.
PiAware ADS-B UAT client (faup978) is not running.
PiAware mlat client (fa-mlat-client) is running with pid 588.
Local ADS-B receiver (dump1090-fa) is running with pid 497.
Local ADS-B UAT receiver (dump978) is not running.

dump1090-fa (pid 497) is listening for ES connections on port 30005.
no program appears to be listening for UAT connections on port 30978.
faup1090 is connected to the ADS-B receiver.
faup978 is NOT connected to the ADS-B UAT receiver.
piaware is connected to FlightAware.

got ‘couldn’t open socket: connection refused’
dump978 is NOT producing data on localhost:30978.
dump1090 is producing data on localhost:30005.

Your feeder ID is 7bf5791e-e0f1-49ea-b371-ef7c5760063e (configured at /etc/piaware.conf:19)

 

Assuming you are using Piaware SD card image, use commands given below.

NOTE: In these commands:

  • Use stx:1090:75 in place of 00001090
  • Use stx:978:68 in place of 00000978

 

I installed piaware on a running but clean pi. using https://flightaware.com/adsb/piaware/install. It does not seem to matter what i put in the piaware-config it runs the 978 sdr in dump1090. I replaced the commands as you described and still get:

pi@piaware:~ $ sudo piaware-status
PiAware master process (piaware) is running with pid 495.
PiAware ADS-B client (faup1090) is running with pid 565.
PiAware ADS-B UAT client (faup978) is not running.
PiAware mlat client (fa-mlat-client) is running with pid 586.
Local ADS-B receiver (dump1090-fa) is running with pid 494.
Local ADS-B UAT receiver (dump978) is not running.

dump1090-fa (pid 494) is listening for ES connections on port 30005.
no program appears to be listening for UAT connections on port 30978.
faup1090 is connected to the ADS-B receiver.
faup978 is NOT connected to the ADS-B UAT receiver.
piaware is connected to FlightAware.

got ‘couldn’t open socket: connection refused’
dump978 is NOT producing data on localhost:30978.
dump1090 is producing data on localhost:30005.

Your feeder ID is 7bf5791e-e0f1-49ea-b371-ef7c5760063e (configured at /etc/piaware.conf:19)
pi@piaware:~ $ sudo rtl_test -d 0 Found 2 device(s):
0: Realtek, RTL2838UHIDIR, SN: stx:978:68
1: Realtek, RTL2838UHIDIR, SN: stx:1090:75

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.
pi@piaware:~ $

pi@piaware:~ $ sudo cat /etc/piaware.conf # This file configures piaware and related software.

You can edit it directly or use piaware-config from the command line

to view and change settings.

If /boot/piaware-config.txt also exists, then settings present in

that file will override settings in this file.

allow-manual-updates yes # updated by fa_piaware_config
uat-receiver-type sdr # updated by fa_piaware_config
receiver-type rtlsdr # updated by fa_piaware_config
rtlsdr-device-index stx:1090:75 # updated by fa_piaware_config
rtlsdr-gain max # updated by fa_piaware_config
rtlsdr-ppm 75 # updated by fa_piaware_config
allow-modeac yes # updated by fa_piaware_config
use-gpsd yes # updated by fa_piaware_config
rfkill yes # updated by fa_piaware_config
uat-sdr-device driver=rtlsdr,serial=stx:978:68 # updated by fa_piaware_config
uat-sdr-gain max # updated by fa_piaware_config
uat-sdr-ppm 68 # updated by fa_piaware_config
feeder-id 7bf5791e-e0f1-49ea-b371-ef7c5760063e # updated by fa_piaware_config
wired-network yes # updated by fa_piaware_config
wired-address 192.168.1.209 # updated by fa_piaware_config
pi@piaware:~ $

So either you used the piaware sd-card image or you named the pi yourself?

If you named it yourself, you’ll need to configure dump978-fa and dump1090-fa in /etc/default/dumpXYZ-fa (files named accordingly).

I’d suggest to just use the piaware sd-card image as the guide for that is good.
For the package addon install the information is harder to find.

@seahawker01

As you have Raspbian image with package install, use commands given below.

NOTE: In these commands:

  • Use stx:1090:75 in place of 00001090
  • Use stx:978:68 in place of 00000978

 

sudo piaware-config uat-receiver-type sdr   
sudo sed -i 's/--device-index 0/--device-index 00001090/' /etc/default/dump1090-fa   
sudo sed -i 's/driver=rtlsdr/driver=rtlsdr,serial=00000978/' /etc/default/dump978-fa   

# Reboot Pi to implement configuration settings 
sudo reboot  

Yes just borrowed the name. Figured it fits. Sorry for the confusion. Thanks for the fix. Its all up and running now.

Is there any chance on noting the documentation on https://flightaware.com/adsb/piaware/install as it makes it seem that piaware-config is all that is needed?

“For further instructions to configure your receiver for 978 UAT, go to our advanced configuration page.”

Thank you! Got it all working now.

@esmathews

It seems to me 978 is mostly supported via the piaware sd-card image …
There shoudl also be documentation or a warning if you use piaware-config options that don’t do anything while using the package install.