FlightAware Discussions

How do you get 978 to work

Hello,
How do you get 1090 and 978 to work with flight aware 3.7.1 Image?
I see there selling antennas but nowhere do I see how to get both or
even 1 receiver to work on 978 with there image file. Do I need some add on from github?
I looked around on this forum and got more confused about it.
Marty

Official Release post with some information:
Announcing PiAware 3! (Latest version: 3.7.1)

More extensive post by abcd567, unofficial:
Piaware SD card image 3.7.1 Quickstart Guide

@esmathews
Your post on 3.7.1 is really hard to find.
Maybe releases should have their own thread made sticky and the old one dropped?
Otherwise people not visiting often have to work through all the clutter in the release thread.

Putting such info on the website somewhere might also be a good idea.

2 Likes

The Quickstart Guide sited above makes it very easy. But 978 is hard. Signal is a lot weaker so antenna needs to be right.

Thanks for the info. Ill give it a try and see what happens.

I get this error when i ran rtl test

Most likely dump978-fa or dump1090-fa still running, so the dongle is already in use.
Expected error.

But the serial numbers are applied that’s what you want to check, is it not?

I see that both were recognized, but was confused about device 0 not opened,
It does not show same error for device 1 and both are plugged in and I rebooted.
So I will have to wait till weather improves and GA aircraft start flying. Are you a
software engineer ? Your knowledge about this program is Great! I just like to tinker
with this stuff and would be lost without people like you to help out.
Thank you
Marty

this command displays manuals for programs that have them.

man rtl_test
OPTIONS
       -s samplerate (default: 2048000 Hz)

       -d device_index (default: 0)

       -t enable Elonics E4000 tuner benchmark]

       -p enable PPM error measurement

       -b output_block_size (default: 16 * 16384)

       -S force sync output (default: async)

The program is meant to test one device at a time, at the beginning it shows an overview of available devices.
Now you didn’t specify which device to test and the default is id 0.

On some other programs like dump1090-fa, there is no manual page.
But you can try “command --help” or “command -h”

dump1090-fa --help

Anyway if you are following the tutorial by abcd567 there are journalctl commands mentioned to check the logs.
In there you can check if they start correctly.