Too early???


#1

It’s 7:19 central tiime so I may be too early running flight planning through it’s paces… Plus figure to give some basic feedback on my experiences on navigating through the web pages.

Problems encountered (obviously beta so expected)

Setting up profiles, I was only able to get one profile successfully set up (climb). I could not delete the erroneous profiles. The erroneous profiles were / (or may) have been user induced by entering too quick without all the fields being completed. I get service interrupted errors at the bottom of the screen (too early?) and there are no “edit” buttons to go back to the erroneous profiles and either edit or delete them.

On altitudes, it was a little confusing on altitudes. Rather then specify 0 1000 2000 3000 and so on, if it’s possible to set up a range of altitudes I.E 0-4000, 6000-9500 and the like. If it’s there already, then maybe an example provided above the box.

I saw airports on the flight planning part listed, probably from past flights for suggested departure and arrival. Are they suppose to be clickable?

For mandatory entries, have the web page prompt you immediately rather then get an error page after entering the data. I tried the flight plan part, didn’t put in the min / max altitudes and was prompted on a subsequent page to put these values in. I had to use the back button to get to the fields again and then add them. I then got service interrupted errors on the bottom of the page. Experiences have been using the back button is taboo for re-entering data and the web page should provide it’s own back button embedded in the web page.

Well enough for this posting, back to playing with the flight planning :smiley:

EDITED to add the following.

Can’t play with the flight planning. Unable to add profiles to drop downs which I am betting is causing the service error at the bottom of the page. It’s not even seeing the successful climb profile I did manage to get in.

Can’t add new pilot information…


#2

Figure to add an updated posting. While I wasn’t able to get the results of a flight plan, I did get further in flight planning. A lot of these problems may be user induced from the setup problems.

I went back in to try and flight plan and got a little better reactions from the web page.

I was able to get the performance drop downs to come in AFTER I saw my alternate airport pop up on the right (it didn’t do that the first time). I think the failure the first time was me putting in the same altitude for minimum and maximum altitude (it is clear in the instructions, but I didn’t read it close enough).

So, maybe there is a bug when a user selects both minimum and maximum the same value? Should be a prompt to revise one or the other if it can not or should not be the same.

Seems that when you get it right as you go down, the web page behaves, but when I go to proceed, I am still getting that service error at the bottom of the web page and that may be due to me not having my profile properly set up.

EDITED to add.

One last thought, maybe some validation of field entry should be in order before allowing to proceed to the flight planning part. I suspect all parts heavily rely on each other, maybe step by step order from pilot information first, then lead on to aircraft data and then finally flight planning so the setup goes more orderly.

If something is missing, then have that page alert you before you proceed on?


#3

I figure to bop in to see if I could complete a flight plan. It is now 12:50 central time.

I see edit buttons have been added for aircraft performance since my morning post, but still not able to edit the category (or delete). I get service interruption at the bottom of the page when I click on the button.

Still cannot add new pilot, now I get java error in the lower left corner. and nothing happens on the web page I am using MSIE 6.0 at work.

Tried flight planning and no different then earlier this morning, unable to create a flight plan. Same error at the bottom of the web page service interruption.

This time I tried with aircraft performance and also NOT selecting an aircraft to see if maybe my setup was messing things up. Both yielded the same results with service interruption.


#4

Seeing some improvement :smiley:

While not very obvious as the cursor doesn’t change to an arrow or a hand (remains an I beam look when hovering over the buttons), the buttons are clickable for flight planning, click on the suggested airport and it will fill in the departure and destination airport.

I also see you can click on the proposed departure time and it will fill it in based on the button you click on (now, 1 hour or 3 hour, I like this!!!)

Clicking on the nearby airport I see will fill in the the alternate (maybe an instruction box to click on airport name?)

I think maybe the verbage “hold altitude” should show “final cruise altitude” making easier to understand.

Also again, need a prompt showing it’s missing before being able to proceed to the next page “plan flight”

Still cannot get past the initial input screen as when I click on plan flight I still get We’re sorry, but FlightAware has encountered an unrecoverable error and is unable to process your request at this time. Please wait a few moments and try your request again. If the problem persists, please contact us. Tried both with my erroneous aircraft performance data and nothing at all.

The above is a huge step (and progress) but no flight plan. Still using MSIE 6.0 if this makes any difference.

Editing performance data still remains the same, unable to make changes to the ones where I erroneously pushed enter before entering data. The one I did manage to get in, I can access it and edit the fields.


#5

Back home…

Took another stab at this with Firefox and no change from above… Same symptoms, only thing different was the reply back from FA.

It only said “Service Interruption” with no contact information.

I will say, I LOVE just clicking on the airports in question, clicking on the fuel price to propagate to the price field and once this gets under way, it looks to be very user friendly.

Couple of more suggestions while I am on the roll :open_mouth:

Allow user configuration for most common airports (maybe the allowance for three buttons to the right of the last three airports shown)

Allow the saving of flight levels (set as default in profile) so it doesn’t have to be retyped every flight plan.

Same with aircraft data, save the settings for people like me that only flies one bird.

Enough for now… :smiley:

Thanks for a really, REALLY practical product!!!


#6

Progress YEAH!

Not sure if something changed since last post, but I don’t see where I tried to set up the pilot using Firefox so I gave it a whirl and that worked! Interesting to see my weight asked :slight_smile: soo maybe weight and balance tools coming???

Anyhow, I got myself set up and successfully saved it.

I decided to create a new aircraft profile and I was able to successfully set up the complete profile with my Climb, Cruise and Descent Profiles.

Tried Flight Plan with all my new found data stored, still no joy… System interruption

One bug encountered. I cannot delete my “older aircraft”. I click Delete this aircraft and it doesn’t go away.

Fortunately I had made the L lower case so I can tell the difference between the two (the good profile is upper case L) until this is resolved.


#7

I don’t have time to read your whole thread now, but I will later and I can offer the following. Hold down shift and refresh the page to resolve most interface issues; browsers are caching our old javascript which doesn’t support the new stuff.

The performance data is intended to be at points, not over ranges. Give us your climb speed and sea level and 4000 ft and we’ll interpolate between them.


#8

Mark,

The interface within Firefox 3.0.3 works wonderfully going through the individual pages and buttons work perfectly, only minor display issues with the mouse over the buttons (doesn’t display as clickable). I will check at work with MSIE 6.0 to verify if I can get to the pilot data. At home, no problems whatsoever.

My problem at home starts with
flightaware.com/flightplan/manage/aircraft?id=22

I did what you said above, shift and refresh, and then clicked Delete Aircraft.

It immediately takes me to flightaware.com/flightplan/manage/aircraft however the plane still remains in the table.

In my new setup, I put in 0 and 7000. I can’t seem to edit the altitude (I am 325 MSL) after entry, just fpm and fuel. Maybe that could be built in for future consideration (ability to edit altitude) OR autofill based on your home airport in your profile???

Once I figured out what the entries were looking for on my “second airplane” it went real fast and made much more sense , just wasn’t sure with the sample numbers provided whether you were looking for every 1000 feet.

Still won’t create a flight plan… Still get that server interruption at the bottom of the screen even after shift reload BEFORE entering data. Can’t do it after, it wipes it out.

I think I am good to go with my “2nd aircraft” and my pilot profile, now ready to generate that elusive flight plan page :slight_smile:


#9

Let’s keep all the replies in your summary thread just so we’re not bouncing back and forth.