Skyview trouble


#1

Since yesterday my skyview is stuck during the loading phase. My settings haven’t changed. According to /var/log/piaware.log all the data is being uploaded to FA without issues, so it’s the web gui that is not working. I checked the lighthttp log and found nothing and restarted the raspberry from cold. Also I tried to access skyview from different computers/browsers to discard some local problem.
Any suggestions before reinstalling everything?
TIA


#2

So you have loaded the map. Otherwise the screen would be blank. It needs a connection to the external internet to do that. The next step is to load the history and current aircraft json files. I’m guessing this is around 22:30 hours. Are there planes in the area? Presumably yes. Try loading the aircraft.json file directly and see if you can get it: http://Your-Pi-IP-address/dump1090-fa/data/aircraft.json You should see some data dump onto the web browser screen. If you look closely there will be a section in brackets for each aircraft currently being tracked.


#3

Ok, I loaded aircraft.json as you suggested and got some results. It seems there are 9 airplanes around here now. Here’s the last output from piaware.log:

Oct 15 02:11:37 piaware piaware[455]: 37960 msgs recv’d from dump1090-fa (185 in last 5m); 37960 msgs sent to FlightAware
Oct 15 02:16:37 piaware piaware[455]: 38074 msgs recv’d from dump1090-fa (114 in last 5m); 38074 msgs sent to FlightAware
Oct 15 02:21:37 piaware piaware[455]: 38161 msgs recv’d from dump1090-fa (87 in last 5m); 38161 msgs sent to FlightAware

And below is the screenshot from aircraft.json. Once strange I noticed thing is that the maps displayed is centered in Italy, but I’m located in Argentina/South America.

Screenshot_2017-10-14_23-19-04


#4

Check your internet connection. And your lat/long in FA… don’t forget you need the minus sign on both!


#5

I checked both things but found nothing wrong up to now…


#6

Try reclaiming your Pi.

Maybe your IP address, somehow, got changed.


#7

Hmmm, I’m stumped. Maybe someone else has an idea? Sorry.


#8

I’ve tried resaving the FA settings but all seems to be ok: https://flightaware.com/adsb/stats/user/limaunion


#9

Ok, no problem. If I don’t have this fixed by monday I’ll reinstall everything from scratch.
Thanks anyway for your help!


#10

Check the browser console (e.g. F12 on Chrome) for errors when it’s stuck.


#11

Skyview page only opens in Chrome with errors:

http://192.168.1.52/favicon.ico Failed to load resource: the server responded with a status of 404 (Not Found)

http://192.168.1.52/dump1090-fa/upintheair.json Failed to load resource: the server responded with a status of 404 (Not Found)


#12

@rugomol: are you experiencing the same situation?

By following the @obj advice, I found this behaviour (browser console from firefox):

403 - Forbidden for different internal pages like:
http://192.168.1.51:8080/data/receiver.json
http://192.168.1.51:8080/data/upintheair.json

A couple of days ago I tried to install the web portal from adbs-receiver and this problem began once a rebooted my raspi. I’m starting to think that that failed installation messed up my configuration. Maybe someone can share it’s /etc/lighhttpd/conf-available files or let me know from where can I download them, in order to check if there’s any difference.

Thanks


#13

These are normal. (SkyView doesn’t have a favicon, and upintheair.json is loaded if present otherwise ignored)


#14

They are available here: https://github.com/flightaware/dump1090/tree/master/debian/lighttpd


#15

@limaunion Yes, the same situation with Skyview in different browsers, except Chrome
This problem has existed for several months on my FlightFeeder (7.7.1) .

In Opera:

Failed to load resource: net::ERR_CONNECTION_RESET http://192.168.1.52:8080/jquery/jquery-ui-1.11.4.min.js


#16

Well, I was finally able to fix this by deleting some erroneous lighttpd config files that were installed by some other external package. I simply mounted the piaware.img (*) and replaced /etc/lighttpd/conf-enabled with the files from the image, then restarted lighttpd. Everything is working now. Hope this helps someone that messes up his configuration.

Thanks all of you for your previous comments.

(*): sudo mount -o loop,offset=138412032 Downloads/piaware-sd-card-3.5.0.img /mnt


#17

I am not aware of this problem, can you provide more detail?


#18

@obj All browsers, except for Chrome, try to open the link ( 192.168.1.52:8080 ) for a few minutes. Dump1090 map view in some browsers becomes visible in the background of the scripts download window. But this download process never ends.


#19

This sounds like a network problem specific to your installation - I don’t see that on any of my test flightfeeders here. What is your network setup?


#20

Wi-Fi.
TP-Link TL-WN727N on FlightFeeder 6.
And Wireless Dual Band Router TP-Link TL-WDR3500