PiAware SkyView not working

Any thoughts as to why I am getting this non-working page when I click on the SkyView link? This is my second Pi, my first worked without issue. Any thoughts? It works fine and uploads tracking data, I just cannot view the map on this Pi.

  1. Clear browser’s cache (Ctrl+Shift+Delete) and reload browser (Ctrl+F5).

  2. If above does not solve problem, try another browser. For example if you are using Google Chrome, try Firefox, or Internet Explorer or Safari.

  3. What address you typed in address bar of browser?
    Try following:

Thanks for the reply. I have tried multiple browsers on multiple computers, all the same. I am using the :8080 path.

Did you try ip-of-pi/dump1090-fa/

Yes, that link does work, just not the clickable link from the My ADS-B page.

This seems to be an old post, but to me this looks like you’re running a script blocker in your browser (such as noscript, no-script suite light, etc). Images and text show up, but nothing else can run. Could also be a popup blocker like uBlock, but I’ve not seen this happen too many times with those.

I had an issue with a new set up (outdoor antenna,prostick plus, rasp-pi B+, etc. … ham station) where skyview wouldn’t load. I thought, hmmm … it did initially. I perused my router’s admin page and found the MAC address differed from my ADS-B stats page and hadn’t realized it until skyview stopped working. It appears that if you use Raspberry pi and piaware in DHCP, powering down or upgrading and restarting can assign a new MAC address. For me, deleting the old piaware in my router adminstrative tools, unplugging and re-powering raspberry pie resynchronized the MAC address.

Everything is fine now. The folks at Github and rasperry pi community forums have wholly good intentions, but this didn’t require a software fix and worked like a charm here (NYS). I hope someone finds this useful and my apologies if I’ve posted to an inaccuate thread.