FlightAware Discussions

Skyview - cannot access - Help Please

Hi All,

New user here. I’ve installed PiAware on my RasP4b 10(buster) install, hooked up my FAPro+ and 1090 antenna and can see my data populating as username Charles Jessee near MHT. View Live Data gives:

This site can’t be reached

10.0.0.115 refused to connect.

  • Search Google for 115 8080
    ERR_CONNECTION_REFUSED

10.0.0.115/dump1090-fa/ doesn’t work either. I’ve tried a few things in Norton Security Suite Firewall without success. Disabling AV & Firewall didn’t work.

Any help appreciated!

Bret/N4SRN

Can you check the IP address your computer has?

I’d suspect you are somehow on a different WiFi or network.

Or maybe piaware is displaying the wrong IP address, if you can check what your router assigned to the RPi.

is a simple ping to that ip-adress working?

Yes. ping 10.0.0.115 gives a scrolling stream of data

Thanks for the help!

dump1090-fa is not a web page. Try 10.0.0.115/tar1090 and 10.0.0.115/graphs1090 instead.

No luck with those. I did this:

sudo netstat -tlnpu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:2947 0.0.0.0:* LISTEN 1/init
tcp 0 0 0.0.0.0:30002 0.0.0.0:* LISTEN 483/dump1090-fa
tcp 0 0 0.0.0.0:30003 0.0.0.0:* LISTEN 483/dump1090-fa
tcp 0 0 0.0.0.0:30004 0.0.0.0:* LISTEN 483/dump1090-fa
tcp 0 0 0.0.0.0:30005 0.0.0.0:* LISTEN 483/dump1090-fa
tcp 0 0 0.0.0.0:30104 0.0.0.0:* LISTEN 483/dump1090-fa
tcp6 0 0 ::1:2947 :::* LISTEN 1/init
tcp6 0 0 :::5000 :::* LISTEN 475/pat
tcp6 0 0 :::80 :::* LISTEN 595/apache2
tcp6 0 0 :::30002 :::* LISTEN 483/dump1090-fa
tcp6 0 0 :::30003 :::* LISTEN 483/dump1090-fa
tcp6 0 0 :::30004 :::* LISTEN 483/dump1090-fa
tcp6 0 0 :::30005 :::* LISTEN 483/dump1090-fa
tcp6 0 0 :::30104 :::* LISTEN 483/dump1090-fa
tcp6 0 0 :::30105 :::* LISTEN 1468/fa-mlat-client
tcp6 0 0 :::30106 :::* LISTEN 1468/fa-mlat-client
udp 0 0 0.0.0.0:68 0.0.0.0:* 467/dhcpcd
udp 0 0 0.0.0.0:38612 0.0.0.0:* 336/avahi-daemon: r
udp 0 0 0.0.0.0:5353 0.0.0.0:* 336/avahi-daemon: r
udp 0 0 127.0.0.1:323 0.0.0.0:* 549/chronyd
udp6 0 0 :::59316 :::* 336/avahi-daemon: r
udp6 0 0 :::546 :::* 467/dhcpcd
udp6 0 0 :::5353 :::* 336/avahi-daemon: r
udp6 0 0 ::1:323 :::* 549/chronyd

Hmm, my install requires inclusion of a port number with the URL. So it is https://http://10.0.1.50:8080/. Of course yours would be the Pi’s actual IP number. That “Search Google” message you pasted initially makes it seem like the colon might be missing?

Is your Pi headless or can you view it via a monitor with HDMI? If you can hook up a monitor and keyboard you could try using an IP of 127.0.0.1 instead of the actual IP address (that is a shortcut meaning to connect to the computer you’re running on, new actual network connection is used; also known as localhost).

I’ve tried 10.0.0.151:8080 and 127.0.0.1:8080 without success, although I can ping both. Wonder if another app is using that port? What’s that 595/apache2 I’m seeing?

You’ve installed apache.

dump1090-fa assumes lighttpd.

Of course it is. That’s the default Skyview once you installed dump1090-fa and it is working.

tar1090 and graphs1090 are only extensions which will not work without dump1090-fa

IP-of-Pi/dump1090-fa is of course a web page.

IP-of-Pi/tar1090 and IP-of-Pi/graphs1090 will only work if someone has installed these, and not everyone installs these.

Is that something I have to fix/change?

Should I try to install these? If so, how?

Any useful information here?

sudo piaware-status
PiAware master process (piaware) is running with pid 618.
PiAware ADS-B client (faup1090) is running with pid 743.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is running with pid 1468.
Local ADS-B receiver (dump1090-fa) is running with pid 483.

dump1090-fa (pid 483) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.

Your feeder ID is e0df51dd-4e42-46d3-a8bb-26821f2444cb (from /var/cache/piaware/feeder_id)

No, you dont have to install tar1090 or graph1090 to see SkyView web page in your browser. What you need to install is lighttpd web server, but seems you have installed apache web server, did you?

Right now, my RasPi4b is setup with a lot of HAM Radio apps that use apache. I should probably get a dedicated RasPi for Flight aware…

Is there a way to have both installed for now?

I am not sure, but as far as I know having both apache and lighttpd most likely will cause conflict.

Theretically it is possible to serve SkyView (dump1090-fa) web page using Apache, but will require reconfiguration of Apache to do so. Some one who has already done this may help you.

Actually dump1090-fa will have installed lighttpd as a dependency.

Do this:

sudo nano /etc/lighttpd/lighttpd.conf

Change server.port to 99 for example.
Ctrl-X to exit, y(yes) and Enter to save.

sudo systemctl restart lighttpd

Now you should have the webinterface at http://10.0.0.151:99/dump1090-fa
Probably :8080 will work now as well.

Until now lighttpd couldn’t start because port 80 was already occupied.

If this doesn’t work, please show the debug log for lighttpd:
https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands

I decided to make a dedicated Pi and did the Howto : Piaware SD card image 3.8.0 Quickstart Guide flash of another microSD and associated my account with that installation. Skyview comes up as expected.

Thanks for all the help guys - I’m learning KISS :wink:

1 Like

you should remove your feeder-id from the post above. This id you should not share.