FlightAware Discussions

PiAware SkyAware Map

Hello ,

Need some help.

Updated to Version 3.5 today , all went Ok. Updated Dump1090 also , all Ok…

Reading , on this site , that the new Version 3.5 , has the ability to do , “PiAware Sky View User interface Dump1090 Map View” …

How does one get the , “Sky View” map to display ??

My System : Purchased the , “Pre packaged” , SD Card . Had Version 3.1 on it , now 3.5. … Raspberry Pi 3, FlightAware ADS-B -BandPass Filter , FlightAware Pro Stick USB Receiver , Power Supply , FlightAware 1090 - outdoor antenna. Receiving , up to 40+ aircraft …

All the hardware and software work perfect … I am on , "Wired " , internet , not wireless…

Any and all help , that you can give me on how to active the , “Sky View” , would be much appreciated …

Thank You ,

Darryl

if I understood right that is nothing new, as is simply as going to your site adsb ip address port 8080
ex: 192.168.xxx.xxx:8080
let me know if you need something else.
Cheers

Sent from my SM-N910F using Tapatalk

1 Like

Be sure to clear your browser’s cache in order to activate Skyview.

I wish to thank the following members for their help ::JVCDCARLOS ; CHRIS JOHNSTON 50 & ABCD567.

I got it to work , thanks to you .

Darryl

Wow just updated , nice improvement! info at the click of your finger

RCH3325

If you aren’t sure what the IP address is for the Pi there should be a link to the SkyView page directly from your Flight aware stat page. It says “Web Interface: View Live Data”. You have to be on the local network to see the SkyView. I just set up a VPN so I can see my SkyView remotely now.

Much appreciated!

1 Like

I like the map view but would like to see it via the hdmi port on the raspberry pi. I understand this is a web browser app, but the PiAware image doesn’t load a GUI to launch a browser from. Anyone know how to make it do that?

As Piaware image is built using Jessie Lite image (stripped down), the method shown on these pages for Raspbian Lite & Jessie Lite may also work for Piaware image also.

I have NOT tried these, so cannot tell anything with surety.

[GUIDE] Raspbian Lite with PIXEL/LXDE/XFCE/MATE/i3 GUI
https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=133691

Add GUI to Jessie Lite
https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=177910
On this page someone has suggested:



sudo apt-get install raspberrypi-ui-mods


The method using Local_IP_NUMBER:8080 works from outside the internal network if the port 8080 is added to the router’s forwarding rules, to redirect incoming packets to the Local_IP number.
The IP is replaced with the Internet (external) IP: External_IP_NUMBER:8080

PS: FA_IP_NUMBER/dump1090-fa/ shows the same page when inside the network.

a method working for me (install LXDE desktop - lightweight) as follows:


 sudo apt-get install -y xinit 
sudo apt-get install -y lxde-core lxterminal lxappearance
sudo apt-get install -y lightdm
sudo apt-get install -y midori

after all installations complete run sudo raspi-config and select 3 Boot Options.
in boot options select B1 Desktop / CLI .
in the new tab select B4 Desktop Autologin Desktop GUI

reboot and now the LXDE desktop will appear on your HDMI monitor.
run Midori (web browser) and try the url 127.0.0.1:80 or 8080 or dump1090-fa, to view the map.

HTH

Greetings,
Can somebody help me in configuring my router so that i can view FlightFeeder Skyview map from outside of my local network, like on my cellphone when i am not at home. I am very new to this and i tried port forwarding in my router with following settings but it didn’t work.
SERVICE PORT: 8080
INTERNAL PORT: 8080
IP ADDRESS: 192.168.0.100 (FLIGHTFEEDER’s IP)
STATUS: ENABLED

I tried on my cellphone by typing my ISP IP address (183.82.66.77:8080) but it didn’t work. I have TP-Link router and FlightFeeder 7.7.1.

Thanks

1 Like

Hi I have the same question. How can I make the rasberry pi HDMI port to show me the skyview map?

You’ll need to install the GUI on your Pi. I’ve done this on a Pi running Stretch Lite with the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt install raspberrypi-ui-mods

Then reboot.

I haven’t tried this with the piaware image but it’s based on Raspbian Lite so it’s worth a try. If it breaks, don’t blame me though.

1 Like

Thank you for the reply. Do I just type in the commands you mentioned at my Rasberry Pi? When you say install the GUI, does it need to be downloaded from somewhere else or already there?

The goal for me is to have the Skyview Map on all the time, so my kids can see planes outside, run back in, and learn about the airplane. This is so I don’t have to use my regular computer to do this.

So I got a new monitor dedicated to my Rasberry Pi. Then I realized that it only shows the terminal command window not the map. :frowning: So I’m trying to see if my Rasberry Pi can do both tracking the flights and showing the map to the monitor I got.

Expert advice needed!

I had a similar problem and solved it by using an old computer.

When i realized how much power the always- on pc used i bought all the bits to run a Pi Zero W and stuck it on the back of the monitor.

I loaded an operating system that included a browser.

Using a separate pc or pi meant i didn’t have to risk one of the Pis that is up and running and feeding reliably.

It is powered from the usb port on the monitor.

From memory the Pi and all the cables and adaptors cost about 10 or 12 $ plus about$4 for the microSD card.

S

1 Like

That’s literally all I did. Ran each command, one at a time (it takes a while to complete the final command as that’s what actually does the work) to install the gui and once I’d done it and rebooted, I was able to log on to the graphical user interface and run a browser.

As I said, I’ve done this on the ‘lite’ version of Raspbian and it works perfectly well.

1 Like

I just updated piaware to 3.7.2 and skyview is still out. No other configuration changes; skyview vitual radar worked until very recently with piaware 3.7.1. I have received auto generated fault messages from skyview suggesting a dump 1090 failure and used the reboot command several times. New flash is my next option. Ideas?

Show the output for:

sudo journalctl --no-pager -u lighttpd
ls /etc/lighttpd/conf-enabled