PiAware SkyAware not showing any aircraft

Hi there,

Got my flight stick pro and PI4 all setup.

I have no problem is seeing aircraft on the map when I use SkyAware Anywhere - that works fine.

However when I used PiAware SkyAware (on my LAN) it just shows the map but no aircraft at all.

Any help gratefully appreciated

When you are viewing the PiAware SkyAware page do you have a value for Position History and ADS-B Message Rate? If other than zero is it changing? Make sure the boxes for ADS-B, MLAT, Other and TIS-B are selected.

Did you by chance adjust gain manually or are you using the adaptive gain rate?
Setting gain wrong is also a source for failures from time to time


Thanks for the reply. No, all this I have not changed, when I use SkyAware Anywhere it works fine, I can see all my ADS-B, MLAT aircraft - no probs at all.

But when I use Skyward (on my local network with the IP for the PI4) it just shows the map and zero flight data


1 Like

Hi Mark

I can see all my ADS-B, MLAT aircraft - no probs at all but only when using SkyAware Anywhere.

If I IP to my PI4 (addresses it just shows a map, no aircraft data, there is not even a option to show ADS-B on the right hand side.



Does the top right of your map page look like my screenshot minus the red arrow? If it does click on the box that my arrow is pointing to (Toggle Sidebar).

Aircraft 002c

This next screenshot will show the boxes below the aircraft data that will select what data source you want to view on the map. If that does not work post a picture of your map page and maybe we will see something else that would be a clue.


Hi Mark,

Thanks for the detailed reply, much appreciated.

Yes, I have these boxes and can track aircraft but only by using the SKyAware Anytime’ link as seen on my sats page (remote interface its called in site information).

However if I try to use PiaWare SkyWare (requires local network connection) it does not do anything at all.

I’m guessing now that I have to have a server running on the PI4 to use this. Is this correct? And any tips getting one installed greatly appreciated,



Yes, this is typically installed while getting dump1090-fa set up as instructed.

Did you try reinstalling the whole thing as described on FA setup guide?

Hi there,

Thanks for the reply. I think so, I followed the instructions as described. Is there a way to ‘activate’ the web server on the PI4 do you think?


The web server should be running already as it is part of the install. It sounds as if you might have a local network problem of some sort.
Where are you trying to view the local map from?
Is it from a computer on the local network?
Can you ping the PI4 from that computer?

Also is the pi connected via a WiFi or a wired connection?
Is the computer you are trying to access it from WiFi or wired?
If one or both are WiFi do you have isolation enabled in your router?
Something like this:

Try installing tar1090 and see if that works … it fixes a couple common lighttpd issues: GitHub - wiedehopf/tar1090: Provides an improved webinterface for use with ADS-B decoders readsb / dump1090-fa

1 Like

Fantastic Wedehopf! It now works, did as you said and now I have local access.

Cheers again

Nick :grinning:

I’m curious, I see you are using the SD card image. Did you install anything else that might have caused the web server to stop working or was this just a straight SD install with no additions?

@NickBeer Can you take a look at your browser’s console logs whenever you load SkyAware to see if there’s any useful info?

It was a standard install from the SD card. It worked perfectly except for the local web server on the PI4, so when wiedehopf gave me the tip above for tar1090 now it works, no probs at all and very fast.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.