FlightAware Discussions

No aircraft showing on SkyAware

In the last couple of days I have stopped seeing aircraft on my SkyAware display. I am still transmitting data to FlightAware but can’t figure out why my SkyAware is blank. I’ve check all my connections and they seem to be OK. In any case, I’m not aware of any changes that have been made to my RPi setup which has been running successfully for about 2 years. I suspect a setting has somehow been changed.
Can anyone advise me what might be wrong? TIA.

https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands#dump1090-fa

Apart from that, Ctrl-F5 is always a good idea in the browser to properly refresh the webpage.

Many thanks for your response. I’ve tried all that you have suggested but unfortunately I still do not have aircraft on the SkyAware display.
Any other thoughts?

Well, show the log obviously, that’s what the link is for.
Lighttpd log doesn’t hurt either.

Also the output from this:

cat /run/dump1090-fa/aircraft.json

If you don’t have console access and can’t get it, really the only thing to do is to reimage …
(For Beginners - How to Get Back Existing Station Number in A Fresh Install)

If unable to debug & solve the issue, then eaay and clean solution is to reimage the microSD card.

Thanks. I suspected I’d have to reimage the SD card. Can you please point me to the page that tells me how to do this?
Also, my stats page does not show my unique identifier. How do I get that?

Did you ever claim your device?
Doesn’t even seem like you have a stats page.

https://flightaware.com/adsb/piaware/build

So … you haven’t tried everything what i suggested because that would include checking the logs on the RPi.
Just say you don’t know what the commands mean …
Anyhow in case you want to have a look at the logs, the commands need to be entered on the console, either locally by connecting a monitor and keyboard or much better due to copy and paste via SSH.
SSH is used like this: For Beginners - How-to SSH to RPi - Setup Putty in Windows

But i presume you’ll just reimage.
You really should be able to find the feeder id on the stats page … have a second look …

I did claim my device, an RPi running 3.7.2. My site is 71356 and in the meantime I’ve found my feeder ID. I’ve been running for over 2 years now and can’t remember how to re-image my SD card. That’s the next step if someone would kindly tell me how to do it.

Thanks for you help and consideration.

Please contact adsbsupport@flightaware.com and we’ll get you sorted out.

Did you follow the links of @Wiedehopf ?

There are the details on how to do that.

Try this one.

  1. Download Piaware sd card image version 3.7.2 on your Desktop/Laptop:
    http://piaware.flightcdn.com/piaware-sd-card-3.7.2.img.zip

  2. Follow this guide. It was written for piaware sd card image ver 3.5, but is applicable to piaware sd card image ver 3.7.2 too:
    https://discussions.flightaware.com/t/bake-a-pi/19886/2

I’ve just ran into this on an Armbian buster fresh install (image downloaded yesterday, kernel 5.3.9).
Appart from the uninstallable dependencies on installing piaware (which I solved, perhaps a dirty way by adding stretch repos to the list), I solved this by reinstalling dump1090-fa and lighttpd.
You may want to backup your dump1090-fa config file before.

Try:
apt remove lighttpd --purge
at this stage it may tell dump1090-fa will be removed as well, confirm.
If it warns some directories could not be removed:
dpkg: warning: while removing lighttpd, directory '/var/www/html' not empty so not removed

dpkg: warning: while removing dump1090-fa, directory '/etc/lighttpd/conf-available' not empty so not removed

Reinstall with apt install dump1090-fa -y
it will reinstall lighttpd in the same stride.

Restore your dump1090-fa config file as needed (and if so, restart service afterwards);

Hope this helps.

Which Pi you are using? I have OrangePi PC, and use following image (downloaded in Sept 2019), and never had any issue installing piaware & dump1090-fa:
“Armbian_5.91_Orangepipc_Debian_buster_next_4.19.59.img”

I have now downloaded the latest image:
“Armbian_19.11.3_Orangepipc_buster_current_5.3.9.img”
I will write it to a spare microSD card, and try to install dump1090-fa and piaware and see how it goes.

Hello,

That machine is an Orange Pi Zero LTS, PCB v1.5, 256MB RAM.
It is used as a test installation, fresh image w/ the latest Armbian release available (Armbian_19.11.3_Orangepizero_buster_current_5.3.9), and I’ve had both the “package is not installable” when attempting to install Piaware and then this blank map issue.

I’ve never had this before either, on my other OPiZs but most are running with Armbian 9 or Buster with an older kernel.

Buster has an issue of dependencies for package install of piaware and dump978-fa.
The package install of dump1090-fa has no issues.
I forgot to mention that to solve the dependencies issue, in Sept 2019 I have done a workaround, and posted it in this post:

NOTE:
I am now in process of installing piaware ver 3.8~dev and dump978-fa ver 3.8~dev (building it from source code). I will shortly post the steps in the OrangePI PC thread I have linked above.
The image I am using now is “Armbian_19.11.3_Orangepipc_buster_current_5.3.9.img”

UPDATE:
Posted method for piaware ver 3.8~dev.

I’ve seen that when I looked for a solution, then I found easier to just add the stretch repo and perform the installation.

Piaware Ver 3.8~dev on Armbian Buster

@obj

EDIT: My mistake. Instead of using ./sensible-build buster, by mistake I used ./sensible-build bionic. Please ignore this post.

I will rebuilt it with ./sensible-build buster.

mlat-client - Fatal Python error: initfsencoding: Unable to get the locale encoding

mlat-client - ImportError: invalid flags 1554269952 in 'encodings’

[2019-12-23 15:17 EST] 3938 msgs recv'd from dump1090-fa (1518 in last 5m); 3938 msgs sent to FlightAware
[2019-12-23 15:18 EST] got EOF from multilateration client
[2019-12-23 15:18 EST] Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.198:5517:2420920541
[2019-12-23 15:18 EST] fa-mlat-client exited with SIG SIGABRT
[2019-12-23 15:18 EST] mlat-client(1369): Current thread 0xb6f7fe70 (most recent call first):
[2019-12-23 15:18 EST] mlat-client(1369): Fatal Python error: initfsencoding: Unable to get the locale encoding
[2019-12-23 15:18 EST] mlat-client(1369): ImportError: invalid flags 1554269952 in 'encodings'

Installation method used:

This will be another case of the bionic rules being out of sync with the updates done for buster I think.

Tonight I will rebuilt piaware for Armbian Buster using ./sensible-build buster.

Apologize for my mistake of using option bionic instesd of buster for Armbian Buster, and posting for solution without first trying to debug.