New PiAware tracking fine but no aircraft on Skyview


#1

Hi,

I set PiAware up last week (on a RPi 3+ with a package install of PiAware on NOOBS) and added an aerial this week (internal by a window for now whilst testing) - you can see my stats are collecting nicely - and the uptick since I added the aerial on 17 April: https://uk.flightaware.com/adsb/stats/user/x3ja.

As you can see it’s picking up plenty of aircraft and positions, but they’re all registering as <50 mi away and when I look at my Skyview there are no aircraft on the map and no Distances showing in the table. Occasionally I see Speed and/or Heading and Altitude seems to work all the time - but never Distance. chrome_2018-04-20_11-58-30

Is this a configuration issue or something to do with the quality / position of the aerial? Any ideas what I can do to resolve it?


#3

Despite your recent improvements, your site is still not working very well. There are a variety of reasons why this may be the case. If you look at one of your near-by neighbor sites for example, you will see a lot more messages and aircraft received: https://uk.flightaware.com/adsb/stats/user/sandalhq

First, check your antenna position. It needs to have an unobstructed clear line-of-sight to the horizon in all directions (clear view to each aircraft). Buildings, trees, mountains, etc. will all block signal. You also may have interference from nearby high-power radio transmitters like mobile phone towers. If you are not using a bandpass filter then you may want to try using one.

To enable MLAT on a PiAware, you need to be receiving reliable ADS-B aircraft signals and have your lat/long set on your My ADS-B page for the site. Since your location is set, you are probably not receiving enough ADS-B aircraft consistently to get MLAT timing synchronized. MLAT will start working automatically when sufficient data is received by your device. Also note that because you’re in the UK, you should expect about 80% of aircraft to be ADS-B equipped. The fact that you’re seeing Mode S only aircraft suggests that you are not receiving very many aircraft messages (so you’re missing the position messages).


#4

Thanks - I moved the antenna the other day and am now getting better signals (approx 10x more), but I think there’s more room for improvement. Currently it’s downstairs so I think I’ll move it upstairs at some point as we have trees around us that will be impacting the signals.

The main thing for me is that I’m now getting long/lat in the JSON data so I can start capturing that and mapping it in my own tool (Qlik Sense).


#5

@x3ja
what receiver do you use? is there a strong mobile phone transmitter or similar near the antenna?