Optimizing my almost-out-of-the-box Piaware setup

So here’s what I have done so far:
Raspberry pi 3b with 16gb sd card, connected to a usb extension cable, connected to the FA stick, connected to the FA filter, connected to an SMA cable, connected to an this antenna on the roof. Because I couldn’t get high enough on the roof yesterday, I have part of the roof blocking coverage. I will have to wait to get it to a better position, but that is in the works.

Thats it. This has been up for about 18 hours now.

It has seen 85 aircraft and 7500+ positions using adsb, and 21 “others”, but no mlat at all.

What can I do to enable mlat? Are there any suggestions on what I can do to make this system more efficient or better?

I haven’t messed around with the raspberry pi at all. I just followed the standard instructions (with optional: outdoor antenna, expanded file-system, and changed default password).

Everything is standard, and working well, but I’d like to see some mlat data, and maybe optimize any settings.

Here are my stats if that would help: flightaware.com/adsb/stats/user/adnanrules

edit: Also, I have done an “upgrade everything” and restarted the raspberry box yesterday.

Any help?

on your FA stats page, is it giving you any errors? IS MLAT enabled on the page? If so how many nearby receivers do you have?

also make SURE your date/time and GPS cords are correct, or MLAT will no work.

  1. No errors from the log on the FA stats page.
  2. MLAT enabled on that page.
  3. 15 nearby receivers (closest is 4 miles, farthest is 27mi)
  4. I entered the GPS coordinated by finding my house on google maps from the FA site information. Because I’m UTC+12, I sometimes get confused about whether I’m on local time or UTC. I corrected this on the pi (which was going by UTC).

check the piaware log file?

Ok, help needed here. what command do i put in the terminal to view it?

I have checked the status via sudo flightaware status, and all works…but don’t know how to view the log file.

do a “cat /tmp/piaware.out”

Everything seems to be enabled and sending messages.

One potential problem, though. It’s 0800 here in local time. But the latest log is writing at 2000, meaning that the time zone is off. Or is that just the UTC that it uses?

In -menu -preferences -raspberry Pi configuration -localisation, the locale and Timezone have been adjusted. And the “date” command in terminal gives the local time and time zone.

Is there a problem with the times on the log reflecting utc rather than local time, or is that normal?

try rebooting the pi and see what happens.

rebooted pi, but the time through the log is still the same. everything seems to be working just as before.


everything seems to be working just as before save the mlat and the log time (if utc output is an error)

Did you accurately set your position on the map for MLAT?

to set the time zone, I went to -menu -preferences -raspberry Pi configuration -localisation, the locale and Timezone have been adjusted. That changed the time zone, so that whenever i give the “date” command in terminal it gives the local time and time zone.

I set the location on the map, perfectly. I just confirmed it. The elevation is a guesstimate based on phone, web data, and altimeter watch.

Time zone now looks good.
MLAT is also now working.

What happened? Did it just need a reboot? I installed it yesterday and then “updated everything”, and gave it a reboot. I wonder why it needed another one after that.

Thanks for all the help, though. I really appreciate it daverdfw, 41south, and jonhawkes2030.

I’ve noticed this before, it can just take a while for MLAT to kick on on new receivers. Looks good now tho.