PiAware Skyview not displaying data


#1

Hi,
I’ve rebuilt my RPi due to FR24 stopping for absolutely no reason and unable to resolve. I put FA on first so FR24 detects dump1090 and utilises that. Both FR24 and FA are doing there stuff now and passing the data to each respectively.

I do have one issue though and that is that Skyview isn’t displaying the data. I see the map but not the aircraft, just displays Spinny.gif.

I’ve tried both port 8080 and /dump1090-fa/ Cleared the cache, tried other browsers but same result.

It was working previously. Any ideas on what I can check?

Thanks


#2

The FR24 problem came because in new version, they removed integral dump1090 (malcolm rob) and in its place included dump1090-mutability ver 1.14. They did not do the integration properly, causing it to crash. On top of that they have an auto-update funtion in their client. Whe new version was released, within a short time the auto update updated ALL RPis, and all stopped feeding FR24.

Now they have rolled back to old version and suggesting manual removal of new version 19-2 and install of old version 18-9.

You may check what versions of dump1090 and fr24feed are curretly installed by following commands. May be you now have both dump1090-fa and dump1090-mutability installed causing your map problem

apt-cache policy dump1090-fa

apt-cache policy dump1090-mutability

apt-cache policy fr24feed

#3

Excellent info and thanks, i’ll check it out tomorrow. If they rolled back and i literally installed just a few hours ago id of thought that i would have been on the previous release, but anyhow i’ll feed back.

Thanks.


#4

Please see this thread for FR24 failure details:

https://forum.flightradar24.com/threads/11589-dump1090-missing-in-latest-debian-package


#5

apt-cache policy dump1090-fa
Installed: 3.5.3
Candidate: 3.5.3
Version table:
*** 3.5.3 500
500 http://flightaware.com/adsb/piaware/files/packages jessie/piaware armhf Packages
100 /var/lib/dpkg/status

apt-cache policy dump1090-mutability
dump1090-mutability:
Installed: 1.14
Candidate: 1.14
Version table:
*** 1.14 100
100 /var/lib/dpkg/status

apt-cache policy fr24feed
Installed: 1.0.18-9
Candidate: 1.0.18-9
Version table:
*** 1.0.18-9 500
500 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages
100 /var/lib/dpkg/status

Your assumptions seem to be correct. I have read the link

When I run:-
sudo apt-get remove fr24feed.
FA Map immediately springs into life.

After fr24feed start. I’m getting:-
Could not connect to tcp://localhost:30005
but both FR and FA are feeding.

I may put this in another thread but with FA I’ve always found MLAT never to be consistently up. Very intermittent and a small amount of logged MLAT signal in comparison to ADSB. There seems to be lots of other “local” MLAT receivers (sync). The log mentions clock stability but the RPI has a substantial PSU, more amperage than required. Any ideas?


#6

It is dump1090-mutability 1.14 clashing with dump1090-fa. You have to:

  1. Remove dump1090-mutability
  2. Reinstall fr24feed

Do NOT use bash script sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)" to install fr24feed as it will again install dump1090-mutability. Use apt-get to install fr24feed.

To summerize, here are the commands:

sudo dpkg --purge dump1090-mutability
sudo apt-get install fr24feed
sudo reboot

I have now found simple & easy workaround for those who have not yet done any extreme remedial actions like fresh install. Please see this thread, though it is too late for you as you have already done fresh install.

Simpe fix for RPi Feeder knocked down by auto upgrade to 1.0.19-2

P.S.
In FR24 settings, do NOT use Receiver = DVB-T
Use Receiver = AVR-TCP and host = localhost:30002
Keep the field COM/DEV/PATH blank.


#7

Thanks.
1.) Now removed dump1090-mutability.
2.) It tells me that fr24feed is the newest version (1.0.18-9)

Both working and importantly Skyview if displaying as normal.

I know the receiver is correct but will confirm host when I’m on the RPI subnet.

I may look at your link for my other RPI as I didn’t fresh-install that, left as-is after the upgrade.

Again thanks


#8

Yes, after they removed newest version 1.0.19-2, the old version 1.0.18-9 became “newest”


#9

Its back to the later version and my FR feed has stopped

apt-cache policy fr24feed
fr24feed:
Installed: 1.0.19-5
Candidate: 1.0.19-5
Version table:
*** 1.0.19-5 500
500 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages
100 /var/lib/dpkg/status

Ive now tried the :slight_smile:Simpe fix for RPi Feeder knocked down by auto upgrade to 1.0.19-2 but to no avail.