FlightAware Discussions

Unable to see Skyview after FR24FEED install

Hello,

I had a working piaware system which showed my Skyview correctly. I wanted to start feeding data to FlightRadar24 so I installed their software.

Now I am unable to view the SkyView, in my piaware logs I see data is being sent to FlightAware so I believe that part is working.

Does anybody have any ideas to get Skyviewer working again?

sudo lighty-disable-mod dump1090

Also let’s check the fr24feed config if the above doesn’t help:

cat /etc/fr24feed.ini

(replace key by xxxxxxxxxxx)

I ran the commands and have pasted the outputs below. One thing I notice on the FR24 local page it shows “127” aircrafts detected but that number has never changed and when I go to view the aircrafts the list is blank. So I am not sure this is working correctly.

pi@piaware:~ $ sudo lighty-disable-mod dump1090
Disabling dump1090
Run "service lighttpd force-reload" to enable changes


pi@piaware:~ $ cat /etc/fr24feed.ini
receiver="beast-tcp"
fr24key="xxxx"
host="192.168.1.27:30005"
bs="no"
raw="no"
logmode="2"    
windowmode="0"
logpath="/var/log/fr24feed"    
mpx="no"    
mlat="yes"
mlat-without-gps="yes"

.

use: host="127.0.0.1:30005"
in place of: host="192.168.1.27:30005"
.
Save file (Ctrl+o) and Close (ctrl+x).

Do not forget to restart fr24feed (or better reboot the RPi) after saving the changes.

sudo systemctl restart fr24feed
.

1 Like

But is your SkyView working again? Try Ctrl-F5 in the browser.

If it’s not you have to check the webserver:

sudo journalctl -u lighttpd --no-pager
1 Like

This worked, I was able to see the SkyViewer and FR24 is recording aircraft correctly.

Thank you!

1 Like

From the “learn something new every day file…” didn’t know there was a web interface to my FR24 feed!

1 Like