FlightAware Discussions

Site local IP address change with new Pi


#1

I have changed my pi for a newer model. I have loaded all the instructions for dump1090 and pi aware. On Flight Aware Sky View I can see the aircraft that my coco is receiving from. However, Neither FA, or 360 Radar are receiving a feed from the pi. I notice that on the “Site Information” section my site local IP is shown as ending in .93, as opposed to the allocation to the new pi of a local IP ending in .203. I have tried to change the new ip back to the old .93 by saving it as a static local IP, by following the instructions on the EE website. It didn’t work. So that begs the question, how do get into the 'Site Information" section to edit the local IP to read .203, and, of course, would that actually help or am I doomed yet again to reformatting the new SDX card and manually re-entering all the instructions


#2

That is the last known IP. As your Raspberry Pi is not even talking to FlightAware at the moment, they don’t know the current address.

Which way did you go, did you use the piaware sd-card image or did you start with another image?

Do you have a keyboard and monitor plugged into the Pi or do you have ssh access?
For checking what is wrong you will need one of those two.

EE? The instructions to changing to a static IP are different with the piaware sd-card, could you link which instructions you followed?

Setting a static IP will lead to problems with internet access if you don’t also specify the other options for a static IP.
If you don’t really need a static IP i would recommend using a dynamic IP.


#3

Wiedehopf, copied and pasted the pi-aware instructions from “Install PiAware on your Raspberry PI”> section 2 “Download and install PiAware” This was after installing Dump1090 from 360 Radar (as I had done on the previous install). The Pi has a keyboard and monitor connected and is located my man cave (Garden Shed?Workshop) but I access it via ssh from my iMac. For the EE router (Bright Box 2) go to https://ee.co.uk/help/phones-and-device/home-broadband/bright-box-2-wireless-router/bright-box-2-advanced-user-guides/bright-box-2-wireless-router-reserve-an-ip-address

Thanks for the speedy reply


#4

Oh that’s not really a static IP then. The router just makes sure to always give the same IP to the Raspberry Pi. (Shouldn’t matter though)

Ok let’s see the output of this command

sudo journalctl -u piaware -en20

Also which image did you use for the sd-card?
Did you use Raspbian or something else?
Or did it come with something written on it?


#5
  • Logs begin at Wed 2019-02-06 13:17:00 GMT, end at Wed 2019-02-06 17:01:44 GMT. –

Feb 06 16:54:54 raspberrypi piaware[560]: Connection attempt with adept server at 70.42.6.156/1200 timed out

Feb 06 16:54:54 raspberrypi piaware[560]: reconnecting in 69 seconds…

Feb 06 16:56:03 raspberrypi piaware[560]: Connecting to FlightAware adept server at 70.42.6.224/1200

Feb 06 16:56:33 raspberrypi piaware[560]: Connection attempt with adept server at 70.42.6.224/1200 timed out

Feb 06 16:56:33 raspberrypi piaware[560]: reconnecting in 59 seconds…

Feb 06 16:57:32 raspberrypi piaware[560]: Connecting to FlightAware adept server at 70.42.6.225/1200

Feb 06 16:57:33 raspberrypi piaware[560]: Connection with adept server at 70.42.6.225/1200 established

Feb 06 16:57:33 raspberrypi piaware[560]: TLS handshake with adept server at 70.42.6.225/1200 completed

Feb 06 16:57:33 raspberrypi piaware[560]: FlightAware server certificate validated

Feb 06 16:57:33 raspberrypi piaware[560]: encrypted session established with FlightAware

Feb 06 16:57:33 raspberrypi sudo[945]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide --all

Feb 06 16:57:33 raspberrypi sudo[945]: pam_unix(sudo:session): session opened for user root by (uid=0)

Feb 06 16:57:33 raspberrypi sudo[945]: pam_unix(sudo:session): session closed for user root

Feb 06 16:57:34 raspberrypi piaware[560]: logged in to FlightAware as user guest

Feb 06 16:57:34 raspberrypi piaware[560]: my feeder ID is f34ab3bc-7dce-42c9-a374-c52d1f6009b4

Feb 06 16:57:34 raspberrypi piaware[560]: site statistics URL: https://flightaware.com/adsb/stats/site/96080

Feb 06 16:57:49 raspberrypi piaware[560]: 51716 msgs recv’d from dump1090-fa (1252 in last 5m); 49187 msgs sent to FlightAware

Feb 06 17:00:46 raspberrypi piaware[560]: timed out waiting for alive message from FlightAware, reconnecting…

Feb 06 17:00:46 raspberrypi piaware[560]: reconnecting in 57 seconds…

Feb 06 17:01:43 raspberrypi piaware[560]: Connecting to FlightAware adept server at piaware.flightaware.com/1200

Raspbian Stretch lite, and no the card was fresh out of the packet from Amazon

Mike W


#6

Ok.

Hmm how did you give it network, wired or wireless?
In case of wireless which configuration did you use?


#7

Did you reset the UUID to the original one?


#8

That doesn’t matter for connectivity.

Somehow the Raspberry Pi can’t even make connections to the internet.
My guess is that the gateway isn’t configured correctly or the Router is configured not to give the Pi internet access.


#9

In the router menu, check to see what IP it associated with the Pi.
Some routers will let you make that ‘static’ and that’s the IP where your VRS should look at.
Internally, feeding from the 30104 port to 30005 is done by the dump1090-fa. On the SD install, the settings can be changed by editing the configuration file. In my experience it can be wrong, that’s why I stopped using the SD card install and switched to add-on method.


#10

netstat -rn should show you your routes.
Generally you should have only one default router, to your router.

The logs above indicate that it is connecting to FA.
"Feb 06 16:57:32 raspberrypi piaware[560]: Connecting to FlightAware adept server at 70.42.6.225/1200

Feb 06 16:57:33 raspberrypi piaware[560]: Connection with adept server at 70.42.6.225/1200 established

Feb 06 16:57:33 raspberrypi piaware[560]: TLS handshake with adept server at 70.42.6.225/1200 completed

Feb 06 16:57:33 raspberrypi piaware[560]: FlightAware server certificate validated

Feb 06 16:57:33 raspberrypi piaware[560]: encrypted session established with FlightAware"


#11

Widehopf,
It’s a wired connection.


#12

Indeed it is connecting i didn’t read the log properly, my bad.

The connection is intermittent though as it timed out 3 minutes later.
Which is really strange because he seems to be connected via ssh.

Anyway you are correct he needs to change his feeder-id as you suggested: For Beginners - How to Get Back Existing Station Number in A Fresh Install


#13

Hi all, just going over this very interesting (and educational) thread I noticed in the download from the Pi.as requested by Wiedehopf, at 16:57:34 -my feeder ID is f34ab3bc-7dce-42c9-a374-c52d1f6009b4. Do I presume that this is my original feeder ID? As Regards Putty, isn’t that Windows only? I shall pop over to " For Beginners…" and see if that feeder id works


#14

You can find your original UUID here


#15

Just scroll up to the top of the thread, somehow the middle of it was linked.

No in the logs is a new feeder-id that was automatically generated.


#16

First delete old log file and reboot to generate new log

sudo rm /var/log/piaware.log

sudo reboot

Now Check full log.
cat /var/log/piaware.log

In the fresh logs, just above or below the line:

“my feeder id is f34ab3bc-7dce-42c9-a374-c52d1f6009b4”

does it say “connected as guest”, or gives your user name & station number?


#17

abcd567, no sign of either. Here’s the script: pi@raspberrypi : ~ $ cat /var/log/piaware.log

Feb 6 19:18:26 raspberrypi piaware[534]: creating pidfile /run/piaware/piaware.pid

Feb 6 19:18:26 raspberrypi piaware[534]: ****************************************************

Feb 6 19:18:26 raspberrypi piaware[534]: piaware version 3.6.3 is running, process ID 534

Feb 6 19:18:26 raspberrypi piaware[534]: your system info is: Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

Feb 6 19:18:27 raspberrypi piaware[534]: Connecting to FlightAware adept server at piaware.flightaware.com/1200

Feb 6 19:18:29 raspberrypi piaware[534]: ADS-B data program ‘dump1090-fa’ is listening on port 30005, so far so good

Feb 6 19:18:29 raspberrypi piaware[534]: Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout

Feb 6 19:18:29 raspberrypi piaware[534]: Started faup1090 (pid 598) to connect to dump1090-fa

Feb 6 19:18:29 raspberrypi piaware[534]: piaware received a message from dump1090-fa!

Feb 6 19:18:57 raspberrypi piaware[534]: Connection attempt with adept server at piaware.flightaware.com/1200 timed out

Feb 6 19:18:57 raspberrypi piaware[534]: reconnecting in 70 seconds…

Feb 6 19:19:00 raspberrypi piaware[534]: 150 msgs recv’d from dump1090-fa; 0 msgs sent to FlightAware


#18

Yeah you have a second problem.

My guess: you messed up something in the router settings.

Your station was transmitting just fine for almost a day: https://flightaware.com/adsb/stats/site/96080

Changing the feeder-id is still a good idea so when the connection works you don’t think again that it’s not working while it actually is :slight_smile:


#19

Check log file again after 10 minutes
cat /var/log/piaware.log


#20

Well well well. in the midst of all this I did what it said in “The Beginners…” thread and then complied with abcd 567 suggestions and inputted them to the PI and guess what? 3 greens! Thanks to all. I really must learn Linux. I think that at 70 I might just have enough time.