FlightAware Discussions

New Router - still sending data but SkyAware address incorrect

I installed a new router (went from a 10/100 to a gigabit). The LAN IP address is 192.168.0.1. The old router was 192.168.1.1. FlightAware is showing than I’m transmitting from my receiver. But the address of the SkyAware is not resolving to the correct new address of my PiAware receiver. If my website diagnostics were not showing traffic, I would think I need to somehow reboot the receiver. Any thoughts or suggestions?

Roger

If the Flightaware page is showing your receiver working, then your profile page should show the local IP of the pi like this:
image

That is the address you need to use to look at your local map page. Depending on how your router is configured, it might be able to resolve local hostnames for you, so you can use the name of the pi rather than the IP address.

Your router probably has settings to configure the built in DHCP server that assigns addresses to machines on the network, so that you can use the address range you want. You can also usually assign a fixed address to a particular client so that you always know what it will be.

1 Like

You can also look at the router admin page and see what devices are attached to your router. You should only have your own household devices attached and not some bandwidth using neighbors tapping into your account. Perhaps create a Guest account with minimal privileges and run the Raspberry Pi on that account. Just in case if someone hacks into your Pi, he cannot then get into the router admin account and mess it up also. Have fun, and enjoy the new router.

1 Like

You can also assign an IP address to the Pi in its configuration. You just want to not use any addresses the router is handing out since you have two cooks (or more) at that point. What I do is tell the router it can hand out DHCP addresses from a certain range, but for things where it’s nice to have fixed IP addresses (security cams, NAS, PiAware, etc), I just configure them with addresses outside the DHCP range.

Some may want to have their configs in only one place, like the router, so as you noted, the router can also hand out specific IP addresses when it recognizes the device’s MAC address.

@rkpeck - your Pi may just have been assigned a different address, and like @astrodeveloper said, if you consult the device list you can find its new address if the router assigned IPs in a different order than before. The device list will show MACs though and probably won’t convert those to devices. You can cross reference to the Raspberry Pi Foundation here though: https://udger.com/resources/mac-address-vendor-detail?name=raspberry_pi_foundation

Or maybe it was set up with a static IP that had the old first three numbers of the IP. There gets to be a lot more possibilities if that’s the case.

So even if tedious, if you start trying to ssh or use the address in the browser into 192.168.0.2, 192.168.0.3, 192.168.0.4, etc, if it was dynamically assigned, you should find it (2-254) Your network must be pretty stable if you haven’t had an issue finding it before if dynamically assigned.

DHCP leases expire though. It might fix itself when it re-negotiates, or if it’s still hanging on, a reboot can fix it.

If it was initially configured with a static 192.168.1.xxx, you may need to take the SD card to another computer and edit the configuration manually to get it on the right subnet. You can also plug it and your computer back into the old router to get things back where you can talk to the Pi to set it to the right subnet for the new router.

Or, just configure the new router to 192.168.1 to make it back like the old system and reboot everything to force renegotiation.

Good luck!

A lot to digest. @SFRobert, great minds think alike. Your last suggestion is what I implemented this morning. I changed the router back to the same ip address as the old router: 192.168.1.1. What’s got me stumped is why I don’t see PiAware in the DHCP client list. 120 minute lease time on addresses.
Can I set a static address in one of the config files on the SD card in the Pi? I don’t see that I’ve done it anywhere.
Thanks to all for your suggestions.

Roger

Just figured it out. The device is not being assigned an address because it’s wirelessly coming through the mesh system (TP-Link Deco m5) that I also installed at the same time as the new router. (trying to get the system up to a 1gb/sec transfer rate - was running old 10/100 devices)

Roger

Setting static IPs is a bit more involved but there’s a guy here who did it on Buster: https://www.raspberrypi.org/forums/viewtopic.php?t=245701

There is a line of thought to keep such configs in one place so you might want to look at doing it on the router, though.

Ah, so if you don’t have a DHCP server on there, you may need to go with static IPs.

Good you found it!