FlightAware Discussions

New FlightAware setup

I am sure this has been discussed before. But I just setup my flight tracker and FlightAware is not seeing it. I am running off of an ethernet so I know that i am getting on the internet for it to see. Any ideas? Please help.

New guy Bill

What do you mean by “not seeing it”? Is this a PiAware sdcard image or a package install? Did you claim the site?

Its a pre-loaded SD card into a Pi4. The Flightaware app is not seeing me to claim it.

Can you explain exactly the steps you’re taking and the results that you see?

If you’re using the PiAware sdcard image, then the simplest claiming process is to ensure that you’re logged into the FlightAware website, then visit the top-level status page at http://IP-of-PI/ and follow the “claim this feeder” link.

Yes, I plugged everything into my Pi4. I have changed the pro-loaded SD card to accept my WiFi. When I go to FlightAware to claim my signal it says to me It cant find any new setups. Not sure if I worded that correctly.

Can you try the claim process I mentioned above?

Also, on the top-level status page, what colors are the status indicators? (Screenshot would be handy). Should look something like this, but with a green radio status:

I copied and pasted the http://IP-of-PI/ and it does not take me to the claim page. It takes me to a bunch of other stuff.

You replaced that with the actual IP address of your Pi, right?

What was the “bunch of other stuff”?

Oh no! How do i find the IP of my Pi?

There are a few ways:

  • If you connect a HDMI display to the Pi, there should be a text status display that tells you the IP address
  • http://piaware/ or http://piaware.local/ may work, depending on your network setup
  • Check the device list on your router / access point / modem for a device named “piaware” and get the address from there

If you have another computer on the same network, you can type arp -a and look for piaware. That should give you the IP address. If not, maybe attach a monitor to Pi4 and the address should be on the console. (In many cases, just browse for http://piaware/ will do without knowing the actual IP address.)

whacky, my Pl4 is not connecting to the WiFi. Here is a screen shot of my wifi setup.

The image on the left-hand side (blue shaded) shows wired-address as 192.168.1.10. If this is correct on your network (i.e., you gave it a static address), then that’s your IP address. Try http://192.168.1.10/. If not, you may want to remove those network lines and let your DHCP server on the Ethernet (which could be your wireless router) assign one for you, and find that address by some other means.

I do notice a conflict on the left-hand side of the screenshot where wired-address is shown; in that part, wired-type dhcp is also shown. If you have indeed assigned a static address, this could be the problem. Additionally, check to make sure if your network’s gateway is indeed 192.168.1.254 as shown.

If, on the other hand, you did not assign static address, i.e., your Pi relies on DHCP (which is default), you need to find out that dynamic address using method suggested above. (If you are unfamiliar with terminal commands and your networking equipment, the easiest method would be to connect the Pi to a modern TV, all of which have HDMI input.)

The Blue side is what its suppose to be, The white side is what I have. I have decided I ordered another 8GB SD card and going to start from scratch! I bought an SD card preloaded and I dont think its correct! LOL Thank you!

Patriot2120
Did you follow this setup guide EXACTLY? PiAware - build your own ADS-B ground station for integration with FlightAware - FlightAware

You can skip Step 2 if you have a prebuilt SD card. OR you can follow step 2 to reuse or rebuild your existing SD card.
ETCHER is a great way to totally wipe the current card files and load the latest Piaware program and latest operating system on your SD card.

I use a downloadable (to your computer) program called Advanced IP Scanner V2 to find my IP address of my Raspberry Pi. You will see every device that is connected to your router. That program will show you the IP address of your Pi.

You can download a simple program to your computer called “PUTTY”. Run it to add your IP address of your Pi, to access the pi from that box. “Yes” to security question, and name will be pi and password will be flightaware.
Then sudo raspi-config to make permanent changes to get your system operating. Be sure to enable the SSH feature after you change the password from “flightaware” to your own personal password for access to the RPi. If you have downloaded the 5.0 version of Piaware, then in a new tab on your browser, type in the IP.OF.YOUR.PI/skyaware (enter) and your pi should be visible in that tab window
Hope this helps…
KB4ERT

I’m a brand newby too, Just got my kit from ebay yesterday, and got it online last night after several false starts.

The advice to hook up your Pi to a monitor is good. I’d still be messing around with trying to get functioning and claimed without one. The screen, once FA software has started will tell you what your feeder’s IP on your local system is. .

None of the ‘automatic’ claim links worked for me, but below where the Pi screen tells you your IP address, it will have another URL that tells you where to go to claim. It will be something like : https://flightaware.com/adsb/piaware/claim/ xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx (replace the xs with numbers and letters from your pi screen) From another computer on the same network, go to that url, wait a few minutes and your device should claim.

I had a hard time with that, because I am using just a 10 inch monitor on the pi and the ‘e’ in the serial number looked like a ‘c’, even under a magnifying glass. After about the 10th attempt, I decided to try changing it to an ‘e’, and it finally worked.

As an aside, I’m not thrilled with the eBay kit. The supposed ‘2 amp’ power supply only puts out a half amp. I kept getting under voltage warnings until I replaced it with a high quality 1A USB charger.

And the orange dongle (receiver) has poor sensitivity and takes many minutes to connect with the system. I replaced it with my old, cheap NooElec sdr dongle and got three times the range, and it connects in seconds instead of minutes.

Just checking, but you are talking to FA with a computer on the same network - not ‘say’ a browser on your phone?

ignoring the radio-side, both dongles use the same chip on the USB side, so there should be no difference how long it takes to connect.
On the RF side, they both have pre-amps, but the orange stick doesn’t have a filter.
What you may be seeing is the receiver being overloaded by out of band signals causing to appear deaf.

That’s depressingly common.

ignoring the radio-side, both dongles use the same chip on the USB side, so there should be no difference how long it takes to connect.
On the RF side, they both have pre-amps, but the orange stick doesn’t have a filter.

Indeed, I realize they have the same chip, and am at a loss to understand why it takes so long, but it does, tested several times.

I do have the separate blue filter 1090 filter, but not using it, I get better performance without it, despite having a 1 watt AV transmitter about 400 yards away for a surveillance camera.

Yikes, that is right in the middle of the heavily regulated air navigation band, you really don’t want to transmit on that (and if that is out-of-the-box equipment I’m surprised it will even let you transmit there) - this is “interfering with safety-critical equipment” levels of badness.

Wow, I no idea of that situation… I went and shut the whole system down. Will have to re-think the security coverage for that area. I didn’t want to run and bury wire that far, but it looks like I’ll have to.

On the bright side, I was using a highly directional patch antenna, so I doubt much signal got out of my little valley