FlightAware Discussions

Site local IP address change with new Pi


#21

My guess is you still have an intermittent connection to fix.
But that is more likely to be either a problem with the router or the cable or whatever, not really sure.

Regarding that intermittent connection could you post the output of this command:

sudo journalctl -u dhcpcd -en100

#22

I confirmed that I am also feeding 360Radar. Here’s the output you asked for:

Logs begin at Wed 2019-02-06 19:18:12 GMT, end at Wed 2019-02-06 20:04:57 GMT. –

Feb 06 19:18:14 raspberrypi systemd[1]: Starting dhcpcd on all interfaces…

Feb 06 19:18:14 raspberrypi dhcpcd[348]: dev: loaded udev

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: starting wpa_supplicant

Feb 06 19:18:15 raspberrypi dhcpcd[348]: eth0: waiting for carrier

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: waiting for carrier

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: carrier acquired

Feb 06 19:18:15 raspberrypi dhcpcd[348]: DUID 00:01:00:01:23:7d:95:f4:b8:27:eb:ee:87:69

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: IAID eb:ee:87:69

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: adding address fe80::3fd3:e04d:b618:199a

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: carrier lost

Feb 06 19:18:15 raspberrypi dhcpcd[348]: wlan0: deleting address fe80::3fd3:e04d:b618:199a

Feb 06 19:18:15 raspberrypi dhcpcd[348]: eth0: carrier acquired

Feb 06 19:18:15 raspberrypi dhcpcd[348]: eth0: IAID eb:bb:d2:3c

Feb 06 19:18:15 raspberrypi dhcpcd[348]: eth0: adding address fe80::cd0c:6630:7b83:36df

Feb 06 19:18:16 raspberrypi dhcpcd[348]: eth0: rebinding lease of 192.168.1.203

Feb 06 19:18:16 raspberrypi dhcpcd[348]: eth0: soliciting an IPv6 router

Feb 06 19:18:20 raspberrypi dhcpcd[348]: eth0: probing address 192.168.1.203/24

Feb 06 19:18:25 raspberrypi dhcpcd[348]: eth0: leased 192.168.1.203 for 172800 seconds

Feb 06 19:18:25 raspberrypi dhcpcd[348]: eth0: adding route to 192.168.1.0/24

Feb 06 19:18:25 raspberrypi dhcpcd[348]: eth0: adding default route via 192.168.1.1

Feb 06 19:18:25 raspberrypi systemd[1]: Started dhcpcd on all interfaces.

Feb 06 19:18:29 raspberrypi dhcpcd[528]: eth0: no IPv6 Routers availab


#23

Strange. Hmm maybe all is well now. Good luck! :wink:


#24

Sometimes the WiFi can be finicky, especially in crowded environments. In my house I can “see” approx 20 other routers in 2.4GHz band (even the electrical power meters have WiFi, to be read while driving a truck on the street) . And only another one in the 5GHz band.
That’s why I connected my Pi with ethernet cable now.


#25

SoNic, that’s why I didn’t (as far as I know) initiate wifi when setting up the new Pi. I have a similar number of routers locally.


#26

You are lucky. My WLC can see 120 odd 2.4Ghz WAPs and maybe a dozen on 5Ghz,
Thankfully some of them are just city buses that go past with onboard wifi.


#27

My experience with wifi is that using it is inviting trouble. I never use it on my Pi, except when testing a WiFi dongle.

I normally use wired network, which is headache free and performs very good. When at home, I even connect Laptop by a network wire to get good speed and smooth operation.


#28

And helps avoid any potential MITM problems.