FlightAware Discussions

Remote DUMP1090/978 access via website?

Is it possible to take a copy of what my Pi is receiving from home on DUMP1090/978 and host it on a website? For my own personal use, I have dynamic DNS and SSH tunneling setup to view the maps on my Pi remotely that way. However, for public access I’d rather have people go through my website rather than opening ports on my router and eating my home bandwidth and Pi resources. Anyone ever done this? Thanks!

You can run dump1090 in net-only mode.

At least for dump1090-fa i’ve made some scripts that you can take a look at if you want:
https://github.com/wiedehopf/combine1090#combine1090

I’m sure you’ll figure it out.

Just in case you don’t want to spend about 15 kByte/s on the beast-data from port 30005 you can copy over the aircraft.json file in intervals. (data volume limited connection)
I’ve made some scripts for that as well but they are more for personal use, so they are not documented. (https://github.com/wiedehopf/mirror-json)

1 Like

I’ll give it a shot. Thanks for the info!

I’ve installed DUMP1090-FA and COMBINE1090 on my Ubuntu VPS. I edited the /etc/default/combine1090 file to point the source at my Pi and the port at 30005 which I’ve opened the port for on the router. It keeps telling me that 127.0.0.1:29004 (which is specified as the target in the config file) is “connection refused”. Is that the port that the web server will be using or something else? I was thinking the source was my Pi at home and the target was the Ubuntu server but not sure what to put there.

The other issue is that I’m guessing dump1090-fa is using lighttpd while my regular web server is using Apache. I’ve set aside a subdomain of my main server but not sure how to get combine1090 to go there rather than a special port. Any thoughts? Thanks!

edit /etc/lighttpd/lighttpd.conf and change the server port so lighttpd and apache can run at the same time.
you can also use apache you’ll have to google this forum, there are some configs for apache published. note that the data directory needs to point at /run/combine1090 instead of /run/dump1090-fa

29004 is the port of dump1090-fa started in net-only mode on the machine running combine1090.

Show the log please.

and show this log:
sudo systemctl -e -u combine1090-dump

edit: meant
sudo journalctl -e -u combine1090-dump

I think the whole thing is messed up. I don’t have a /run/combine1090 or /run/dump1090-fa. I tried running your command and it gave me an invalid option ‘e’. The only way I could get dump1090-fa to install was to use the script from adsb-receiver. It never would install any other way so I’m thinking it’s in a different directory than /run. It’s showing me that dump1090-fa is here:

/root/adsb-receiver/build/dump1090-fa/dump1090

dump1090-fa has an error when I look at the log:

dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2019-06-17 20:37:53 CDT; 5s ago
Docs: https://flightaware.com/adsb/piaware/
Process: 20798 ExecStart=/usr/share/dump1090-fa/start-dump1090-fa --write-json /run/dump1090-fa --quiet (code=exited, status=1/FAILURE)
Main PID: 20798 (code=exited, status=1/FAILURE)
Jun 17 20:37:53 bears systemd[1]: dump1090-fa.service: Main process exited, code=exited, status=1/FAILURE
Jun 17 20:37:53 bears systemd[1]: dump1090-fa.service: Failed with result ‘exit-code’.

Here’s the combine1090 log:

combine1090.service - combine1090 - redirect beast data
Loaded: loaded (/lib/systemd/system/combine1090.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2019-06-17 16:30:52 CDT; 4h 8min ago
Docs: https://github.com/wiedehopf/combine1090
Main PID: 10178 (combine1090.sh)
Tasks: 3 (limit: 1096)
Memory: 1.8M
CGroup: /system.slice/combine1090.service
├─10178 /bin/bash /usr/local/bin/combine1090.sh
├─10181 /bin/bash /usr/local/bin/combine1090.sh
└─20921 sleep 6.0
Jun 17 20:35:52 bears combine1090.sh[10178]: 2019/06/17 20:35:52 socat[20702] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:36:07 bears combine1090.sh[10178]: 2019/06/17 20:36:07 socat[20719] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:36:29 bears combine1090.sh[10178]: 2019/06/17 20:36:29 socat[20740] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:36:50 bears combine1090.sh[10178]: 2019/06/17 20:36:50 socat[20747] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:37:13 bears combine1090.sh[10178]: 2019/06/17 20:37:13 socat[20774] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:37:35 bears combine1090.sh[10178]: 2019/06/17 20:37:35 socat[20790] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:37:52 bears combine1090.sh[10178]: 2019/06/17 20:37:52 socat[20796] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:38:16 bears combine1090.sh[10178]: 2019/06/17 20:38:16 socat[20816] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:38:35 bears combine1090.sh[10178]: 2019/06/17 20:38:35 socat[20831] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused
Jun 17 20:38:54 bears combine1090.sh[10178]: 2019/06/17 20:38:54 socat[20846] E connect(6, AF=2 127.0.0.1:29004, 16): Connection refused

Not sure what settings I should have for dump1090-fa. I’m thinking if I can get that to run then maybe combine1090 would be able to connect to it and do its thing.

Thanks!

I appear to have Apache working with DUMP1090-FA anyways. It doesn’t see the data of course but at least the map shows up! :slight_smile:

Here is my test site.
https://planes.k9swx.com/

Now if I could just get it to talk with combine1090… Baby steps!

I reinstalled your script and now I have the /run/combine1090 folder. I’ve changed the Apache setup to point at it and now I’m getting a forbidden error. I did chown -R www-data:www-data combine1090 but no luck. Should /run/combine1090 look like the dump1090-fa folder cause I’m not seeing all those files in there.

-rw-r–r-- 1 www-data www-data 65 Jun 17 21:09 aircraft.json
-rw-r–r-- 1 www-data www-data 65 Jun 17 21:07 history_0.json
-rw-r–r-- 1 www-data www-data 65 Jun 17 21:07 history_1.json
-rw-r–r-- 1 www-data www-data 65 Jun 17 21:08 history_2.json
-rw-r–r-- 1 www-data www-data 65 Jun 17 21:08 history_3.json
-rw-r–r-- 1 www-data www-data 65 Jun 17 21:09 history_4.json
-rw-r–r-- 1 www-data www-data 57 Jun 17 21:09 receiver.json
-rw-r–r-- 1 www-data www-data 3123 Jun 17 21:09 stats.json

I get

Forbidden

You don’t have permission to access / on this server.

Apache/2.4.38 (Ubuntu) Server at planes.k9swx.com Port 443

Yeah there is no index.html file in that folder which I think is why it is giving that error. It worked when I pointed it to dump1090-fa but that has an index.html and a bunch of other files. Almost wondering if I’m supposed to copy everything from that folder to the combine1090 folder.

I copied all the HTML files over from /usr/share/dump1090-fa/html but still getting the access denied. I’ll keep tinkering!

Fixed the permissions problem! Had to modify the /etc/apache2/apache2.conf file and add /run/combine1090 to it. Now to get the data feed working!

Rebooted the Pi and the web server and everything I put in /run/combine1090 is gone which has brought back the forbidden error. I wonder what folder it should be looking at for the dump1090-fa stuff? On the data side, it looks like that is working as there are multiple history.json files in /run/combine1090 with data so that’s good! Just need to figure out how to get it to talk to the map.

I figured it out! Took me a few reads of your initial reply where you mentioned data directory. I had to add this to my apache conf file.

Alias “/data” “/run/combine1090”

It’s alive! Thanks for letting me ramble and talk it out on here. Thanks for the nice script as well!

this was the command i meant for checking the log:
sudo journalctl -e -u combine1090-dump

Yeah the /run directories are created with the services when they are started.
They are cleaned up when the service or computer restarts.

Didn’t the example for apache have 2 alias, one for data and one for the hmtl/javascript?

Anyway for non Raspberry Pi installations on non-arm computers you need to compile it yourself.

It did but I wasn’t paying attention to it at first. I was just excited that the map was loading and not getting the forbidden error.

It appears I need to figure out MLAT now. I don’t think my Pi is listening on the port that you have listed in your script. Is the default 30105? I’ll have to open the port on my router and try it out tonight.

piaware opens this port open by default for mlat results.
(30105)

I added port 30105 back to /etc/default/combine1090 and opened the port on my router. MLAT is working now. Thanks again for all your help!