FlightAware Discussions

Dump1090 --net-only

Hi, help please.
I’ve read various posts but cant seem to get this working so need a bit more hand holding…

Aim to run dump1090 on a PC (ubuntu) [ip:192.168.1.166] getting it’s data from dump1090 on a Pi [192.168.1.11]. The Pi is running fine. There was a dongle in the PC (for TV) and initially dump1090 claimed this (and consequently I can see the install is working and displaying aircraft). If I then set --net-only (by setting DEVICE=“none” in /etc/default/dump1090-mutability) and restart the service the aircraft go from PC. I’ve tried various permatations of nc and socat but am missing a key bit of information on how to get PC to show Pi’s aircraft.

Any help will be much appreciated

I don’t use the mutability branch, but this is what I got in my /etc/default/dump1090-fa :

#RECEIVER_OPTIONS="--device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"
RECEIVER_OPTIONS="--net-only --net-bo-port 0 --fix"
DECODER_OPTIONS="--max-range 360"
NET_OPTIONS="--net --oversample --phase-enhance --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-http-port 0 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104  --net-bo-port 30005"
JSON_OPTIONS="--json-location-accuracy 2"

The other Pi has to have the 30004 and 30104 ports open for listening.

In the rc.local (with execute bit set!) add those:

while true
    do
    	socat -d -u TCP:[source IP]:30005 TCP:127.0.0.1:30104
    	sleep 5
    done &
1 Like

I guess you want to use mutability and not -fa?

Anyhow if you understand scripting looking at https://github.com/wiedehopf/combine1090 could help you.

The installation is meant for dump1090-fa though.

Are you sure you have the beast input port configured in dump1090-mutablity?
(not familiar with how mutability is configured)

Then using socat to actually connect both pis should work. (you might need to install socat)
If you want a complete solution that starts on boots and can be restarted as a systemd service:
From the git repository get the following three files:
combine1090.sh --> /usr/local/bin/
combine1090.service —> /etc/systemd/system/
combine1090.default —> /etc/default/ and rename to combine1090

Then you can edit /etc/default/combine1090 to specify which ports from which IPs get forwarded where.

systemctl enable combine1090
systemctl start combine1090

Would then start the forwarding.

Now you just need to make sure that you open 29004 as a input port in whatever program you want to receive the data.

1 Like

@Akissack
have you tried just DEVICE=

@SoNic67 - Many thanks. I added your receiver and net options as extra arguments and ran your socat code… all working a charm. You’ve made me very happy

@wiedehopf - thanks, I had tinkered with this without success as part of my frustrations

@evangelyul - thanks, this has the same effect in that it claims the USB device

2 Likes

You can give that post a “heart” then :slight_smile:

BTW, check to see if you have this at the end of the NET_OPTIONS:

It’s relaying the data from 30104 to piaware and from there to the FA servers. It should be by default on the add-on installs, but doesn’t hurt to check.

1 Like

Those receiver and netoptions from sonic are for dump1090-fa. Glad it is working anyhow.

In case you installed my script, do you know where it went wrong? Or did you try to combine it with dump1090-mutability?
It does not combine into the main dump1090-fa but rather a second one reachable under /combine1090 on the ip-address.

I re-did my install using dump1090-fa today, still looking good. I am not saying there is anything wrong with @wiedehopf 's script, I was just using it from a position of ignorance and a broken system :frowning:

2 Likes