FlightAware Discussions

Problem fetching data from dump 1090

I know this might be a little redundant, for which I´m sorry. I only happened to disconnect my RPi for a second since I was changing my electric distro in my room. And now this happened. I am able to keep feeding but port 8080 is showing nothing and I receive

Problem fetching data from dump1090. AJAX call failed (error). Maybe dump1090 is no longer running? The displayed map data will be out of date.

RPi IP is the same…nothing else happened. Any thoughts? I am using a Pro Stick Plus.

Thanks

Most likely, the ip address changed. Second most likely would be to try [ip address]/dump1090-fa instead of :8080

Most likely Local IP address has changed.

Click this link while you are logged-in to your Flightaware Account

https://flightaware.com/adsb/stats/user/

 

Your “My ADS-B” page (similar to my “My ADS-B” page shown below) will open which will show your current Local IP address

Connection to the stick could have been tripped, or otherwise the receiver is no long sending messages. Go to “My ADS-B”, click the gear icon to open Site Configuration popup. Near the bottom there is a section “Log”. Scroll to the end. You may see some clues.

What is the output of this command?

journalctl -e -u dump1090-fa

 

Same here start a fresh install and after a few days dump1090 didn’t work.

After a restart of the pi it works for a few days again but then dump1090 stop working.

That’s typically power issues.

sudo dmesg --ctime | grep voltage

No output means the power is fine … pretty much any other output means: get a proper power supply.

But yeah check the dump1090-fa log as well:

sudo journalctl -u dump1090-fa | tail -n30

@wiedehopf

sudo dmesg --ctime | grep voltage

There’s no message, so you write that’s good.

On:

sudo journalctl -u dump1090-fa | tail -n30

Nothing wrong as I see.

Or did you mean to check if the issue is happening?

I am having the same problem,
Problem fetching data from dump1090.
AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
The displayed map data will be out of date.
Have tried restarting Pi with no luck and the message on the Log is
no ADS-B data program seen listening on port 30005 for 190 seconds, next check in 60s
I got this when I tried changing the aerial this morning.
Any ideas??.

Chris

Same problem description … same things to check, log and voltage, see my post above for the commands.

Yeah you’d need to check when it’s happening.

You could try my readsb fork and see if it handles the error condition better than dump1090-fa (mostly a guess so no guarantees: Automatic installation for readsb · wiedehopf/adsb-scripts Wiki · GitHub).
I don’t think the piaware sd-card image would like removing dump1090-fa so … in that case i wouldn’t recommend it. On the other hand removing readsb and reinstalling dump1090-fa wouldn’t be hard either if it doesn’t work so … shouldn’t hurt to try.

I’d actually recommend everyone of the people with an issue that might have similar symptoms to nonetheless open their own thread as otherwise … this is going to get very confusing.

I would check your network connection on the Pi and make sure it’s stable. Try Ethernet if you’re on wifi.

The IP is still the same, and when attempting to log into 192.168.x.y/dump1090-fa it says that the URL does not exist

Hi! Nope, apparently is the same as previously assigned. It didn’t renew

Can you run sudo piaware-restart-network? After that, get the IP address from ifconfig and visit that URL again.

This is what I got

You have some other software that is using the SDR.

Are you trying to do 978?
That would require a second SDR.

Could also be fr24feed or rbfeed when configured wrong.
Or anything else that uses the SDR.

Let’s see what’s using the SDR then, my bet is on rb24 or fr24.

pgrep -af dump1090
grep receiver /etc/fr24feed.ini
grep network_mode /etc/rbfeeder.ini 

Yes I am feeding also to rb24, FR24, ADSB Exchange. But didn’t experience any issues for around a month. I am only doing 1090, and the only dongle I am using is the Pro Stick Plus. The only thing I did was disconnect the Rpi for about a minute since I was switching its position

So … fr24feed and rbfeed are configured correctly.
adsbexchange is only the mlat-client … that’s not dump1090
The openskyd feeder doesn’t grab the SDR i believe.

Have you tried rebooting … it might just be hanging or something.

Also … remove the image it has rather precise coords in it.

Unplug the dongle, then after few minutes re-plug it and restart dump1090-fa.
Do you still get “Problem fetching data”?
If yes, then reboot Pi and check again.