FlightAware Discussions

Unable to access Dump1090 data

I have been able to access my Dump1090 data for the last 5 years or so without problems.

A few months ago, I upgraded my system to run on a Pi4 - again, all running smoothly since then, except that, today, all I can see is the standard page header - no map & no data. Running 3.8.1. All was OK the last time I looked at the map - sometime either late last week or earlier this week. I’m looking at < ip address:8080 >

I have rebooted the Pi but still no ‘proper’ access.

I have tried accessing using a Mac (with both Firefox & Safari), an iPhone (with Firefox) & a PC (Windows 10) with both Edge & Firefox. No difference - all give me the same response.

If I click on the cog symbol at the top of the page, nothing happens (not too sure if it should!).

Can someone advise, please, if something has changed in the software in the last week or so that would have this effect?

Thanks,
Graham

No software changes in the last week. Have you checked to see if the Pi’s IP address has changed?

No, the IP address hasn’t changed. It was the first thing I checked.

I’m still getting the page banner, the top blue buttons etc. & the altitude bar at the bottom of the screen & the column headers for the planes seen - I’m just not getting the map with plane positions, nor am I getting the list of planes currently visible.

I guess this means I’m getting the fixed data but not the live data to populate the screen.

Could be browser cache as well.
Have you checked your stats page, is it still producing data?

I assume you mean my browser cache. I always delete that on closing the browser, so no cookies or history are ever retained beyond the current session.

Yes, Flightaware is still receiving live data OK (my rank at this moment is 7652). I just can’t see any of it on my network!

So when trying to access that page, in the browser add /data/aircraft.json to the URL.

Check if you get that.

If you have SSH or local console access, check the lighttpd and dump1090-fa log:
https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands

The aircraft.json command gives a screen full of information about the planes that can be seen.

With the lighttpd command, I get:

A warning that plugin.c.190 (plugin mod_setenv) Cannot be loaded more than once (that’s the gist of it!)

lighttpd/conf-available/89-skyaware978.conf: 24: server-modules += ( “mod_setenv” )
lighttpd/conf-available/89-dump1090-fa.conf: 24: server-modules += ( “mod_setenv” )

With the dump1090 command, I get:

piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization)
piaware dump1090-fa[535]: Thu May 7 dump1090-fa 3.8.1 starting up
piaware dump1090-fa[535]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
piaware dump1090-fa[535]: Detached kernel driver
piaware dump1090-fa[535]: Found Rafael Micro R820T tuner
piaware dump1090-fa[535]: rtlsdr: enabling tuner AGC
piaware dump1090-fa[535]: Allocating 4 zercopy buffers
piaware dump1090-fa[535]: Detected Kernel usbfs mmap() bug, falling back to buffers in userspace

(Hopefully I copied that lot across correctly)

I’m afraid I’m not sure what that lot is telling me, so hopefully you do.

For SkyAware that shouldn’t be an issue. (tar1090 would fix that issue because it can’t work properly with that issue)

That means it should be working.
Can you open the browser console?
In Firefox that’s Ctrl-Shift-K
In Chrome press F12 then click on the console tab in the thing that opened.

Post a screenshot of that after accessing the page.

(NB This was using the Screenshot app on my Mac, so may be slightly different to what you asked for)

Would need to see the F12 console output, given the complete lack of map tiles and none of the placeholder elements being filled in I’d guess that’s something is failing very early on.

Screenshot 2020-05-07 at 18.01.41

looks like corrupted files or filesystem to me

1 Like

I’d agree.

Get a new sd-card, put piaware on it.
This might be useful: For Beginners - How to Get Back Existing Station Number in A Fresh Install

As an interim, you can try this:

sudo apt purge -y dump1090-fa
sudo apt install -y dump1090-fa

Might create more problems though if the sd-card is dying, so might stop feeding data.

OK, thanks both.

I’ll sort something out tomorrow. Main thing is that it is currently feeding data to Flightaware.

Replacement SD card flashed & it’s now running as it should.

Thanks for the suggestions - I hadn’t thought of the SD card being the weak link - it’s a fairly new card.

Graham

I bought a brace of Raspberry 3B plusses last year. They are exactly the same and are doing exactly the same job. One of them suffered a card failure after a few months while the other one is going great guns.

No rhyme nor reason to it.

I’ve also had odd instances of failure but it’s usually been that I haven’t been able to write to the card & usually after the cards have been over a year or so old. Some makes are more prone to failing than others, especially with the RPi.

Fortunately I keep a small stock of micro SD cards - they’re so cheap these days, I’ve found it’s the safest thing to do, so replacing the card wasn’t a big problem - the hardest part was connecting via ssh from my Mac (I never did manage, even after using raspi-config, so had to connect up a Pi where I could work on it - again not a big deal as I have more than one Pi4 to play with).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.