FlightAware Discussions

Problem after updating to piaware 5.0

Hello, I have been feeding for a couple of years now and recently had to replace my pi when it gave up. I replaced the pi and at the same time I flashed a new microSD card with Raspbian Buster lite and then updated to piaware 5.0 [I have previously been running Raspbian Jessie and piaware 3.6.3]
All seems to have gone OK and I can see my feed is working okay the only slight problem I have is that my feeder page is still telling me that I am running 3.6.3 [even though I’m not] I thought initally it might have been something like my feeder page not updating due to a cache issue but I’ve even tried signing in on other browsers and it’s still the same. I have a message saying my feeder needs updating to Ver 5.0 as it is on an old version.
Looking at all the data on my feeder page, I think I’ve figured out what the problem may be, the MAC address shown is still the MAC address of my old pi [not the new one] but I have no idea how to change my MAC address in piaware to reflect this? anyone got any ideas please? I’ve sent a message to Flightaware to ask about this but had no reply.

The new installation will have created a new receiver ID. You need to set it to the one from your old installation. Have a read of this thread: For Beginners - How to Get Back Existing Station Number in A Fresh Install

Also this thread might be useful for future reference: Re-imaging Made Easy

Thanks for the reply, it hasn’t created a new ID as I pasted in my my unique ID as per the instructions in the link that you posted when I initially did the new set-up and indeed that is correct on my user page, it is only the MAC address that is incorrect, being the MAC address of the previous pi I was using, which is why I think it still thinks I’m using 3.6.3 rather than 5.0?

That method has been discontinued, you probably have to wait for support to fix that.

Not sure if claiming would do anything: PiAware - Claim and Link a Brand New PiAware Ground Station - FlightAware
But if it did anything it would likely be a new station.

As far as i know the MAC-Adress is used by Radarbox24 only. I reinstalled my feeder the other day and got automatically the ID back without configuring it

For all others i always needed to add my existing ID

Look at /var/log/piaware.log, it will tell you what feeder ID / site ID it connected as.

Piaware does not use the MAC address to identify the feeder.

1 Like

I’d say your old pi is still running or you have the old micro sd-card in use:
Runway2406 ADS-B Feeder Statistics - FlightAware

Maybe check locally on the pi what the version is…

piaware -v 

Also make sure the old pi is no longer running? :slight_smile:

1 Like

Definitely not still the old pi running as I have it here in front on me and it is not even plugged into anything [not power or any antenna/flightstick etc]

The new pi has a completely new micro SD card, which I flashed with a new version of Raspian [Buster lite] and then the piaware 5.0 image [the same unit is also feeding Planefinder and FR24]
When I checked your command piaware -v it does show as running version 5.0

I’m really at a loss to know why my page shows my feeder as needing upgrading to the new version and is still showing that I’m running piaware 3.6.3 on Raspian Jessie? My actual skyaware feeding page when I look at it shows version 5.0,

Look at /var/log/piaware.log , it will tell you what feeder ID / site ID it connected as.

Piaware does not use the MAC address to identify the feeder.

When I try and enter that command I get “permission denied”, is there anything I need to enter before that command? Thanks.

Well this is all very strange, now suddenly in the last few minutes my feeder page has updated and now it finally shows I am on piaware 5.0 and my feeder page no longer states my station is running an old version. Not sure what happened but thanks guys for helping out with suggestions, I’m still on a learning curve using my pi but I’ve got more time to play around with it going forwards…

Try less /var/log/piaware.log to view the log (> to go to end of file, q to exit)