FlightAware Discussions

Re-imaging Made Easy

When anyone re-images microSD card with latest image, the re-imaging itself (using balena-etcher or win32diskimager) is not difficult, but people face difficulty in configuring it. Another discouraging factor is to reinstall and configure feeders of other sites. However if you follow instructions below, re-imaging is not as difficult as it seems

NOTE: It is strongly recommended to use a SPARE microSD card to make a fresh install. This way your existing install will be preserved and you can fall back on it if fresh install fails or you decide to quit before finishing the fresh install.

STEP-1: Retrive & Save Feeder Keys

Before you write fresh image, retrieve feeder keys from existing image, copy-paste and save these in Notepad on your desktop/laptop.

1.1 - Piaware feeder-id

Following command will print feeder-id

cat /var/cache/piaware/feeder_id
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx

1.2 - Plane finder share-code

Give following command

cat /etc/pfclient-config.json

It will output following long line. Your Planefinder sharecode is the last item zzzzzzzzz in this long line

{"tcp_address":"127.0.0.1","tcp_port":"30005","select_timeout":"10","data_upload_interval":"10","connection_type":"1","aircraft_timeout":"30","data_format":"1","latitude":"xx.xxxx","longitude":"yy.yyyy","sharecode":"zzzzzzzzzzzz"}

1.3 - Flightradar24 key:

Give following command

cat /etc/fr24feed.ini  

Following line in output of above command has your fr24 key:

fr24key="xxxxxxxxxxxxxxxx"

1.4 - Radarbox24 key:

Give following command:

cat /etc/rbfeeder.ini  

Following line in output of above command has you RB24 key

key=xxxxxxxxxxxxxxxxxxxxxx

 

STEP-2: Write image to microSD Card

OPTION-1: How to Install and Configure Piaware 4.0 SD card image - Quickstart Guide

OPTION-2: [Package Install] How to Install and Configure Piaware on Raspberry Pi OS Image / RPi

 

STEP-3 : Install & Configure Feeders

3.1 - Planefinder

3.1.1 - Create new blank file /etc/pfclient-config.json by following command:

sudo nano /etc/pfclient-config.json

3.1.2 - In new blank file, copy-paste following code
(Replace xx.xxxx by your latitude, yy.yyyy by your longitude, and zzzzzzzzzzzzz by your Planefinder key)

{
"tcp_address":"127.0.0.1",
"tcp_port":"30005",
"select_timeout":"10",
"data_upload_interval":"10",
"connection_type":"1",
"aircraft_timeout":"30",
"data_format":"1",
"latitude":"xx.xxxx",
"longitude":"yy.yyyy",
"sharecode":"zzzzzzzzzzzzzzz"
}

 

3.1.3 - Save file (Ctrl+O) and close file (Ctrl+x)

 

3.1.4 - Now install Planefinder feeder by following commands
(Latest feeder released on January 20, 2021)

wget http://client.planefinder.net/pfclient_4.2.70_armhf.deb 

sudo dpkg -i pfclient_4.2.70_armhf.deb 

At the end of installation, the installer will ask if you want to install new version of config file or keep the current version (i.e. the config file you have created). The default choice is to keep copy created by you. Press Enter key to accept default (keep current version).
On pressing Enter Key, the installer will announce that installation is completed.

pfclient-config.json

 

3.1.5 - Go to following address in your browser to see the map

IP-of-Pi:30053

3.2 - Flightradar24

3.2.1 - Create new blank file /etc/fr24feed.ini by following command:

sudo nano /etc/fr24feed.ini

3.2.2 - In new blank file, copy-paste following code
(Replace xxxxxxxxxxxxxx by your fr24 key)

receiver="beast-tcp" 
fr24key="xxxxxxxxxxxxxxxx" 
host="127.0.0.1:30005" 
bs="no" 
raw="no" 
logmode="1" 
logpath="/var/log/fr24feed" 
mlat="yes" 
mlat-without-gps="yes"

 

3.2.3 - Save file (Ctrl+O) and Close (Ctrl+X)

 

3.2.4 - Next install FR24 feeder by following command

sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"  

As you have already created the config file, the installer will by default keep it, and show following output

image

 

When installation is finished, the installer will start the configuration. As you already have created configuration file in step (1), don’t proceed, instead break the process by pressing (Ctrl+C).

image

3.2.5 - Now restart fr24feed

sudo systemctl restart fr24feed 

3.2.6 - Wait for 5 minutes, then check status

fr24feed-status

It will show status similar to tthis

[ ok ] FR24 Feeder/Decoder Process: running.
[ ok ] FR24 Stats Timestamp: 2020-12-30 19:41:08.
[ ok ] FR24 Link: connected [UDP].
[ ok ] FR24 Radar: T-CYYZ52.
[ ok ] FR24 Tracked AC: 29.
[ ok ] Receiver: connected (64993 MSGS/0 SYNC).
[ ok ] FR24 MLAT: ok [UDP].
[ ok ] FR24 MLAT AC seen: 26.

3.3 - Radarbox24:

3.3.1 - Create new blank file /etcrbfeeder.ini by following command:

sudo nano /etc/rbfeeder.ini

 

3.3.2 - In new blank file, copy-paste following code
NOTE: In code below, replace:

  1. kkkkkkkkkkkkkkkkkkkkkkkkkkk by your RB24 key
  2. xx.xxxx by your Latitude
  3. yy.yyyy by your Longitude
  4. zzz by your Altitude above Sea in meters

 

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=kkkkkkkkkkkkkkkkkkkkkkkkkkk

lat=xx.xxxx
lon=yy.yyyy
alt=zzz


[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true
#mlat_cmd=/usr/bin/python3.7 /usr/bin/mlat-client

[dump978]
#dump978_enabled=true

 

3.3.3 - Save file (Ctrl+O) and Close (Ctrl+X)

 

3.3.4 - Next install RB24 feeder by following command

sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"

As you have already created the config file, the installer will show following output. Press Enter Key to accept the default (i.e. keep the file you have created)

rbfeeder.ini-1

Next it will ask if you want to install dump978-rb (requires extra dongle). To say NO, type n and press Enter Key.

rbfeeder.ini-2

The installer will now announce rbfeeder has been installed.

 

3.3.5 - Next install mlat-client by following command

sudo apt-get install mlat-client   

 

3.3.6 - Reboot Pi and check status

sudo reboot   

sudo systemctl status rbfeeder   

 

3.3.7 - Check your stations status Map (replace xxxxxx by your 6-digit station number)

https://www.radarbox.com/stations/EXTRPIxxxxxx

image

 

 

3.4 - Graphs by @wiedehopf

3.4.1 - Install graphs

sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/graphs1090/master/install.sh)"   

 

3.4.2 - To update data

sudo /usr/share/graphs1090/graphs1090.sh 24h  

 

3.4.3 - To Make all graphs full width
By default some graphs occupy full width of page (1 graph per row), while some other occupy half width (i.e. 2 graphs in one row). To make all graphs full width, do this

sudo nano /etc/default/graphs1090  

Scroll down and change:
all_large=no
to
all_large=yes

Then run:
sudo /usr/share/graphs1090/boot.sh

Go to IP-of-Pi/graphs1090/ and reload browser (Ctrl+F5)

 

4 Likes

Thank you very much. Great tutorial.

Would it be an idea to add Opensky network as well?

@abcd567 Thanks for this.
I will be doing this soon when I re-build my pi with an SSD drive. I just did the process 3.4.3 to make graphs full-width and nothing happens. Any ideas?

I have installed graphs over a year ago, and on that version changing all_large=no to all_large=yes works ok. May be in later version of graphs the width function has been disabled.

@wiedehopf will be able to answer this.

 

P.S.
May be you forgot to save the file after making changes. Please check the file what is there now, all_large=yes or all_large=no?

My mistake, I was ssh’d into my other ADS-B pi when I edited graphs1090 but was checking the graphs for the other pi :grin:.

2 Likes

re-imaged and updated a while back, just did another update (apt-get update and apt-get upgrade) and no rb24. re-installed the rb24 and now I am not reporting planes on Flightaware, but RB24 works… Must have installed the full rb24 in error? Flightaware is still working but nothing showing on the map for ADSB or UAT.
Likely need to change a port somewhere. Any idea which one?
Tnx…

CONFLICT. One dongle two dump1090 trying to grab.
dump1090-fa and integral (hidden) dump1090 of rb24

Check settings of rb24 feeder

sudo nano /etc/rbfeeder.ini

Disable rb24’s dump1090, by making sure that under [client], the network_mode=true. Now dongle will be used by dump1090-fa.

[client] 
network_mode=true

To enable RB24 to get data from Flightawsre’s dump1090-fa, settings under [network] should be as follows:

[network] 
mode=beast 
external_port=30005 
external_host=127.0.0.1
2 Likes

Thank you abcd567
There we go.
network_mode=true was the culpret.

Now maybe a completely different problem I think…
I realize I am not getting any UAT 978 messages last three days. Found a bad red Radarbox flightstick on the main feeder. Replaced it with a standard SDR stick which shows up good, but no data on 978 mHz.
My second feeder is also showing no data on 978 with a good USB dongle.

Both these feeders have dongles powered by a seperate power supply and both test good at just over 5v under load using my modded USB connector and voltmeter. Something else to track down. Did some rpi Flightaware updating on Sunday so might be the issue, just have to figure out what broke…
These are two RPI3Bs.

edit:
Got UAT working on both following updates and a reboot. Logging lots of activity in ND today on 978. Flight school at GFK (UND) keeping my numbers up! :slight_smile:

2 Likes

STEP-2: Write image to microSD Card

But you don’t tell us to move the microSD card to the Raspberry Pi and boot.
At this point, I have the microSD card mounted in an Ubunut box where I have a good backup of the working Pi, so I can copy the other “save” files to where they need to be, but I’ll have to move the microSD card to the Pi and reboot before installing anything.

STEP-2 provides links to two sets of instructions;

Both of these instructions contain the line

3 - Slip microSD card in RPi and Power up.

which you may have missed.

S.

1 Like

Ah. I had already built the image, and was only visiting here to get the instructions for reclaiming my former identity.

:grinning: Don’t you just hate that.

Hope you have everything sorted now.

Cheers,

S.

My PiAware is working, but I can’t do any OS updates.
I broke the OS horribly trying to add some Python package. The advice is to give up and start over, so that’s what I’m going to do.

(I thought I was still in the downloading and offline editing mode when I inadvertently started to install FR24 on the Ubuntu machine where I was prepping the card.)

I think I’m set to swap cards tomorrow.
From here on, I’m not going to install anything on the Pi except FlightAware and FlightRadar.

I have piAware running, reporting statistics properly.
I ran the script to install and run FR24, and it’s not happy.

Oops. Never mind I did a sleep 300 (as suggested after restart) and it wasn’t happy, but now, a minute or two later, it looks like I’m working okay.

pi@piaware:~ $ piaware-status
PiAware master process (piaware) is running with pid 648.
PiAware ADS-B client (faup1090) is running with pid 865.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is running with pid 945.
Local ADS-B receiver (dump1090-fa) is running with pid 848.

dump1090-fa (pid 848) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.

Your feeder ID is 63d96deb-ceb4-463b-918b-72b2884c0c70 (configured at /boot/piaware-config.txt:85)

pi@piaware:~ $ fr24feed-status
[ ok ] FR24 Feeder/Decoder Process: running.
[ ok ] FR24 Stats Timestamp: 2021-04-21 00:24:52.
[ ok ] FR24 Link: connected [UDP].
[ ok ] FR24 Radar: T-KSTS12.
[ ok ] FR24 Tracked AC: 8.
[ ok ] Receiver: connected (856 MSGS/0 SYNC).
[ ok ] FR24 MLAT: ok [UDP].
[ ok ] FR24 MLAT AC seen: 6.

I just went through this, initializing a new microSDcard.
I copied my previous fr24feed.ini, and it doesn’t match the suggested entries.
image

The key is obviously different, windowmode is meaningless, and I should probably turn on a logfile, but I didn’t have one before.

receiver=“beast-tcp” suggested, instead of receiver=“avr-tcp” confuses me. The FR24feed-manual says AVR-TCP if I already have a decoded running (like FlightAware?)

host="127.0.0.1:30005 I think I had set when I first installed a couple of years ago, and it didn’t work. I changed it to 3002 based on something in these forums.

Actually, it looks like it is using 30005 and not 30002, on tcp6
sudo netstat -anp | grep 30002


sudo netstat -anp | grep 30005

FlightAware is reporting my ADS-B statistics on the proper (old) ID.
Feeder Check-In: a minute ago

FlightRadar24 is showing my proper RADAR online three minutes ago.

Am I done?
Should I cahnge the port number and receiver type?