No ip address assigned (of course it's got to happen to me!)


#1

Hello all, so this summer I bought a pi and a dvb-t stick to set up a ais system for my sailboat (still working on that one :wink: ) and found out that you can also track planes, how cool, so after following the steps on pimylife I get this error message, I cant even get to see it on my laptop (before making it to the flightaware site) as it is shown in several youtube videos. So as you can see on the photo I have no ip address, why? the pi is connected to my laptop (via ethernet cable) , I am in Canada using Bell, nothing particular. What do I do wrong?

Beware, I am not a coder or a computer whiz, please explain this in simple terms, how do I assign an IP address to my piaware so I can then punch it into my browser and see planes.

Lets put a twist, could I do it via wifi instead?

In the photo I have not connected the receiver, but that made no differences.


#2

Did you follow the instructions here?


#3

You may need to turn on “internet connection sharing” or similar on your laptop (I don’t have any real experience with it though) if you want to route the Pi through your laptop to the internet.

That said, your Pi isn’t seeing the dvb-t dongle either…


#4

Yes or course, but before I make it to step 3 how could I be detected by flight aware if I have no ip address, wifi or line connections?


#5

I know about the dongle, It was not connected


#6

Can you explain what you’re trying to set up, exactly? You will need internet access for the local aircraft map to work (the map tiles are retrieved from the internet) and to allow uploading data to FlightAware. If you don’t have internet access available where the receiver is, then the piaware sdcard image is not really suitable.


#7

I saw a video on youtube that shows before registering to flightaware you can type the pi ip address into your internet browser and get some kind of a preview (this video at 2:30 : https://www.youtube.com/watch?v=1WD_dgjCBVc&t=165s)

This is what I wanna to do first!

But as you can see in the photo I posted in my original post, I have no ip address assigned, so I cannot enter it in my browser!

My laptop has high speed internet via wifi, so I do have internet. And once I have my pi connected to flightaware I would ideally prefer to communicate via wifi to upload data.


#8

Piaware will try to get an address via DHCP, which is a mechanism for assigning IP addresses automatically. You need something connected to the Pi that provides DHCP. Usually this will be provided by your router / modem. If you directly connect your Pi to your PC, there’s nothing providing DHCP on that network segment between the laptop and the Pi.

“internet connection sharing” may be the simplest way to make your laptop provide DHCP and let your Pi get an address, so that is probably the simplest thing to try first.

Or if you have a router that handles your WISP connection, you could just plug the Pi into that.

Or if you have a router / access point that’s providing your local wifi network, you can configure the Pi to connect to that by editing the file piaware-config.txt on the Pi’s sdcard (you can do this on your laptop); see step 3 at https://flightaware.com/adsb/piaware/build

Another option is to assign a static IP address to both the laptop’s ethernet interface and the Pi’s interface, but that requires some knowledge of how to set up networking.


#9

If you have a local wifi network I would take out the SD card and edit the file piaware-config.txt
The lines to modify are: “wireless-allow yes”, “wireless ssid”, and "wireless-password"
Put the SD card back into your pi and it should connect over wifi.

More PiAware Configuration information can be found here
https://flightaware.com/adsb/piaware/advanced_configuration


#10

Nice! this is in my realm, I will try and let you all know, thanks!


#11

David Baker, your the man, it took me 3 minutes and now it works. The epitome of simplicity.

Merci

Sam