New FlightFeeder does not acquire IP address


#1

Hi guys!
Just got a FlightFeeder version 10, and installed it yesterday. However, no matter what I do I can’t get it to acquire an IP-address from my DHCP server, either when connected through ethernet or WiFi. It does however show a green indicator on Network in both cases, and when connecting it to WiFi I can see it in my accesspoint as a connected device, however it doesn’t seem to be recognized by my gateway at all. I also tried giving it a static address outside of my DHCP range, but to no avail. To troubleshoot, I installed Raspbian on another SD-card I had laying around and chucked it in there, and low and behold, both wired and wireless connections worked perfectly instantly. This leads me to conclude it’s a software issue, not a hardware problem.

I have emailed the support address and asked if it’s possible to receive an image for the stock SD-card to see if that might help, but while waiting for the response I thought I might trow the problem in here too, to see if anyone knows of a solution or what the problem might be.

Thanks!
/The new guy.


#2

There is a FF GUI setting to turn on/off the wifi circuit.
It is under the tab for network -> then Wifi
If the wifi circuit it off then the wifi will not connect even with the correct login and password configuration.

If the Wifi is On then you might have the SSID and password not correct?

The other thing you can do is connect the box through ethernet and remote test can be done by someone at FlightAware.


#3

Thankyou David, unfortunately I have checked and rechecked everything many times, and as I said it connects to the WiFi fine, it’s just not recognized by my gateway and given an IP.
As I also mentioned, the issue is present both on WiFi AND Ethernet.


#4

This is odd since each FF is tested before shipping.
Your testing ruled out hardware problems and this looks like a software problem.

If you email adsbsupport@flightaware.com they will send you a link to the latest FF SD card image.


#5

Yeah, that’s what I’ve done, no response yet though. I guess I’ll have to be patient, but at the same time it’s hard when you get the automated messages complaining it’s not online yet…


#6

I think this will require remote diagnosis after hooking it up to wired ethernet.

Oh - misread - it fails on wired, too? and with a static IP? Very odd. If a static assignment worked, then it’s something that your DHCP server doesn’t like about the requests - some consumer routers are pretty bad at handling anything unexpected in a DHCP request - but if a static assignment doesn’t work then that’s strange. I assume you mean you’re assigning a static address via the FF’s touchscreen GUI?

Do you have another network environment you can try it in?


#7

Yeah, my thought was that I might have some sort of MAC address block going on or something, but all those settings in the gateway seemed to be turned off, and then trying it with Raspbian ruled that out too, since it worked instantly then.
I don’t know how my gateway handles devices with static IP-addresses, but one would think it shouldn’t be a problem as long as it’s outside of the DHCP range. Nontheless I couldn’t access it from the outside.

I might be able to experiment some more after work tonight, I should have a couple of old gateways laying around I could try connecting it too and see what happens. Didn’t think about that, thanks.


#8

Out of curiosity which static ip did you assign and which settings are assigned to your other computers?

You seem to know your way around networks still want to make sure you chose a static address from the same subnet otherwise it wouldn’t work.

Also with a static ip if you want the FF to have internet you will have to enter a gateway address too and maybe even a dns server.

What do you mean with “access it from the outside”?


#9

DHCP range is 192.168.1.100-149, so I gave it .99. I have fixed IP bindings in the lower range .10 to .40. Subnet mask is 255.255.255.0, and gateway is 192.168.1.1. DNS:s are set to googles throughout the network,

I might not be completely inept, but I am far from an expert. I am however pretty good at reading up on how to solve problems, and most importantly, not afraid to try things to learn how they work.


#10

Well, this is a little frustrating. I rummaged up an old Linksys WRT54, the classic WiFi-router everyone used to use back in the day. Did a hard reset on it and hooked up the FlightFeeder and my laptop to it, both through WiFi, and guess what; it worked flawlessly instantly. F**k…

No, to figure out why my $400 business gateway is being a grympy child and not accepting the flightfeeder is probably a different matter entirely…


#11

Found it. Release note from a firmware update on the router from 2016:

“- Fixed a DHCP server issue that caused Fedora Linux DHCP client not able to get an IP address from LRT.” (LRT is the name of the gateway)

Evidently I hadn’t updated the firmware since 2014 (although I have to say I thought I had), and they’ve released one a year since.

Anyhow, that solved it. Imagine that.