MAC/DHCP Reservation vs Static IP for FlightFeeder - I have a problem

Hi there,
I have a FlightFeeder set up very near the local airport at my friend’s place, in his garage. I want to monitor reception from there via VRS, but of course that entails having port forwarding for ADSB & MLAT set up. The ISP modem seems a little flaky and the homeowners have to reboot the modem periodically, which usually breaks my port forward setup. My issue is this: the ISP modem there does not seem to have MAC/DHCP reservation functional. I’ve tried numerous times but alas, I have finally given up…it just does not seem like it is going to work on this modem. (I have 5 other PiAware setups that all use a ‘Reservation’ methodology (router manufactures all seem to call it something different), but they all work.

So I tried another route: to set a static IP on the FlightFeeder. You can go through all of the steps on the built-in screen+ interface, but after everything is set up and seemingly saved…nothing ‘sticks’. It is like I never entered anything at all. I subsequently read on another forum post here from a FA mod dating back to 2014 explaining that static IP can’t be set of a FF, but that there is another way (which I can’t use as explained above):

<<<Just to clarify, the FlightFeeder does support a static IP if assigned by your router/DHCP server. You can set it up on your router/DHCP server via the MAC address printed on the bottom of the FlightFeeder.>>>

Assuming nothing has changed regarding the FA implementation of assigning a static IP (or lack thereof) since then, then that seems to be a non-starter.

One other option would be to hang a router off of the modem and run the MAC/DHCP reservation to the FlightFeeder from that router. That is not really desirable as the location of their modem makes it difficult to put a router any significant distance from the modem. The radio signal proximity is likely to be detrimental to the wifi coverage that exist now.

Anybody have any thought as to how I might rectify this situation? (Sorry, I don’t have the model # of the modem right now…thought I had a photo of it, but can’t find it)


You could ask if they are able to help with setting a static ip. At least you get a definite answer if it is possible or not.

If one of your feeders is a RPi, maybe it is possible to swap location? Setting a static on a RPi is easy.

Maybe there is a firmware update available for the modem that allows MAC address reservation?

With modem you mean a router with a modem, right?

If you have a second router available, why not use the old modem just a modem and let the new one handle everything else? Might actually be an improvement in other areas as well, not being able to reserve ips does not sound like a very modern device?

Out of curiosity, which DDNS-Service are you using?

1 Like

If you use a Raspberry Pi with Debian/Raspbian you may run into a problem as I did:

Setting a fixed address in /etc/network/interfaces.d/wlan0 works (example for my network

auto wlan0
iface wlan0 inet static
dns-search my.domain
wpa-ssid “myssid”
wpa-psk “mypassword”

But you have to disable dhcpcd, else your interface will get an additional dynamic address and that may cause trouble:

sudo service dhcpcd stop
sudo systemctl disable dhcpcd

He has a Flightfeeder, not a DIY station.

Setting a static IP on the FlightFeeder is possible. Please e-mail for assistance.

Thanks for the replies everyone. I’ve shot an email off to Hopefully I’ll find the resolve to setting a static IP.

To biekerc : Good suggestions.As mentioned, it is not my modem…it is my friend’s. The finally got a second, fairly reliable service (except maybe the modem part) available locally, which they went with. I don’t want to mess things up on them after their years of misery with the other service. I thought of it, but have (to this point) decided against it. MAC address reservation IS available on the current firmware build in the modem…it just doesn’t seem to work. The service was only installed through the community a few months ago and I would expect fairly recent firmware in the accompanying modem…but worth a check for sure. I use DDNS service.

thanks again