FlightAware Discussions

Flightaware Feed not worknig

I had my SD card on my Pi-W become corrupted so i reinstalled from the ground up, added my feeder unique ID and restarted. I have it set to static IP and am receiving data and seeing flights. However it’s not connecting to flightaware and shows off-line on the front screen.

I’ve confirmed the unique ID via flightaware.com and it matches what’s in /boot/piaware-config.txt. I’ve rebooted several times and can connect to it via SSH, and obviously the web browser at the static address.

Hardware was working before the Pi brown-out trashed the card and since I can see aircraft, it doesn’t feel HW related.

Any suggestions?

Have you set the default gateway correctly?

As a sanity check, grab a spare SD card and install a completely standard virgin image.
Add nothing to it (no ssh, static IP, no UUID - nothing)
Just plug it in and see what it does.

When you have convinced yourself that works, do one mod at a time, reboot and confirm it’s doing what it should.
When you reach your last mod, it’ll either still work or not and you’ll know why.

There are a couple of bugs still floating around with static IP config on buster. Do you have a nonstandard netmask? (not the same as the one implied by the IP address)

Two easy tests to find the problem

Firstly, SSH into the Pi

Enter the command ifconfig and press enter and copy and paste the result here so someone can check your settings.

Secondly, at the SSH prompt type in traceroute flightaware.com and press enter.

The output will tell you where the packets get lost and give a clue to the reason.

S

edit to fix spelling mistakes.

1 Like

Checked that and it looks ok using ifconfig. However the netmask was messed up somehow. when i built the first piaware-config I mis-typed it, now I can’t figure out which file is actually controlling it. I changed it there and restarted, but no change. I also changed dchpcd directly, but again no change.

I was able to get it to work by simply making the address dynamice and using my DHCP server to configure it, and it works. So it’s something in a corrupt configuration of the network.

I think my next step is as suggested in this thread - start with a new image and walk step by step, getting the static address configured and verified and then put piaware on top.

What is the lastest raspbian OS that current PiAware support? is there a “requirements” page that lists the supported OS versions? I can’t seem to find it on the support pages.

Thanks all for the help!

You can use the latest Buster image from https://www.raspberrypi.org/downloads/

Why don’t you assign the “static” IP via your DHCP-server? That way your device will get the same IP, even after reformat, since the MAC-address doesn’t change. I run all my network like that.

1 Like

On a piaware sdcard image, the settings in /boot/piaware-config.txt are used to generate dhcpcd.conf on boot.

However in the currently released image, the netmask config options are actually ineffective (there’s a typo in the dhcpcd config file that they generate, so they have no effect). This is only usually a problem if you have a netmask that’s not the normal netmask for the class of address you’re using. You can work around it by specifying the static address in a.b.c.d/N form, which will set both the address and netmask.