Newbie help - wifi


#1

G’day all

I’ve had my flightfeeder running wired for about 10 days and today tried connecting to wifi. I purhased a TPlink dongle (TL-WN725N) and put together a flightfeeder-config.txt file which is saved onto a plugged in USB drive. Unfortunately it doesn’t connect to FlightFeeder.

I have set the config file up as follows:

wired-network no
wireless-network yes
wireless-ssid **********
wireless-password ************
wireless-type dhcp

Am I needing to have anything else in my config file?

I’ve asked the support email question - hopefully I’ll get a quick reply from here or support so I can get it up and running.

Cheers! :smiley:


#2

Did it connect successfully to your wifi router? Check the router’s status pages and see if an IP address was assigned to the Foightfeeder. Also check you don’t have blanks or special characters in the password. If you do, then I think you have to put the whole thing in quotes, but I’m not sure on that.


#3

The router/modem says its connected but not using the internet. IP is fine too.
No blanks in the password so all OK there.
When I tried to get the FlightFeeder Info it comes up FlightFeeder | Radio | Network | GPS | MLAT
MLAT is ok - not too many receivers around here.
Trying again and it’s red across the board. FlightFeeder | Radio | Network | GPS | MLAT :confused:

Additional

Now FlightFeeder Info is looking like:
FlightFeeder | Radio | Network | GPS | MLAT
On the Skyview it comes up with a box showing:
Problem fetching data from dump1090.
AJAX call failed (timeout: timeout). Maybe dump1090 is no longer running?
The displayed map data will be out of date.

Additional additional: :stuck_out_tongue:
LED status on the adapter indicates that the driver has been installed but no data is being transmitted or received.


#4

you can try these settings, edit piaware-config.txt and substitute items as required:

wireless-network yes
wireless-type static
wireless-ssid yourSSID
wireless-password yourPassword
wireless-address 192.168.x.x
wireless-netmask 255.255.255.0
wireless-broadcast 192.168.x.255
wireless-gateway 192.168.x.x

HTH/brgds


#5

He has a Flightfeeder, not a Pi.


#6

yes, but…

The configuration file format is the same as PiAware 3.x advanced configuration

http://flightaware.com/adsb/faq#ff_wifi

so in essence the config file must be parameterized as above.


#7

There are a couple of different revisions of this and IIRC (I don’t have the details on hand) one or the other has problems out of the box on Raspbian.

If you leave wired-network yes and leave it on the wired network while leaving the wifi dongle in place then support can connect in remotely and take a look


#8

Much appreciated but it did not seem to help things.

My wifi router is a part of my AVM Fritz! Box modem which uses a 192.168.1##.* IP system. (Might be 178? I’m at work and don’t remember.) I had to change the IP addresses to suit the modem.

:question: What is the wireless-broacast setting? I can’t find it in my modem page or when I use ipconfig -all. I have used the .255 ip address as suggested.

:question: Do I need to spoof the MAC address at all as the wifi dongle has its own?

FYI - The Flightfeeder is type 7.7.1. It is now sitting in the garage as the antenna has been mounted outside. (Previously it was taped to the inside of the office window.) Wifi has been use as it was too far from the modem to connect with cable. I don’t have a monitor or keyboard.


#9

G’day all. I swapped out the TPLink wifi dongle with a new Edimax and all is good! Thanks to all who offered suggestions. Your help is very much appreciated. :smiley: